Sign in   |  Join   |  Help

Beomaster 1900 i need help with its repair

rated by 0 users
Not Answered This post has 0 verified answers | 4 Replies | 1 Follower

Camiloastu
Not Ranked
3 Posts
OFFLINE
Bronze Member
Camiloastu posted on Sat, Aug 28 2021 5:39 AM
I need help with my beomaster 1900, when I turn on only the function selector blinks and turns off, the volume remains on but the buttons do not work, can someone guide me in the repair ??? a big greeting !!!
I leave a video with the problem
https://drive.google.com/file/d/1-On-UppfStLIfKOyLJsQ6E51BObYdfLs/view?usp=sharing

All Replies

Dillen
Top 10 Contributor
Copenhagen / Denmark
13,044 Posts
OFFLINE
Founder
Moderator
Dillen replied on Sat, Aug 28 2021 7:53 AM

Unstability in power supply.
Bad capacitors, bad rectifier, bad lamps, faulty selector IC.
Or any combination.
All very common for a Beomaster that hasn't been restored yet.

Parts here.

Martin

Camiloastu
Not Ranked
3 Posts
OFFLINE
Bronze Member
Hello Martin, thank you very much for your help, I will start with the IC selectors,
the volume toch bonnets do not work from the panel. but if they respond when pressing the pin on the board. do you have any idea of ​​the problem?
Greetings.
Dillen
Top 10 Contributor
Copenhagen / Denmark
13,044 Posts
OFFLINE
Founder
Moderator
Dillen replied on Mon, Aug 30 2021 1:30 PM

Sounds like the front panel wasn't fitted correctly.
The small bronze forks under the touchpads need to grip their respective pins on the boards.

Martin

Camiloastu
Not Ranked
3 Posts
OFFLINE
Bronze Member
Hello Martin
Thank you again, I have reviewed the installation of the front panel and the small bronze forks hold their respective pins. 
I have tried touching the pins with a non-rubberized screwdriver and the system works, when testing the pins with a rubberized screwdriver the pins do not work.
do you have any idea of ​​the problem?

will I need some land?
a big greeting
Page 1 of 1 (5 items) | RSS
Beoworld Security Certificate

SSL