Sign in   |  Join   |  Help

Stage flashing red lights - not starting

rated by 0 users
Not Answered This post has 0 verified answers | 1 Reply | 0 Followers

Not Ranked
1 Posts
Bronze Member
freezer posted on Fri, Nov 20 2020 10:03 PM

Hi everyone, 

I bought a Stage online which got delivered today and I tried to set it up. After setting it up in the Google Home app it said that it had to be updated. After that it was "restarting" for a long time, nothing happened. I finally unplugged the Stage after about an hour.

Now all I get is flashing red light, the Stage cannot be found in the B&O app and the Google home app says the product is "outdated or needs to be reset". I tried pressing the settings button on the Stage to do a factory reset, but it's not working. The two lights simply keep pulsing red.

I have no idea what I can do? Is there any other way to reset the Stage?


All Replies

Top 50 Contributor
2,818 Posts
Bronze Member
Hiort replied on Sat, Nov 21 2020 5:06 PM
Flashing red lights indicate problem with WiFi connection.





Livingroom: BL3, BL11, BV11-46 Kitchen: Beosound 1 GVA, Beocom 2 Bathroom: M3 Homeoffice: M3, Beocom 2  Library: Beosound Emerge, Beocom 6000 Bedroom: M5, Essence remote  Travel: Beoplay E8 2.0, Beoplay P2, Beoplay Earset

Page 1 of 1 (2 items) | RSS
Beoworld Security Certificate