Sign in   |  Join   |  Help

Bang & Olufsen App 3.00 prod/beta

rated by 0 users
Not Answered This post has 0 verified answers | 70 Replies | 3 Followers

mbolo01
Top 75 Contributor
Annecy - France
1,636 Posts
OFFLINE
Gold Member
mbolo01 posted on Sat, Feb 8 2020 12:18 PM

Dear app users, here's is a summary of some issues/comments I could find in previous app versions related threads that are still valid with the new app iteration.
I may have missed some, or some have been fixed since, so feel free to update the list while keeping all the items grouped for better reading (copy paste with changes).

Hopefully someone in B&O still reads this forum and cares.

Issues (new, re-introduced and on-going):

  • iPad version: Cannot put products into standby individually, power icon missing per product. Power icon is only available for global standby action.
  • Cannot get the app to control BeoSystem 4500 and BeoSound 2300, each connected to an NL/ML converter.
  • Apps freezing when Internet access is not available while local network access to products is functional.
  • Now playing screen: moving forward/backward within a DLNA track does not work as it should
  • Now playing screen: when changing a DLNA track, album cover is not displayed back until now playing screen is minimized/maximized <-- Issue seen with PLEX DLNA server but not with MinimServer
  • Music browsing: white back (<) and more (...) buttons are not visible when artist/album image background is white <--- Version 3.00 introduces a black back symbol (<) while keeping the more icon (...) white, no comment ....
  • Music browsing on iPhone: top artist/album image overlaps top screen informations
  • Now playing screen: icon depicting the product flashing for a fraction of a second.
  • IOS 3D Touch "shutdown all" option does not do what it is supposed to do but simply opens the B&O App (case opened by mbolo01 - Dec 2019)
  • Multiroom icon not always displayed against products member of a multiroom experience
  • Play queue: When inserting music track(s) to a product play queue, the play queue is emptied prior to loading new content to it which is the correct behavior, but when a TuneIn radio has been played after a music source, loading new music content to the product no longer clears the play queue but instead inserts the new track(s) after the latest music track played (case opened by mbolo01 - Dec 2019)
  • Cover-Art is not displayed when using Airplay while it is when using other music sources such as Chromecast or DLNA.
  • Product Multiroom screen: When a given product is streaming Airplay flow, its Multiroom page indicates that other products cannot join when such source is in use, which is obviously wrong (when products are correctly configured) and which works despite the displayed message.

Note: I have opened a case (#200208-000081) on Feb 8th 2020 for all the points above but the "Cannot get the app to control BeoSystem 4500 and BeoSound 2300, each connected to an NL/ML converter." that i cannot support as I don't have such equipment and "Now playing screen: when changing a DLNA track, album cover is not displayed back until now playing screen is minimized/maximized" which may be a PLEX DLNA poor implementation.

Issues fixed in 3.1:

  • Play Queue: Album Artist is shown for each track instead of Track Artist like in the now playing screen. When listening to Compilations that have "Various Artists" for Album Artist, identifying the track artist in the Play Queue is not possible which is a pity.
  • (introduced in 3.0): Now playing screen: back arrow (<) is black on a dark grey background, hardly visible.
  • (introduced in 3.0): iPad landscape mode the product images are overlapping in the most recent versions.

Issues fixed in 3.00:

  • Beolink settings: When disabled, Integrated devices monitoring option does not stay disabled after app restart (case opened by mbolo01 - Dec 2019)

On-going requests for enhancement by BeoWorld forum members:

  • Ability to “join” NL streams from the app.
  • Lack of virtual keyboard for the Eclipse when a menu where text input is required is encountered, e.g. search field
  • Split view and slide over on the Apple iPad
  • Deezer Flow
  • Possibility to reduce local source list in the now playing screen
  • Genre overview - with much smaller pictures per Genre, so that you see more content without scrolling, e.g to follow the Deezer design (as you did with Artists using round circles instead of squares). Deezer is using small rectangle instead of squares for displaying genre.
  • Clearer multiroom screen, you see all groupings at once, without changing selected products
  • Possibility to alias sources' names, e.g change BS Core "Line In" to "BG 4000"
  • More consistency across screen designs, e.g.  when you choose "show all“ at "Deezer Selection“ the displayed list looks different than all the other lists displayed at  "show all“, why?
  • Now playing screen: changing track by pressing on the image is far too sensitive, lack of inertia
  • Dark mode

 

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

All Replies

steve1977
Top 100 Contributor
809 Posts
OFFLINE
Bronze Member
Carolpa:

Example: you have an A6, an A9 and a BV11. On the BV11 the Homemedia is playing a song. Some minutes later the A6 Music is started to play its own song. If you JOIN the A9 it is actually linked with the A6. After a second JOIN command it is linked to the BV11.

You have always been able to start a ML source in NL with the app. But (to my knowledge) you never been able to start a NL source on a ML master with an app.

Just checked the original Beomusic app (still working on my wife's phone), but I simply can't see how it could be done. You can not address a ML master directly.

Yes, it’s the beomusic app where i got it working. When selecting the nl/ml, it allowed me to select mapped sources. Once i click the streaming source, it joins. It worked with an active source as well as to turn on an nl source that wasn’t playing. While technically also not the “+”, it was close enough.

On separate note, i think beomusic even had a “+” when set in a different mode. There is a mode that didn’t use the ML, but the PL (when connecting beolabs to the ml/nl). Assume this worked as it then purely relies on nl.

Both features no longer work with the b&o app.

Thanks again for your thoughts.
Hiort
Top 50 Contributor
Sweden
2,551 Posts
OFFLINE
Bronze Member
Hiort replied on Sat, Feb 15 2020 10:57 AM
Just updated to latest build released today.

Still ridiculously small multi room icon.

App is not showing that icon on all devices part of multi room playing.

 

 

 

 

Livingroom: BL3, BL11, BV11-46 Kitchen: Beosound 1 GVA, Beocom 2 Bathroom: M3 Library: A6, Beocom 6000 Bedroom: M5 Office: Beocom 2 Travel: Beoplay E8 2.0, Beoplay P2

mbolo01
Top 75 Contributor
Annecy - France
1,636 Posts
OFFLINE
Gold Member
mbolo01 replied on Sat, Feb 15 2020 11:22 AM
Hiort:

Still ridiculously small multi room icon.

It is not even the multiroom icon, I reported it again via the beta feedback, not sure if it reaches some developper .....

You’ll notice that there is no more back button in the multiroom screen (previously black but not functional), and, cherry on the cake, sometimes the black bottom product bar disappear and you are stuck in the multiroom screen, forcing you restart the app.

Steps to recreate the issue: open a product now playing screen, click on the bottom right multiroom icon, et voilà !

All bugs are still present apparently

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

ngnear
Top 500 Contributor
207 Posts
OFFLINE
Bronze Member
ngnear replied on Sat, Feb 15 2020 12:20 PM
mbolo01:

It is not even the multiroom icon, I reported it again via the beta feedback, not sure if it reaches some developper .....

You’ll notice that there is no more back button in the multiroom screen (previously black but not functional), and, cherry on the cake, sometimes the black bottom product bar disappear and you are stuck in the multiroom screen, forcing you restart the app.

Steps to recreate the issue: open a product now playing screen, click on the bottom right multiroom icon, et voilà !

All bugs are still present apparently BS Moment, BS Core, BS Ouverture, BG 4002, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

Just swipe back to the previous screen ( left to right)

I just did intuitively I didn’t notice there was no back arrow.

Tim
mbolo01
Top 75 Contributor
Annecy - France
1,636 Posts
OFFLINE
Gold Member
mbolo01 replied on Sat, Feb 15 2020 12:26 PM
ngnear:

Just swipe back to the previous screen ( left to right)

Good catch thanks, I wonder why they never communicate on changes like this.

That said, don’t swipe too much or the app freezes in the below state Big Smile

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

Hiort
Top 50 Contributor
Sweden
2,551 Posts
OFFLINE
Bronze Member
Hiort replied on Thu, Feb 20 2020 4:40 PM
The ”X” up in left corner is “dark on dark” in the playlist screen.

To get back to now playing screen you swipe, but if you tap the X you come back to the Product setting screen for the product that are playing....

 

 

 

 

Livingroom: BL3, BL11, BV11-46 Kitchen: Beosound 1 GVA, Beocom 2 Bathroom: M3 Library: A6, Beocom 6000 Bedroom: M5 Office: Beocom 2 Travel: Beoplay E8 2.0, Beoplay P2

mbolo01
Top 75 Contributor
Annecy - France
1,636 Posts
OFFLINE
Gold Member
mbolo01 replied on Fri, Feb 21 2020 12:43 PM
Hiort:

To get back to now playing screen you swipe, but if you tap the X you come back to the Product setting screen for the product that are playing....

Are they sneakily introducing new navigation modes while forgetting to remove legacy ones? Or has the swiping gesture always be there in both multiroom and play queue?

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

beojeff
Top 50 Contributor
USA
1,778 Posts
OFFLINE
Bronze Member
beojeff replied on Fri, Feb 21 2020 12:59 PM

mbolo01:
Hiort:

 

To get back to now playing screen you swipe, but if you tap the X you come back to the Product setting screen for the product that are playing....

 

 

Are they sneakily introducing new navigation modes while forgetting to remove legacy ones? Or has the swiping gesture always be there in both multiroom and play queue?

I, too, felt that I was stuck on a screen until I accidentally swiped. The swiping is not at all intuitive.

Hiort
Top 50 Contributor
Sweden
2,551 Posts
OFFLINE
Bronze Member
Hiort replied on Fri, Feb 21 2020 2:40 PM

beojeff:

mbolo01:
Hiort:

 

To get back to now playing screen you swipe, but if you tap the X you come back to the Product setting screen for the product that are playing....

 

 

Are they sneakily introducing new navigation modes while forgetting to remove legacy ones? Or has the swiping gesture always be there in both multiroom and play queue?

I, too, felt that I was stuck on a screen until I accidentally swiped. The swiping is not at all intuitive.

Agree,

It´s a bit akward that you sometimes swipe and sometimes have to tap to go back.

Again, quality control seem to be non-existing given the strange thing with the "X". 

 

 

 

 

Livingroom: BL3, BL11, BV11-46 Kitchen: Beosound 1 GVA, Beocom 2 Bathroom: M3 Library: A6, Beocom 6000 Bedroom: M5 Office: Beocom 2 Travel: Beoplay E8 2.0, Beoplay P2

mbolo01
Top 75 Contributor
Annecy - France
1,636 Posts
OFFLINE
Gold Member

I checked in 2.11 version and swiping gesture was already there, on top of working and visible « X » and « arrow back » signs. Never noticed that ...

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

mbolo01
Top 75 Contributor
Annecy - France
1,636 Posts
OFFLINE
Gold Member
Production 3.00 is out since one week and still includes the design/cosmetic bugs reported a while ago on top of the ones reported through the recent beta, e.g. wrong or missing multiroom icon (top image), “

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

kuyttendaele
Top 150 Contributor
591 Posts
OFFLINE
Founder

In previous versions I could change the volume simply bij using the volume up/down button on my iPhone when the app was open. That's not possible anymore. 'Ringer" volume is now displayed. Don't know it that is related to the app or to the new iOS 13.4 beta.

Karel.

mbolo01
Top 75 Contributor
Annecy - France
1,636 Posts
OFFLINE
Gold Member

kuyttendaele:
In previous versions I could change the volume simply bij using the volume up/down button on my iPhone

Stupid question maybe, but did you check if the option is still active in Settings/Music/Commands ? When I activate the option in mine, it works when the screen is locked as well as when the app is running. It requires to minimize/maximize the app after the setting is turned on to be effective (another bug ...)

 

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

ngnear
Top 500 Contributor
207 Posts
OFFLINE
Bronze Member
ngnear replied on Wed, Feb 26 2020 7:04 PM
I also noticed this. The function was always designated “Beta”

Edit: Thanks mbolo01 works again now. That was the solution.
mbolo01
Top 75 Contributor
Annecy - France
1,636 Posts
OFFLINE
Gold Member

Issues fixed in 3.1 (beta):

  • Play Queue: Album Artist is shown for each track instead of Track Artist like in the now playing screen. When listening to Compilations that have "Various Artists" for Album Artist, identifying the track artist in the Play Queue is not possible which is a pity.
  • (introduced in 3.0): Now playing screen: back arrow (<) is black on a dark grey background, hardly visible.
  • (introduced in 3.0): iPad landscape mode the product images are overlapping in the most recent versions.

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

Page 2 of 5 (71 items) < Previous 1 2 3 4 5 Next > | RSS
Beoworld Security Certificate

SSL