Sign in   |  Join   |  Help

Beomaster 1900. Standby LED on but nothing else. Lots of work done so far but no progress

rated by 0 users
Not Answered This post has 0 verified answers | 5 Replies | 1 Follower

FredFredson
Not Ranked
3 Posts
OFFLINE
Bronze Member
FredFredson posted on Sat, Sep 14 2019 2:57 PM

Hi all.

 

I've a Beomaster 1900 here that only has the standby led lighting up. If I press any touch buttons, the LED flickers (and it constandly flickers if I hold my finger down on any touch buttons)

Nothing works or powers up, no click from the relay, no lamps, nothing.

 

So far I have:

 

1. installed full new lamp kit

2. installed full cap kit

3. replaced IC9

4. replaced relay

5. replaced rectifier.

 

I read about testing TP15 for 15v with a multimeter but mine only measures a few millivolts. Is this because it's in standby mode or should this always measure 15v? 

 

Any ideas?

 

 

 

All Replies

solderon29
Top 150 Contributor
U.K.West Midlands
636 Posts
OFFLINE
Gold Member

TP15 is the output of the electronic switch.It's zero voltage in stand-by,and 15 volt when the unit is on.

You need to investigate whether TR31 is trying to switch on?

It seems to be if the stand-by light is flickering when you keep a finger on any of the touch zones.

Are you confident that you have installed all the cap's correctly,and that there are no solder blob shorts on the pcb anywhere?

There is a fault detector system in the Beomaster which will prevent the electronic switch from working if a fault,particularly in the main amplifier occur's

Nick

FredFredson
Not Ranked
3 Posts
OFFLINE
Bronze Member

I'm 100% on the cap polarity. This was the issue before I started work on it and all the changes made so far have been in an attempt to fix the unit.

 

Thanks for the tip in the tr31. I've ordered a replacement as well as a replacement for tr27.

 

Does anyone know where the component d50 is on the pcb? I've read on this forum about people replacing d50 to fix power issues but cant find the component location on pcb...

 

 

Also, would anyone have a photo of where on the board is the best point to place the multimeter probe for ground when measuring DC voltage and AC voltage? I'm getting the below readings for tr27 and 31 with the gnd I'm using right now. Can I use the same gnd point to measure AC?

 

TR31
B = 10v on standby. drops to 5.2v when holding finger on a touch button.
C= 0v (70millivolts). rises a little to 200millivolts when holding finger on a touch button.
E= 10v. drops to 5.7v when holding finger on a touch button

 

TR27:
B = 15.8v on standby. rises to 17v when holding finger on a touch button.
C= 10.7v on standby. drops to 5.3v when holding finger on a touch button.
E= 23.3v. on standby. no change when holding finger on a touch button

According to Martin tr27 readings are way off so this may well be the culprit.

 

 

solderon29
Top 150 Contributor
U.K.West Midlands
636 Posts
OFFLINE
Gold Member

TR27 collector is certainly low,it should be at least 15 volt in standby and when the unit is on.

You need to investigate TR27,28,29 and C92.Although the supply at the emitter of TR27(23v) is normal,it's worth checking D50,the square bridge rectifier next to C92(2200uf)If this is the rectifier that you refer to earlier,is it fitted in the correct polarity?

D50 is a common failing in these Beomaster's,and if it looks as though it hasn't been changed,ie no fresh soldering since original),it's well worth replaceing it anyway.

I'm still suspicious of the fault switch though too.Not the switch system itself,but that something is triggering it?

Check the main output transistors IC200/201 and IC300/301) for leakage or short circuit?

For voltage checks,connect your meter negative clip to any metalwork,or to the negative connection of C92.

Nick

Dillen
Top 10 Contributor
Copenhagen / Denmark
10,907 Posts
OFFLINE
Founder
Moderator
Dillen replied on Sun, Sep 15 2019 11:11 AM

solderon29:

TR27 collector is certainly low,it should be at least 15 volt in standby and when the unit is on.

It was the B-E voltage, that first sprung in my eyes.Laughing
R147 is what provides the voltage at the collector then, changing with the load.

Martin

 

FredFredson
Not Ranked
3 Posts
OFFLINE
Bronze Member

Thanks for all the help guys

 

TR27 is definitely faulty. I took it out of circuit and tested with the multimeter in diode mode to confirm: I get a small voltage reading measuring from C to B but it's OL for E to B.

 

I'll try find a D50 to buy onlne. Does anyone sell a "D50 + transistor kit" for the beomaster 1900 series?  I bought the TR27 and TR31 already yesterday from RS online but they are coming in a tube of 20 each as that's the minimum order :D

 

Page 1 of 1 (6 items) | RSS
Beoworld Security Certificate

SSL