Sign in   |  Join   |  Help

Semi Solved: Beoplay A9 Mark 3 - Inputs Delay: Bluetooth & Line in

rated by 0 users
This post has 13 Replies | 1 Follower

Battlecat
Not Ranked
Posts 13
OFFLINE
Bronze Member
Battlecat Whisper [:-*] Posted: Thu, Feb 28 2019 9:46 PM

Hey everyone. Finally took the plunge and got the A9 MkIII. Must say that the looks are still out of this world and the sound is highly enjoyable especially with the 2 new drivers. A little tweaking of the equalizer and the sound is just amazing - with punchy bass.

I had only one concern with the product. It's a major one - I am hoping a software update can fix. B&O if you're listening or reading this - please do try and fix the below with haste:

I am now using a a multi-room music throughout my home - with multiple Amazon Echo devices. These connect to my amps or standalone speakers either via Bluetooth or Line out and work great. 

I was totally shocked when I did the same with the A9. Basically I tried a Bluetooth method - where it did connect successfully quite easily. When playing the audio out - there was almost a 1 - 1.5 second delay on the Bluetooth input. This is the worst when listening to anything in a small multi-room environment as the beats and vocals are not aligned, making any beautiful track or sound, turn to NOISE. Prior to this even a 8 year Bluetooth speaker was in sync - using far older Bluetooth technology. 

I said the other solution could be using the direct line in - so i did connect the Echo directly from the line out to the line in of the A9. Guess what? There is still a delay - shorter one - but enough to drive you mad as sounds turn back into noise. 

Not sure what I can do next as I do not think the system is bad or problematic. Works smooth and sounds amazing. It's just that a sound delay from Bluetooth for a new system is not fun and for a line in level; it is just not acceptable. 

Would anyone be able to advise me. Is there feedback I can give to B&O directly. ANy hep would be greatly appreciated. 

Thanks in advance. 

 

Battlecat
Not Ranked
Posts 13
OFFLINE
Bronze Member
Anyone!?
Millemissen
Top 10 Contributor
Flensborg, Denmark
Posts 12,276
OFFLINE
Bronze Member

Maybe this can help you - from the B&O FAQ site.

Note that if you connect your music system to a TV, there is a small sound delay and therefore sound and image are not completely synchronized.

The delay can be switched on or off via Bang and Olufsen App.

Go to SOUND and select DELAYS. Follow the instructions. note that if the delay is switched off, you cannot distribute sound in a multiroom setup

It is a common thing for all the newer product - due to the processing of the sound in the device.

P.S. ‘distribute sound in a multiroom setup’ means in a beolink/NL setup!

MM

There is a tv - and there is a BV.

Millemissen
Top 10 Contributor
Flensborg, Denmark
Posts 12,276
OFFLINE
Bronze Member

By the way - what did your dealer answer, when you asked him about your ‘worries’?

MM

There is a tv - and there is a BV.

Battlecat
Not Ranked
Posts 13
OFFLINE
Bronze Member

Big Smile

Thanks. Will try tomorrow and give feedback. 

Does Bluetooth Delay also get fixed by this option or does Bluetooth have a similar settings to stop s delay? Will also try but I hope it's not the case. Stay tuned. 

 

 

Battlecat
Not Ranked
Posts 13
OFFLINE
Bronze Member

Dealer had no comment. I will be home in 8 hours and give feedback on the line-in delay (If any). 

Battlecat
Not Ranked
Posts 13
OFFLINE
Bronze Member

Ok great. This has fixed the line in delay problem (via the app). Most pleased. Here is my Beosound 1 V1 and A9 Mk3 now playing in perfect sync via the line in (Amazon Dot Echo as the streamer for multiroom).  Turn up the volume. Good thing also is that the Amazon Echo acts a Bluetooth receiver with no time delay or lag (Albeit at the cost of the line in now used).

https://youtu.be/bogJSy9fucc

 

Will test Bluetooth and get back. 

Battlecat
Not Ranked
Posts 13
OFFLINE
Bronze Member

Was trying to embed the video but don't know how .Copy paste the link above!

Millemissen
Top 10 Contributor
Flensborg, Denmark
Posts 12,276
OFFLINE
Bronze Member

Glad that it works for you.

Maybe you should change the title of this post from ‘worried’ to ‘solved’ 😉

MM

There is a tv - and there is a BV.

poodleboy
Top 500 Contributor
Posts 243
OFFLINE
Bronze Member

Millemissen:

Glad that it works for you.

Maybe you should change the title of this post from ‘worried’ to ‘solved’ 😉

MM

I think you might have solved that particular problem, and cheers for that, but wait, there's more. The documentation you quoted says..

Note that if you connect your music system to a TV, there is a small sound delay and therefore sound and image are not completely synchronized.The delay can be switched on or off via Bang and Olufsen App."

Video processing delay makes perfect sense, has always been the case, and is difficult to solve. The OP didn't mention a TV, right? 

Line in audio delay without video processing in the loop does not make sense unless the B&O products have compatibility issues outside it's own ecosystem. In case, the documentation should state that or prepare people for more unpleasant surprise. 

Or did I miss something? 

trackbeo
Top 500 Contributor
Posts 208
OFFLINE
Bronze Member

poodleboy:
Line in audio delay without video processing in the loop does not make sense unless the B&O products have compatibility issues outside it's own ecosystem. In case, the documentation should state that or prepare people for more unpleasant surprise. Or did I miss something?
Yes, probably: The reason for the delay is twofold: (1) Analog-to-Digital conversion happens in real time with a very slight latency, but if you also have to compress the audio for retransmission to multiple recipients over a (potentially uneven transmission rate) network, that takes longer because you have to scan over part of the stream to compress; plus (2) Each generation of wireless speaker will have its own delay to buffer before starting to play, so the source speaker must delay its own output until it can be certain that the slowest of its destination speakers will be able to play in sync.  

The Sonos systems have the same problem, and the same setting in their app to override multi-room transmission in favor of instant local-zone playback.  You can imagine that a similar problem is at the root of the Roon multi-zone caveats: RAAT implementations can all be synced up, Chromecast zones can all play in sync, as can all AirPlay zones, but not any of them cross-protocol at the same time.  You are right, the documentation should state that.  Roon are explicit about this incompatibility.  But B&O manuals have always been a travesty of icons & vagueness, so there is no reason to expect them to start now -- especially for a cross-brand experience that they have traditionally never wanted to encourage, much less support.

Makes me occasionally pine for the analog multi-room network: MCL was so straightforward: each zone had its own volume & mute, but the audio was at "electron speed"!

Battlecat
Not Ranked
Posts 13
OFFLINE
Bronze Member

Thanks for the extended feedback. Extremely informative and a pleasure to read; line in without delay works fine. 

The reason I cannot completely mark this as solved is due to the fact that Bluetooth is still terribly lagging in terms of a delay. 

What's shocking is that my 7 year old Bluetooth speaker and Bluetooth gateway exhibit almost no lag and I did not expect this of a 2018 / 2019 state of the art speaker. Has anyone reached out to B&O to resolve this Bluetooth lag?

poodleboy
Top 500 Contributor
Posts 243
OFFLINE
Bronze Member

@trackbeo Thanks for the very informative response. 

ericitzhak
Not Ranked
Posts 2
OFFLINE
Bronze Member
ericitzhak replied on Wed, Aug 21 2019 11:26 PM

Probably not relevant for your right now but for future people,

I've had the same issue with the Beoplay M5, had a 1 second delay when using Bluetooth to play video even after I disabled delay in the settings.

What fixed the issue for me was going to (in the B& app) to Settings -> Beolink -> Sound Syncronization and there I found out that for some reason the "Network delay" was set to 1000 ms. Go figure why they did it on default but I set it to 0 and  it fixed it for me.

 

Hope this helps someone.

Page 1 of 1 (14 items) | RSS
Beoworld Security Certificate

SSL