Sign in   |  Join   |  Help

Beoplay A1 bass/sound problem

rated by 0 users
Not Answered This post has 0 verified answers | 12 Replies | 2 Followers

Cookieuser
Not Ranked
1 Posts
OFFLINE
Bronze Member
Cookieuser posted on Tue, Feb 19 2019 7:32 PM

Hey there guys,

so i have a small problem with my b&o beoplay a1 after it fell down on the ground from 30cm height.

When playing music bass started to have distortions and makes “fart” noises. So i decided to check whats happened inside.

I disassembled whole speaker but did not unplug any wires or so. Connected it to a phone and played some music, and everything sounded superb, without any distortion or “fart” noises. But when i put it together distortions come again, i dont even need to screw everything back, just when i put upper part back distortions comes but when they are separate everything sounds great.

I tried to check if some wires or anything touching the main speaker or so, but it doesnt look like it. Maybe problems with air inside or something.

Maybe somebody knows whats going on?:)

I bought this speaker from B&O shop in Switzerland abroad and i dont have any checks from it so warranty wont apply for this one.

Thank you for any kind of help :)

 

All Replies

tph
Top 500 Contributor
Finland
156 Posts
OFFLINE
Bronze Member
tph replied on Tue, Feb 19 2019 9:36 PM

I had this problem with an A1 once. Try to see if covering the screw holes underneath the aluminium grille will fix the issue – in my case, air was leaking through those holes, causing extra noises with bass. I did the easy thing and just put tape on them (as one does at BeoCreate) and the problem was solved Big Smile

Jan2017
Not Ranked
8 Posts
OFFLINE
Bronze Member

I have the same problem. Cracks in the plastic lid, also the tubes where the screws need to exhibit cracks.

I'm going to try to stick with Superglue but think better to buy a new lid.

Does anyone know where I can buy?

PaulGiles
Top 500 Contributor
209 Posts
OFFLINE
Bronze Member
Funnily enough I “repaired” one the weekend.

Plastic fatigue on the inner plastic cover.

Woofer mounts had failed, fixed with super glue.

The air leakage was also coming out of a cracked fixing hole, rectified with Gorilla tape.

No spare parts available for these.
mbolo01
Top 75 Contributor
Annecy - France
1,721 Posts
OFFLINE
Gold Member

Thanks so much guys !

I tape-fixed mine which is no longer farting and I can enjoy it again. Summer is coming!

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

moxxey
Top 25 Contributor
South West, UK
5,215 Posts
OFFLINE
Bronze Member
moxxey replied on Thu, Apr 25 2019 2:54 PM

PaulGiles:

No spare parts available for these.

It might be easier/cheaper just buying an A1 refurb from the BeoPlay eBay store - they are often well under £100!

PaulGiles
Top 500 Contributor
209 Posts
OFFLINE
Bronze Member
Gorilla tape to the rescue!
Patrauleasaunu
Not Ranked
3 Posts
OFFLINE
Bronze Member

Hi guys. 

I bought as new the same speaker and on some tracks, would sound really bad but others would sound decent so I thought ok, I was unlucky with my choice and I have to deal with it... But today I dropped my speaker and the cracking sound is in every track when the bass/kick comes in. 

I don't understand exactly what to do as I was reading your posts and some pictures would really help me... 

Happy new year and I hope one of you will have the time to follow a brother in need... 

mbolo01
Top 75 Contributor
Annecy - France
1,721 Posts
OFFLINE
Gold Member

Hi, look at this thread, I posted a picture:

https://forum.beoworld.org/forums/t/38493.aspx

happy new yeA1r !

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

Patrauleasaunu
Not Ranked
3 Posts
OFFLINE
Bronze Member

thank you!

i just tried cotton and some ordinary tape, still same issue.

need to find gorilla tape which is not easy in a foreign country where you cant even read the alphabet but i guess will happen one way or another :)

For the screws, what type did you use to unscrew ?

Patrauleasaunu
Not Ranked
3 Posts
OFFLINE
Bronze Member

thank you!

i just tried cotton and some ordinary tape, still same issue.

need to find gorilla tape which is not easy in a foreign country where you cant even read the alphabet but i guess will happen one way or another :)

For the screws, what type did you use to unscrew ?

mbolo01
Top 75 Contributor
Annecy - France
1,721 Posts
OFFLINE
Gold Member
Patrauleasaunu:

i just tried cotton and some ordinary tape, still same issue.

It may not be the same issue then :-( The one fixed by the tape is a bass « farting » effect, excuse my French

I didn’t unscrew anything on my side.

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

PaulGiles
Top 500 Contributor
209 Posts
OFFLINE
Bronze Member
Probably cracked internal housing. Remove the black grille and check the screw mounts.
Page 1 of 1 (13 items) | RSS
Beoworld Security Certificate

SSL