Sign in   |  Join   |  Help

M70 Speaker repair

rated by 0 users
Not Answered This post has 0 verified answers | 7 Replies | 1 Follower

Jim Carr
Not Ranked
Loleta CA.
41 Posts
OFFLINE
Bronze Member
Jim Carr posted on Sat, Dec 8 2018 7:56 PM

Hi all!

I bought a set of M70's and have been reading about the speaker magnets coming loose. All of my speakers sound good now and I have one grill off (they were glued on) and the speakers pass the finger test.

Now I would like to do the epoxy prevention repair but cannot find a good procedure or pictures about doing it just mentions in different threads.

Also a method of reattaching the grills.

Thanks, Jim.

All Replies

priklep
Top 500 Contributor
Slovakia
69 Posts
OFFLINE
Bronze Member

Dear Jim,

here are some instructions:

https://forum.beoworld.org/forums/t/30259.aspx

https://archivedforum.beoworld.org/forums/p/19654/192178.aspx

Jim Carr
Not Ranked
Loleta CA.
41 Posts
OFFLINE
Bronze Member

Thank you! That is what I was looking for.

Should I do this to all the speakers? The links talk about just the woofers and I read that some people were having trouble with the phase link speakers. Also I have some S60 speakers should I do those also?

Thanks, Jim.

priklep
Top 500 Contributor
Slovakia
69 Posts
OFFLINE
Bronze Member

You welcome Smile.

I am not so oriented , so please wait for another advice.

Saint Beogrowler
Top 150 Contributor
Saint Paul
735 Posts
OFFLINE
Gold Member
My approach has been; if I have it open- I epoxy all drivers. If I’m going to be transporting this era B&O speakers to loan to someone across town; I open and epoxy. Cheap insurance and saves an enormous amount of time.
Beo_Jean
Top 200 Contributor
QC, Canada
293 Posts
OFFLINE
Bronze Member

Hi Jim,

I surprised that my M70 restoration did not come up in your search.  Pretty much everything was covered!?!

Let me see where it is...

Beo_Jean
Top 200 Contributor
QC, Canada
293 Posts
OFFLINE
Bronze Member

https://forum.beoworld.org/forums/p/30201/237797.aspx#237797

Jim Carr
Not Ranked
Loleta CA.
41 Posts
OFFLINE
Bronze Member
Jim Carr replied on Mon, Dec 10 2018 12:04 AM

Thank you!  I'm not sure how I missed your project but now I have the link and of course some questions I posted on it.

I read Sorens M70 project but none of the pictures will load up the just say "picture not found". Not sure why.

Thanks, Jim.

Page 1 of 1 (8 items) | RSS
Beoworld Security Certificate

SSL