Sign in   |  Join   |  Help

Playmaker requires Firmware

rated by 0 users
Answered (Not Verified) This post has 0 verified answers | 7 Replies | 0 Followers

kinnetik
Not Ranked
4 Posts
OFFLINE
Bronze Member
kinnetik posted on Tue, Sep 4 2018 8:58 AM

Hi everyone,

since today my playmaker is not working anymore, the internal playmaker website always shows me the update product software page. I tried to reboot, reset and so on, but nothing changes.

Any suggestions ?

Thanks

Chris

All Replies

Aussie Michael
Top 50 Contributor
Melbourne, AU
3,347 Posts
OFFLINE
Bronze Member
kinnetik:

Hi everyone,

since today my playmaker is not working anymore, the internal playmaker website always shows me the update product software page. I tried to reboot, reset and so on, but nothing changes.

Any suggestions ?

Thanks

Chris

If you want to update the playmaker you have to plug it in to your router with the Ethernet cable.
kinnetik
Not Ranked
4 Posts
OFFLINE
Bronze Member

Hi Michael,

 

my playmaker is always connected to the router directly by LAN. No Switches or Hubs inbetween.

Kiran
Top 75 Contributor
UK
1,011 Posts
OFFLINE
Bronze Member
Kiran replied on Thu, Sep 6 2018 12:13 PM
Try factory reset then update...

Regards

Kiran

Born in NL; I ride ML

Guy
Top 50 Contributor
Buckinghamshire
1,583 Posts
OFFLINE
Gold Member
Guy replied on Thu, Sep 6 2018 2:25 PM

Aussie Michael:

If you want to update the playmaker you have to plug it in to your router with the Ethernet cable.

I think the direct connection was only required by the Mk1 Playmaker.  The Mk2 (non-FLAC) version is able to update in situ.

 

kinnetik
Not Ranked
4 Posts
OFFLINE
Bronze Member
Suggested by kinnetik

So after leaving it unplugged for a few weeks i tried my luck again today and the playmaker started again.

Its so weird because the reset didnt work. 

I am just frustrated with the customer service, this product is not being sold anymore, they should just publish the last firmware and not wanting to charge you 75 Euros.

Jeff
Top 25 Contributor
USA
3,490 Posts
OFFLINE
Bronze Member
Jeff replied on Sat, Nov 24 2018 12:23 AM

How do you use your Playmaker? Directly to speakers or to another thing like a Beosound and then to speakers?

My PM was a bit balky at first, then I assigned a fixed IP address to it, still had problems. Then I noticed that I only had issues when streaming to it from my laptop iTunes, from Spotify on my iPad it was fine.Or mostly fine. Turns out it was a process on my laptop related to networking that kept stomping on the Airplay feed. Solved that and it was mostly fine.

The PM would still drop the network connection fairly regularly and need rebooting. If I didn't use it for a week or so it's not respond and I'd have to go through the process of rebooting the PM. Finally it got to where it seldom worked, and I replaced it with an Auralic Aries Mini, which works flawlessly and never loses connectivity. Something to think about as a replacement if you still want similar functionality.

Jeff

I'm afraid I'm recovering from the BeoVirus. Sad

Aussie Michael
Top 50 Contributor
Melbourne, AU
3,347 Posts
OFFLINE
Bronze Member
kinnetik:

So after leaving it unplugged for a few weeks i tried my luck again today and the playmaker started again.

Its so weird because the reset didnt work.

I am just frustrated with the customer service, this product is not being sold anymore, they should just publish the last firmware and not wanting to charge you 75 Euros.

I thought you can download the firmware. I did when I had mine.
Page 1 of 1 (8 items) | RSS
Beoworld Security Certificate

SSL