Sign in   |  Join   |  Help

Sign up for AirPlay2 beta testing

rated by 0 users
Not Answered This post has 0 verified answers | 96 Replies | 3 Followers

beobeta
Not Ranked
5 Posts
OFFLINE
Bronze Member
beobeta posted on Mon, Aug 6 2018 10:49 PM

Hello BeoWorld,

We are starting up beta testing of AirPlay2 this month. This includes following products:

  • BeoPlay A9 2nd Gen
  • BeoPlay A6
  • BeoSound Essence 2nd Gen
  • BeoSound 35
  • BeoSound 1
  • BeoSound 2
  • Beoplay M5
  • Beoplay M3
  • BeoSound Core
  • BeoSound Shape

To sign up, we will require that you provide feedback on any issues that your might find.

If you would like to participate, please send a mail to  beta@bang-olufsen.dk with your product serial number (8 digit), full name and e-mail address. 

Disclamer: We might decline you as beta tester if no feedback is provided for long time or we have enough beta testers enrolled.

Best regards 

B&O Beta Community team 

(Privacy policy for B&O: https://www.bang-olufsen.com/privacy-policy)

All Replies

madskp
Top 500 Contributor
Denmark
299 Posts
OFFLINE
Gold Member
madskp replied on Sat, Aug 11 2018 10:03 AM

AnalogPlanet:

I believe you could be right madskp. I actually use Apple TV Remote daily to adjust my LG LCD TV volume with +/- buttons on the remote. Since I mostly watch whetever I stream from the ATV4K, then I practically don’t even touch TV’s remote (ATV also set up to “wake” the TV). 

Oh and this might also work with other brands of TV's than B&O. For TVs with HDMI-CEC it might actually work without the Apple remote being part of it. Can not test it though as I only have the V1 

elephant
Top 10 Contributor
AU
8,218 Posts
OFFLINE
Founder
elephant replied on Sat, Aug 11 2018 12:26 PM

madskp:

Just tried it with my simple setup Beoplay V1 and ATV4. No other Airplay devices.

I placed the Apple remote in front of the tv and tried to play music from my iphone to the Apple TV without turning the V1 on. Nothing happened. Then i tried with video to see if the Apple TV would react differently. Nothing happened. 

Next thing I activated the Apple remote (which turned the TV on) and turned of the TV again. Now when I started airplaying music or video from the Iphone to the Apple TV the V1 turned on.

So here is what I think is happening: The Apple TV remote might go into som kind of sleep mode to preserve battery (I rarely use mine but it has keept the charge for several months without use) after a while and will only respond if you activate it by a button press. This makes sense from a normal use case. When the remote is in sleep mode it will not recive commands from the ATV and can not relay IR signals to the TV. 

I Will try to connect the Apple remote with a lightning cable and see if charging is preventing it from going to sleep. Will wait a couple of hours before i try again as I dont know how fast the remote will go to sleep under normal circumstances.   

This could be very interesting in order to turn on Beovisions with airplay Smile

Great thinking / detective work !

I think you are on to something ... the first use was in the morning after everything (including me) had been asleep for 6 to 8 hours.

I will try tomorrow :) as well as checking my apple remote's charge level (I last checked this week, and it was about 75% (you can check yours via the ATV's configuration App where all the remote & IR settings are also kept)).

BeoNut since '75

elephant
Top 10 Contributor
AU
8,218 Posts
OFFLINE
Founder

And now some AIrPlay2 (I believe) testing from the ATV itself to the Core (BL20s) and the Essence (BL6000), from my MacBook Pro (2015), and from my Mac mini (2010) both running High Sierra ....

The ATV worked a treat - no screen shots, I'd have to use the iPhone's camera, and besides which you have seen the basic screen already.

Just start a track, go to "What's Playing", use the Apple Remote to go to the AirPlay symbol on the top left, click it and you get a list of all AirPlay(2) addressable speakers include the HomePod and now the beta B&O streamers of the Essence and the Core. After that you just mix and match the speakers you want. 

But with the Macs I get different results !

From the MacBook Pro ........

1/ The BeoLab 20 volumes were painfully loud even at the smallest setting (but thankfully no ARMAGEDDON!!!!).

2/ So too were the BL11+2xBL6K volumes!

However from the Mac mini the same test produced volumes that were reasonable and pleasant to listen too and definitely controllable without going deaf.

I have mentioned this is my JIRA to Struer.

MacBook Pro screen shot below :)

 


BeoNut since '75

Hiort
Top 50 Contributor
Sweden
2,593 Posts
OFFLINE
Bronze Member
Hiort replied on Sat, Aug 11 2018 7:29 PM
Ran into some problems.

I managed to setup all B&O speakers in the Home app, configure different rooms and so on. Everything seemed to work and I could direct where the music was played using Siri.

I then added AppleTV. Then all configuration in Home app disappeared. All rooms and everything.

When I then tried to add the B&O speakers once more the app said it was unable to do so even if they appeared nicely in a row to select from.

Tried to restart app, router and even one of the speakers. Still not possible to add speakers.

Any advice?

 

 

 

 

Livingroom: BL3, BL11, BV11-46 Kitchen: Beosound 1 GVA, Beocom 2 Bathroom: M3 Library: A6, Beocom 6000 Bedroom: M5 Office: Beocom 2 Travel: Beoplay E8 2.0, Beoplay P2

Millemissen
Top 10 Contributor
Flensborg, Denmark
13,541 Posts
OFFLINE
Bronze Member

elephant:
Following observation: that without knowing the detail of speakers in rooms and knowing how things are named and knowing how the system works I suspect most of our family will not be able to use things the way I have done today.

And the starting, adding/joining and stopping of rooms is complex and requires careful use of Siri commands.

I wonder whether the way to go is simply to inject the HomePod stream into one part of the B&O network and then use all the technology we already have to add and join rooms: such as the Essence’s Wheely.

Nonetheless I found myself excited by the possibilities.

Many of us have iPhones and some also iPads, some of us have Apple TV, a few of us have Essence Mark IIs - Core Mark Is and IIs, and fewer still have HomePods.

And of course somewhere in the above is the sub-/super- set of users of the Philips Hue lights, bridge, and HomeKit.

Some of us (Moi included) have google mini speakers, chrome audios, and chrome videos which would complicate/enrich and frustrate/delight our family/selves.

Then add Amazon, Apple, and Google voice in the future to speakers like BeoSound 1s 2s and various BeoPlay products and the possibilities compound exponentially.

I will leave it to others to ponder about home automation devices and B&O’s various gateways. That topic is well beyond me.

Now much of these additions to what was meant to be a simple AP2 beta thread may be unwelcome.

If they are please say so!

I can always start a new thread.

Of course what you do is very extreme, complicated and therefore nerdy.

Everyone will have to find his way with his mix of devices - and he will have to are for a way to use these,

that everyone in the household understands and accepts.

Often less is more!

However - nice to read about your tests, learning from them (and from anyone, who does testing)

Keep them coming....here, I’d say.

MM

There is a tv - and there is a BV.

elephant
Top 10 Contributor
AU
8,218 Posts
OFFLINE
Founder
elephant replied on Sun, Aug 12 2018 12:52 AM
Hiort:

I managed to setup all B&O speakers in the Home app, configure different rooms and so on. Everything seemed to work and I could direct where the music was played using Siri.

I then added AppleTV. Then all configuration in Home app disappeared. All rooms and everything.

When I then tried to add the B&O speakers once more the app said it was unable to do so even if they appeared nicely in a row to select from.

Tried to restart app, router and even one of the speakers. Still not possible to add speakers.

Wow 😲

I have never had anything like that.

However my ATV was there before I added the BeoLab streamers.

Are you using AP2 smart speakers, or only have Essence/Core streamer(s)?

I hate to say this (you’ve seen how many definitions my HomeKit setup has) but can you try deleting objects Sad

Or even deleting the App itself [:\'(]

I have some “rooms” from my HomePod testing but which I can’t delete ... maybe I should take some of my own medicine 🤢

BeoNut since '75

elephant
Top 10 Contributor
AU
8,218 Posts
OFFLINE
Founder
elephant replied on Sun, Aug 12 2018 12:54 AM
Millemissen:

what you do is very extreme, complicated and therefore nerdy

yup

that’s me

Mr 🤓

🤣

BeoNut since '75

elephant
Top 10 Contributor
AU
8,218 Posts
OFFLINE
Founder
madskp:

Just tried it with my simple setup Beoplay V1 and ATV4. No other Airplay devices.

I placed the Apple remote in front of the tv and tried to play music from my iphone to the Apple TV without turning the V1 on. Nothing happened. Then i tried with video to see if the Apple TV would react differently. Nothing happened. 

Next thing I activated the Apple remote (which turned the TV on) and turned of the TV again. Now when I started airplaying music or video from the Iphone to the Apple TV the V1 turned on.

So here is what I think is happening: The Apple TV remote might go into som kind of sleep mode to preserve battery (I rarely use mine but it has keept the charge for several months without use) after a while and will only respond if you activate it by a button press. This makes sense from a normal use case. When the remote is in sleep mode it will not recive commands from the ATV and can not relay IR signals to the TV. 

I Will try to connect the Apple remote with a lightning cable and see if charging is preventing it from going to sleep. Will wait a couple of hours before i try again as I dont know how fast the remote will go to sleep under normal circumstances.   

This could be very interesting in order to turn on Beovisions with airplay

elephant:

Great thinking / detective work !

I think you are on to something ... the first use was in the morning after everything (including me) had been asleep for 6 to 8 hours.

I will try tomorrow :) as well as checking my apple remote's charge level (I last checked this week, and it was about 75% (you can check yours via the ATV's configuration App where all the remote & IR settings are also kept)).

Congratulations on the solution madskp !

I charged my ATV’s remote overnight.

It had gotten down to 42% (yikes)

This morning (after already using the BV, the Beo 4, the ATV, and it’s remote) I tried this test:

0/ setup the ATV remote to point towards the BV8’s IR eye

1/ active the iPhone remote app

2/ ATV comes on

3/ use iPhone remote ... cannot see anything as BV is not on

4/ click ATV remote and hold one’s breath ... yes there it is the BV relay click

5/ keep on waiting for the usual 30 seconds or so

6/ yes ... there we have the ATV display on (with a YouTube channel from earlier today) the BV with the L+R BL3s powered on ... but not the BL4 rears

7/ and sound system setting is ... SPEAKER 2 with PCM input

Now repeat test with ATV remote flat (horizontal) on the coffee table ...

3/ jump straight to clicking volume + on ATV remote

4/ ATV light comes on ... BV relay clicks ... BV display opens with YT running ... so probably lost a minute of dialogue

Try again to confirm loss of dialogue ...

0/ pause 🤓 lecture at 27:48

1/ put ATV to sleep

2/ wait to see if BV goes to sleep

3/ yes in the time it does in the time one thumb took to type 2/ ... 3/ Smile

4/ press +

5/ ATV ... one BV click (relay) ... a softer click (screen static energising) ... catch BL19 light coming on

6/ after 20 seconds we have the YT display, but not running, and the BL19 light off

So a bit random with the ATV’s precise behaviour with YT but none the less a great result.

Thanks madskp !

BeoNut since '75

mbee
Top 75 Contributor
Paris, France
1,754 Posts
OFFLINE
Bronze Member
mbee replied on Sun, Aug 12 2018 10:53 AM

Do you have an essence integrated with your bv8? I can’t reproduce this behavior at home!

Hiort
Top 50 Contributor
Sweden
2,593 Posts
OFFLINE
Bronze Member
Hiort replied on Sun, Aug 12 2018 12:12 PM
elephant:

Are you using AP2 smart speakers, or only have Essence/Core streamer(s)?

I’m using BS1, M5, M3 and A6 with the AirPlay 2 beta.

Have tried to power off devices, delete app, reinstall app, resetting router, but no luck.

 

 

 

 

Livingroom: BL3, BL11, BV11-46 Kitchen: Beosound 1 GVA, Beocom 2 Bathroom: M3 Library: A6, Beocom 6000 Bedroom: M5 Office: Beocom 2 Travel: Beoplay E8 2.0, Beoplay P2

madskp
Top 500 Contributor
Denmark
299 Posts
OFFLINE
Gold Member
madskp replied on Sun, Aug 12 2018 12:51 PM

mbee:

Do you have an essence integrated with your bv8? I can’t reproduce this behavior at home!

For airplay from aTV to turn on a Beovision you have to make sure that the setting for turning on tv is enabled in the Apple TV settings app/menu. See more here: http://www.iphonehacks.com/2016/02/how-to-set-apple-tv-to-automatically-turn-television-on.html 

 

madskp
Top 500 Contributor
Denmark
299 Posts
OFFLINE
Gold Member
madskp replied on Sun, Aug 12 2018 1:11 PM

elephant:
Congratulations on the solution madskp !

 

 

I charged my ATV’s remote overnight.

 

It had gotten down to 42% (yikes)

 

 

This morning (after already using the BV, the Beo 4, the ATV, and it’s remote) I tried this test:

 

0/ setup the ATV remote to point towards the BV8’s IR eye

 

1/ active the iPhone remote app

 

2/ ATV comes on

 

3/ use iPhone remote ... cannot see anything as BV is not on

 

4/ click ATV remote and hold one’s breath ... yes there it is the BV relay click

 

5/ keep on waiting for the usual 30 seconds or so

 

6/ yes ... there we have the ATV display on (with a YouTube channel from earlier today) the BV with the L+R BL3s powered on ... but not the BL4 rears

 

7/ and sound system setting is ... SPEAKER 2 with PCM input

 

 

Now repeat test with ATV remote flat (horizontal) on the coffee table ...

 

3/ jump straight to clicking volume + on ATV remote

 

4/ ATV light comes on ... BV relay clicks ... BV display opens with YT running ... so probably lost a minute of dialogue

 

 

Try again to confirm loss of dialogue ...

 

0/ pause 🤓 lecture at 27:48

 

1/ put ATV to sleep

 

2/ wait to see if BV goes to sleep

 

3/ yes in the time it does in the time one thumb took to type 2/ ... 3/ Smile

 

4/ press +

 

5/ ATV ... one BV click (relay) ... a softer click (screen static energising) ... catch BL19 light coming on

 

6/ after 20 seconds we have the YT display, but not running, and the BL19 light off

 

 

So a bit random with the ATV’s precise behaviour with YT but none the less a great result.

 

 

Thanks madskp !

Sound a bit random what you experience with youtube. I guess one thing that will always be a problem is the Beovision startuptime. The Youtube vide will start as soon as the Apple TV is varmed up and the vide has buffered. This will ususaly be faster than the startup time of the BV. Same goes for music. 

Here is what I have tried since yesterday. 

1) When the ATV goes to sleep it will loose the connection with the ATV remote (also if the Apple remote is charging). It is still possible to control the ATV with a BEO remote via PUC. The Apple remote will not connect again before a button on it is pressed.

2) If the ATV is set to newer go to sleep at, some point it will loose connection to the Apple TV remote. I am not sure how long it takes before the remote goes to sleep. I guees this is in order to preserve battery on the remote. The Apple remote will not connect again before a button is pressed.

3) If the ATV is set to never go to sleep  and the remote is charging with a ligtning cable the connection will stay alive. I tried to check the connection after 10 hours idle time over night. 

So in conclusion. If you wan't to Airplay music og Video to an Apple TV 4(K) and turn on the BEO TV you have to set the ATV to never go to sleep, have the Apple remote charging all the time, and have the Apple remote pointing at the TV.

If the apple TV never goes to sleep the power consumption will raise from arround 0.4W at sleep to arround 2.1W at idle with screensaver according to https://www.flatpanelshd.com/review.php?subaction=showfull&id=1447825664

elephant
Top 10 Contributor
AU
8,218 Posts
OFFLINE
Founder
mbee:

Do you have an essence integrated with your bv8? I can’t reproduce this behavior at home!

diisign.com

Integration is via BLC NL/ML however I don’t think I used it apart from standard functions; so I am not sure which behaviour you are referring to !

Please specify so I can solution something for you.

BeoNut since '75

elephant
Top 10 Contributor
AU
8,218 Posts
OFFLINE
Founder
Hiort:

I’m using BS1, M5, M3 and A6 with the AirPlay 2 beta.

Have tried to power off devices, delete app, reinstall app, resetting router, but no luck.

Maybe we need to focus on the ATV as a culprit ?

What generation do you have, and what version of software is it ?

And are any HomeKit TVOS Apps installed on it ?

BeoNut since '75

elephant
Top 10 Contributor
AU
8,218 Posts
OFFLINE
Founder
madskp:

So in conclusion. If you wan't to Airplay music og Video to an Apple TV 4(K) and turn on the BEO TV you have to set the ATV to never go to sleep, have the Apple remote charging all the time, and have the Apple remote pointing at the TV.

I have the previous ATV however I believe your analyse is valid.

BeoNut since '75

Page 5 of 7 (97 items) « First ... < Previous 3 4 5 6 7 Next > | RSS
Beoworld Security Certificate

SSL