Sign in   |  Join   |  Help

Beomaster3500

rated by 0 users
Not Answered This post has 0 verified answers | 4 Replies | 1 Follower

permdent
Not Ranked
4 Posts
OFFLINE
Bronze Member
permdent posted on Fri, Jul 20 2018 2:50 PM

While playing tuner or cd player I hear a click and the amp goes back to standby,sometimes after a few seconds ,sometimes after a few  minutes .Is anyone familiar with this problem?Any help would be appreciated 

All Replies

solderon29
Top 150 Contributor
U.K.West Midlands
716 Posts
OFFLINE
Gold Member

The unit has a self protection system,which will switch it off in case of overheating or overload.

See if the unit still switches itself off when you have the 'speakers disconnected?What speaker's are you using?

Nick

permdent
Not Ranked
4 Posts
OFFLINE
Bronze Member

Thanks ,It happens with the beovox redline speakers disconnected as well.It jumps to standby.Sometimes immediately sometimes after a few minutes.

solderon29
Top 150 Contributor
U.K.West Midlands
716 Posts
OFFLINE
Gold Member

There is a fault then!

Something is triggering the safety circuit,probably a faulty main amplifier output chip.

You will need to investigate further,by checking internal voltages etc.

Do you have technical experience and tool's/instruments?

If not,you will need to get the unit to someone with B&O expertise.

Do you have a Service Agent nearby?

Nick

permdent
Not Ranked
4 Posts
OFFLINE
Bronze Member

Sounds reasonable.I have few skills,but I will look for a technician . Thanks for your help

Page 1 of 1 (5 items) | RSS
Beoworld Security Certificate

SSL