Sign in   |  Join   |  Help

beolab 3

rated by 0 users
Answered (Not Verified) This post has 0 verified answers | 17 Replies | 2 Followers

altist
Not Ranked
40 Posts
OFFLINE
Gold Member
altist posted on Mon, Jul 2 2018 6:42 PM

My beolab 3 are rear speakers-one just made a phut sound and the light has gone out...no longer working. Any ideas of scenario and how much its going to cost? Ugh

 

Thanks for the suggestions..it's gone to my local dealer for a new power supply...£200ish...

All Replies

Aussie Michael
Top 50 Contributor
Melbourne, AU
3,337 Posts
OFFLINE
Bronze Member
It’s the power supply.

It’s easy to change.

The dealer can arrange it for you and provide you with an estimate of cost.

I’m not sure of the cost.
neilgk175
Not Ranked
14 Posts
OFFLINE
Bronze Member

That happened to one of my beolab 3 speakers about a year go. It was about $500 for the part and labor to get it fixed from our local repair shop.

BV11-46, Beolab 3, Beoplay A1, A9, H3ANC, H8, H9i

Beobuddy
Top 25 Contributor
Utrecht, The Netherlands
3,543 Posts
OFFLINE
Founder

It's difficult to extimate the costs nowadays. The number of spareparts are rapidly decreasing and sometimes not even in stock anymore.

AFAIK you only can order a complete chassis which costs at least twice the amount mentioned here above.

Sometimes , not always, the BL3 can be repaired on componentlevel. A dead BL3 can be caused by a failing powersupply, which then again, can be caused by a failing ICE powerboard. So, a bit of a gamble there (I've fixed around 15-20 pcs and not always succesfull, sadly)

So, it certainly can be fixed, but a cheaper alternative would be buying a secondhand set used for spare speaker..

altist
Not Ranked
40 Posts
OFFLINE
Gold Member
Thanks for all the replies...fingers crossed it’s the cheaper (!) option of the power supply being replaced.
BeoPeter
Not Ranked
3 Posts
OFFLINE
Bronze Member

I had the same issue with my BL3. No LED at all.

Send them to an authorized repair shop in Denmark, who quoted 880 Euro for the repair. Apparently spare parts are no longer available, so they have to refurbish the speaker with parts from another speaker. The whole chassis must be replaced.

Currently I am investigating alternative solutions....

Does anyone have a BL3 schematics? I mean a real detailed schematics - not the service manual ?

 

BeoPeter
Not Ranked
3 Posts
OFFLINE
Bronze Member

I had the same issue with my BL3. No LED at all.

Send them to an authorized repair shop in Denmark, who quoted 880 Euro for the repair. Apparently spare parts are no longer available, so they have to refurbish the speaker with parts from another speaker. The whole chassis must be replaced.

Currently I am investigating alternative solutions....

Does anyone have a BL3 schematics? I mean a real detailed schematics - not the service manual ?

 

altist
Not Ranked
40 Posts
OFFLINE
Gold Member
altist replied on Sun, Feb 24 2019 5:48 PM

Hi,I may have been lucky in that, though the mk 1 parts aren't available any more,our local B&O repair guy here in Scotland managed to effect a repair-I can't remember the exact details.tho chassis was certainly part of the process...he said it had a been a useful learning process for him, and somewhat convoluted to boot..?! Anyway it was a modest £250 cost all in ,which I thought was pretty good.I am listening to music through my system as I type and its good to have all the speakers on songs to speak.

noflynn
Not Ranked
5 Posts
OFFLINE
Bronze Member
Suggested by noflynn
Hello Very interesting to have found these posts, I suddenly no longer feel alone with my problem. I am using the same thread in order to seek further opinions. In my case, one of my Beolabs 3 (1st generation) blew up in the sense the red light just went and no more sound from that faulty speaker, this is already a couple of years. So one guy who takes care of such problems for us, took the speaker to a BO dealer. Like for others, they were not able to find a replacement chassis and after much trouble they used my original casing and put in a chassis of a beolab 3 of a newer generation. Our guy then re-mounted the speaker for us. The problem now, although there is sound coming from both speakers, there is a mono/stereo issue, which wants to make me cry every time, for all tracks that are recorded so certain music parts only come out of say the right speaker, well it doesn’t or just very faintly. Have been living with this for a couple of years now (it was never right since the repair), our guy who took care of the whole thing seems to believe there is no problem to be resolved, he didn’t seem to get the point even demonstrating very typical tracks. Anyway i would like some opinions, do you think that the shop simply did their best and what they did with the other chassis may have not been compatible or do you think that there is a chance that when the speaker was mounted again something was done wrong with the cables ? Those speakers are mounted high against a wall so it’s not easy for me to just get at them and look at whatever, when i wouldn’t know what i am looking at let alone unscrew things. I had chosen those speakers as active speakers for the kitchen, because of their size and they are connected to the main BO system. I have been looking to see if BO did anything similar (wired speakers to main system using the same cell already in place) but it seems there isn’t anything that would be suitable. Everything sums to be geared up for wireless, or there are full size ones , i don’t see anything that would meet my requirements, is there really no solutions if what i have today cannot be repaired ? I would value some opinions here thanks and regards
Beobuddy
Top 25 Contributor
Utrecht, The Netherlands
3,543 Posts
OFFLINE
Founder

Perhaps the switch between left or right has set in the wrong way? That way you only have both speakers playing either left or the right channel and so missing sometimes sound which only is played through the other channel?

noflynn
Not Ranked
5 Posts
OFFLINE
Bronze Member

Thanks for this first suggestion.  I will check this when next at the holiday place where the speakers are.  Is that something simple to check ?  Would you be able to guide me a little ?  I am really clueless in this deparmtent.  Or perhaps I need to get someone in the know.    Thanks again

Hiort
Top 50 Contributor
Sweden
2,316 Posts
OFFLINE
Bronze Member
Hiort replied on Thu, Jun 13 2019 8:48 PM
Beobuddy:

Perhaps the switch between left or right has set in the wrong way? That way you only have both speakers playing either left or the right channel and so missing sometimes sound which only is played through the other channel?

Sounds definitely to be the problem.

 

 

 

 

Livingroom: BL3, BL11, BV11-46 Kitchen: Beosound 1 GVA, Beocom 2 Bathroom: M3 Library: A6, Beocom 6000 Bedroom: M5 Office: Beocom 2 Travel: Beoplay E8 2.0, Beoplay P2

Hiort
Top 50 Contributor
Sweden
2,316 Posts
OFFLINE
Bronze Member
Answered (Not Verified) Hiort replied on Thu, Jun 13 2019 8:58 PM
Suggested by noflynn
noflynn:

Thanks for this first suggestion. I will check this when next at the holiday place where the speakers are. Is that something simple to check ? Would you be able to guide me a little ? I am really clueless in this deparmtent. Or perhaps I need to get someone in the know. Thanks again

There is a lid you can remove where the cables enter the speaker.

Besides the sockets there is a switch that you can flip to tell the speaker to play either right or left channel. It’s very simple.

If speakers are wall mounted (like my are) you may need to remove them from the wall bracket by unscrewing the screw in the wall bracket in order to be able see how the switch is set and if needed flip it to left or right.

 

 

 

 

Livingroom: BL3, BL11, BV11-46 Kitchen: Beosound 1 GVA, Beocom 2 Bathroom: M3 Library: A6, Beocom 6000 Bedroom: M5 Office: Beocom 2 Travel: Beoplay E8 2.0, Beoplay P2

Millemissen
Top 10 Contributor
Flensborg, Denmark
12,273 Posts
OFFLINE
Bronze Member
noflynn
Not Ranked
5 Posts
OFFLINE
Bronze Member

Wow thanks a million for going through this trouble... have to wait 4 weeks till I can check this out now Angry but I see a glimmer of home.  Feedback then when am done.... thanks again

Page 1 of 2 (18 items) 1 2 Next > | RSS
Beoworld Security Certificate

SSL