Sign in   |  Join   |  Help

How to re-install RX2 dust cover?

rated by 0 users
Not Answered This post has 0 verified answers | 11 Replies | 1 Follower

agoraphone
Not Ranked
11 Posts
OFFLINE
Bronze Member
agoraphone posted on Wed, Mar 28 2018 2:23 AM

Hi all- I have an RX2 turntable that I've disassembled and fixed an issue with. Now I'm trying to reassemble it and the dust cover is proving to be a huge pain. I can't seem to get the screw holes to align, as you can see in this photo from the back (sorry I can't figure out the images on this forum but I think you can click this to enlarge):

It seems like the cover assembly isn't dropping low enough into the turntable back for the screw holes to line up. Here's a view from the inside:

To make matters worse, when I start to close the lid, I hear the snapping of plastic as part of the hinge cracks off. You can see in the below photo how the right part of this hinge is cracked off and the left side is sitting on top of the metal portion of the hinge - I'm guessing it should be underneath instead?

Any tips on getting this dust cover back in place would be appreciated!

Thanks!

All Replies

agoraphone
Not Ranked
11 Posts
OFFLINE
Bronze Member

That last photo is cropped on the right - trying to post it here again:

Hiort
Top 50 Contributor
Sweden
2,136 Posts
OFFLINE
Bronze Member
Hiort replied on Wed, Mar 28 2018 6:35 AM

Its probably the snapped hinge that causes the miss alignment. Not much to do im afraid, other than getting a new dust cover from a donor deck.

 

Dillen
Top 10 Contributor
Copenhagen / Denmark
10,641 Posts
OFFLINE
Founder
Moderator
Dillen replied on Wed, Mar 28 2018 8:46 AM

Difficult to explain, but the hinge block needs to "lean forward" as it is lowered into place.

Martin

agoraphone
Not Ranked
11 Posts
OFFLINE
Bronze Member

Thanks, that makes sense, Martin. I probably shouldn't be trying to lower the cover before it is securely screwed in place. I just thought doing so might help get the mounting screw holes aligned. Any thoughts on how to do so?

Thanks

Dillen
Top 10 Contributor
Copenhagen / Denmark
10,641 Posts
OFFLINE
Founder
Moderator
Dillen replied on Wed, Mar 28 2018 12:51 PM

The holes in the hinge block and the holes in the chassis must align.
To do this, the hinge block must go down a further 2mm or so.
That's what I talk about, when I say that the hinge block must lean a bit forward to get it down into place.

I am not talking about the dustcover. 

Martin

agoraphone
Not Ranked
11 Posts
OFFLINE
Bronze Member

Thanks Martin. I understand that the hinge block must go down further for the holes to align, but I can't see how to make it do so. I tried leaning it forward as you suggest, but it doesn't seem to make a difference. There doesn't seem to be much wiggle room between the hinge block and the chassis, so it doesn't really lean forward much at all - it slides down a bit on the chassis and comes to a solid stop just a bit too high.

There are two screws that hold the hinge block to the dust cover. Would you recommend removing them and seeing if disassembling the hinge block will help it get into place? I just don't know if I'd be able to reassemble it once it's in place again.

Thanks again for your help.

agoraphone
Not Ranked
11 Posts
OFFLINE
Bronze Member

Anyone else have experience installing the lid on an RX2? Should disassemble the hinge before trying to install? Thinking about trying that but I'm worried about getting it back together again.

Saint Beogrowler
Top 150 Contributor
Saint Paul
690 Posts
OFFLINE
Gold Member
If you are struggling with the lid now, you might not want to make it worse for yourself. Take your time, many have struggled with this but it does go back on.
agoraphone
Not Ranked
11 Posts
OFFLINE
Bronze Member

Thanks Peter- I am taking my time but I seem to have hit a dead end. I'm hoping someone who's been through this before has a tip to get the cover hinge to sink lower and align properly.

iantimothy
Not Ranked
3 Posts
OFFLINE
Bronze Member

i just went thru this process. are you still having trouble?

 

agoraphone
Not Ranked
11 Posts
OFFLINE
Bronze Member

I was eventually able to get it back in somehow - can't remember exactly what I did except maybe press really hard. Smile Thanks for checking in though!

Page 1 of 1 (12 items) | RSS
Beoworld Security Certificate

SSL