Sign in   |  Join   |  Help

Beovision 7-40 no picture.

rated by 0 users
Not Answered This post has 0 verified answers | 6 Replies | 2 Followers

gibbo123
Not Ranked
1 Posts
OFFLINE
Bronze Member
gibbo123 posted on Mon, Oct 9 2017 2:36 PM

Hi all,

I've read about my problem but found no solution. 

I can turn on the tv from the remote, TV symbol shows at top of screen, but all that happens is the screen changes to a dark grey like a backlight has come on. DVD works from remote, I can hear the disk spin up but no picture.

Any basics I can check myself?

Any good independent service guys out there in the uk I could contact? My local B&O centre were sympathetic but understandably just want to sell me a new tv.

Any help appreciated,

Stuart

All Replies

Menahem Yachad
Top 75 Contributor
Jerusalem, Israel
1,195 Posts
OFFLINE
Bronze Member

Stuart

First place to check is the PSU PCB.

Then the T-CON PCB

And finally the Inverter PCB

Contact me directly  (Contact member) to send me pictures of the PCB's, and I'll be able to help.

 

flux
Not Ranked
1 Posts
OFFLINE
Bronze Member
flux replied on Thu, Mar 1 2018 10:15 AM

I have the same issue, how can it be fixed?

dan1969
Not Ranked
24 Posts
OFFLINE
Bronze Member
dan1969 replied on Sun, Oct 13 2019 12:20 AM

Do you know if parts are still available for the beovision 7-40 mk6 type 7744? I think o need a t con

Menahem Yachad
Top 75 Contributor
Jerusalem, Israel
1,195 Posts
OFFLINE
Bronze Member

Send pictures of the PCB's to yachadm AT gmail DOT com

9 LEE
Top 10 Contributor
Eastbourne, UK
7,087 Posts
OFFLINE
Founder
Moderator
9 LEE replied on Sun, Oct 13 2019 10:47 AM

Isn't the T-CON part of the panel on the Mk6?

Fink
Not Ranked
5 Posts
OFFLINE
Silver Member
Fink replied on Sun, Jan 19 2020 9:57 AM

On T-con module is a tiny fuse 'CP' that can be the problem.

It is possible to repair when having removed the metalcover from the T-con module.

Page 1 of 1 (7 items) | RSS
Beoworld Security Certificate

SSL