Sign in   |  Join   |  Help

Beolab 9 - green light but no sound! What's wrong?

rated by 0 users
Not Answered This post has 0 verified answers | 11 Replies | 1 Follower

jans
Top 200 Contributor
Belgium
391 Posts
OFFLINE
Bronze Member
jans posted on Mon, Aug 22 2016 7:56 PM

Dear Beoworlders, 

 

I hope you can help me.

One of my BL9's is not working anymore. The green light comes on when I activate the system, but there is no sound coming out of the speaker. The speaker remains fully silent, not even a small hiss. When putting the system into stand-by, the red light comes on as expected. 

 

I tried to switch all "switches" on the back of the speaker to different positions, but this had no effect. I also tries swapping the speakers to check if the problem could be a cabling problem. However, the other BL9 performs perfectly using the same cables. Therefore, the problem seems to be inside the speaker.

 

Any suggestions what's wrong, and how to repair this problem?

 

Looking forward to hear from your experiences

 

Jan

All Replies

jans
Top 200 Contributor
Belgium
391 Posts
OFFLINE
Bronze Member
jans replied on Tue, Aug 23 2016 6:07 AM
Anyone who could offer some advice?
Esax
Top 500 Contributor
257 Posts
OFFLINE
Bronze Member
Esax replied on Tue, Aug 23 2016 10:03 AM
Are you shore it's green not yellow. If it is yellow then probebly blown tweeter.

Beovision 7-55 MK1 red, Beolab 10 red. Beolab 50, all black. Beolab 17 broken ice. Beolab transmitter. Apple tv4 and apple express 2.

Michael
Top 50 Contributor
Sweden
2,487 Posts
OFFLINE
Bronze Member
jans:

Dear Beoworlders,

I hope you can help me.

One of my BL9's is not working anymore. The green light comes on when I activate the system, but there is no sound coming out of the speaker. The speaker remains fully silent, not even a small hiss. When putting the system into stand-by, the red light comes on as expected.

I tried to switch all "switches" on the back of the speaker to different positions, but this had no effect. I also tries swapping the speakers to check if the problem could be a cabling problem. However, the other BL9 performs perfectly using the same cables. Therefore, the problem seems to be inside the speaker.

Any suggestions what's wrong, and how to repair this problem?

Looking forward to hear from your experiences

Jan

When one of my BL9s stopped working it was because of an electrical board failure. Not the tweeter (that they replaced twice in trying to find the fault).

Have you tried disconnecting the power cable for a few minutes? Perhaps try a bit longer. It might help. It did when my board was problematic.

thankfully for me the boards was replaced under warranty.

Beolab 50, Beolab 20, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9i, BeoPlay H6, EarSet 3i, 
BeoVision Avant 55, BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

jans
Top 200 Contributor
Belgium
391 Posts
OFFLINE
Bronze Member
jans replied on Tue, Aug 23 2016 8:37 PM
Michael:

When one of my BL9s stopped working it was because of an electrical board failure. Not the tweeter (that they replaced twice in trying to find the fault).

Have you tried disconnecting the power cable for a few minutes? Perhaps try a bit longer. It might help. It did when my board was problematic.

thankfully for me the boards was replaced under warranty.

Dear Michael and Exan

The light that comes up is green, so it's probably not a problem with a tweeter, but a failure on the electrical board.

I brought the BL9 to the dealer this afternoon, who confirmed this assumption. He will have a closer look and inform me in the coming days. I will keep you posted on the exact cause and the solution.

My dealer also mentioned that in huis experience the BL9's are fairly robust. So far, he only had 3 failures: 2 tweeters and one motherboard.

P.s. He also had 2 Horizons and one Beovision 14 on display. I am not yet convinced of the Horizon's design (I actually prefer my V1 Cool). However, the BV14 in black with the wooden front is absolutely stunning!

Michael
Top 50 Contributor
Sweden
2,487 Posts
OFFLINE
Bronze Member

Hope they will be able to fix it! I also have the same belief about the BL9. They seem to be quite solid. Nice to hear your thoughts about the Horizon and BV14. I also have a V1 in my bedroom (white 40") and I was thinking about selling it before, now I will keep it. I love the design too!

Beolab 50, Beolab 20, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9i, BeoPlay H6, EarSet 3i, 
BeoVision Avant 55, BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

Millemissen
Top 10 Contributor
Flensborg, Denmark
13,541 Posts
OFFLINE
Bronze Member

@Michael

Getting a bit off-topic, but since all we can do is to wait for the feedback of what is/was wrong with the 9, I'll allow myself a comment on your V1.

I would not sell it either - at least not at the moment.

The Horizon will have to prove itself - the software isn't 'finished', no multiroom support for now etc...

My V1-32 stays, where it is!

MM

There is a tv - and there is a BV.

jans
Top 200 Contributor
Belgium
391 Posts
OFFLINE
Bronze Member
jans replied on Mon, Aug 29 2016 1:18 PM
All

The Power Supply board was defect. The dealer replaced it with a new board, and now everything is fine again!

Apparently it doesn't happen very often that this problem occurs.

Jan

Michael
Top 50 Contributor
Sweden
2,487 Posts
OFFLINE
Bronze Member

Great to hear. May I ask what cost you had to pay? 

Beolab 50, Beolab 20, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9i, BeoPlay H6, EarSet 3i, 
BeoVision Avant 55, BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

jans
Top 200 Contributor
Belgium
391 Posts
OFFLINE
Bronze Member
jans replied on Mon, Aug 29 2016 3:57 PM
Michael:

Great to hear. May I ask what cost you had to pay?

Approx 350€
Jeff
Top 25 Contributor
USA
3,793 Posts
OFFLINE
Silver Member
Jeff replied on Mon, Aug 29 2016 4:34 PM

350 euros for a power supply board seems quite reasonable to me. Yes - thumbs up Thanks for posting the solution and cost, I have BL9s so it's good to know about. Love them a lot.

Jeff

I'm afraid I'm recovering from the BeoVirus. Sad

Michael
Top 50 Contributor
Sweden
2,487 Posts
OFFLINE
Bronze Member
Jeff:

350 euros for a power supply board seems quite reasonable to me. Thanks for posting the solution and cost, I have BL9s so it's good to know about. Love them a lot.

Jeff

Beovirus victim, it's gotten to be too much to list!

Same for me! Thanks for the price and repair info Smile.

Reasonable price for that kind of speakers absolutely.

Beolab 50, Beolab 20, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9i, BeoPlay H6, EarSet 3i, 
BeoVision Avant 55, BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

Page 1 of 1 (12 items) | RSS
Beoworld Security Certificate

SSL