Sign in   |  Join   |  Help

Beogram 6500 fuse constantly blowing

rated by 0 users
Not Answered This post has 0 verified answers | 46 Replies | 2 Followers

Steve
Not Ranked
Cape Town
73 Posts
OFFLINE
Bronze Member
Steve posted on Tue, Jul 26 2016 7:15 PM

Hi 

 

I've recently moved house - and my Beogram 6500 has blown two fuses. It was working when I moved in, but every night when I come home the turntable won't power up and fuse blown. The first time I replaced fuse it played fine all evening.. but then tonight I come home and the new fuse is gone. Is this a power / surge issue in my apartment block.. or something problematic with the electronics?

 

any advice appreciated!

steve

All Replies

kimhav
Top 500 Contributor
Malmo, Sweden
300 Posts
OFFLINE
Gold Member
kimhav replied on Fri, Apr 16 2021 9:27 PM

Friday evening and Beogram reparation time Smile So this evening I replaced TR6, D2, D3 and D4 and with that the BG6500 once again works fine and also noticed that chassis bulb (10IL1) also worked again (I did also previously replace TR3-TR5).

While on it, I also replaced the 10uF on the motor PCB including replacing the motor suspension rubber bushing which was quite try and was easy to deform by applying some pressure to them. Thanks Martin for getting these manufactured including helping out with several other parts.

Also thanks to Menahem who helped out with cap-kit for the PCB1 and PCB2 including the RIAA board which is next up for re-cap and fixing.

It's a pity that there isn't any karma button in this forum, since both Martin and Menahem would get a lot of +1 karma if it would be possible; so thanks to both of you taking the time to support the Bang Olufsen community!!

Menahem Yachad
Top 75 Contributor
Jerusalem, Israel
1,226 Posts
OFFLINE
Bronze Member

Kim,

I am humbly honored by your kind words.

Thank you.

The truth is that ALL the members are a part of the success of this forum.

Page 4 of 4 (47 items) < Previous 1 2 3 4 | RSS
Beoworld Security Certificate

SSL