Reply To: Beolab 28 to Theatre

#12981
Razlaw
BRONZE Member
  • Topics Started 5
  • Total Posts 109

    I have 28s connected to the Theatre.  My connections are one PL to left, a second PL to right, one Ethernet to left, a second Ethernet to right.  I have heard that there is an issue with having the 28s directly cabled to each other when connected to a Theatre.  Additionally, ensure both are on the same software.  There was a recent update from version 1.8xxxxx to 2.3.4xxxxx. Even though my 28s had been working fine, when the update occurred, only one speaker took the update and then they stopped pairing.  Going into the app it would show both had taken the update but going in to the system overview page of the app showed that the second speaker did not take the update.  I had to do a factory reset of that speaker, remove from the system/app, and reinstall. It immediately took the update.  I had the exact same issue occur with my Emerges. Also, rereading your question, it sounds like you have a PL connected to one speaker, then Ethernet between the two using the Ethernet connections on both? If you are using PL on one, I think you need to run a PL cable to the other. I don’t think they will work with only one connected to PL. You do not mention an Ethernet connection from your router? Also, as suggested by previous post, after cabling my 28s I paired them before adding to the Theatre in the app.

    • This reply was modified 1 month, 1 week ago by Razlaw.
    • This reply was modified 1 month, 1 week ago by Razlaw.
    • This reply was modified 1 month, 1 week ago by Razlaw.
    • This reply was modified 1 month, 1 week ago by Razlaw.