Reply To: New product launch – beosound theatre?

#10562
Mark
BRONZE Member
  • Topics Started 1
  • Total Posts 44

I received my Beosound Theatre, BeoLab 18s, BeoLab 19, and BeoRemote One BT yesterday.

Setup:

The Theatre didn’t have the user manual included as shown in the installation videos.  The video skipped over attaching the side fins which needed to be done. After that it was pretty much as the video showed.  I am using my BeoLab 17s that used to be connected to an Essence MkII, now in wireless mode for the rear speakers.  Once I assembled the BeoLab 18’s and unboxed the 19 and set them in place I plugged everything in.  To my delight doing a scan on the Theatre everything was discovered correctly, and after the calibration all the correct roles were assigned.   As a result of the BeoLab 18’s being assigned front left and right, the corresponding channels on the Theatre are disabled.  I don’t know if that means that the speakers are unused or if they are at least partially assisting the other channels as described in the sound design video from B&O.  This part went pretty smoothly.

Initial Imparessions:

I watched the beginning of The Greatest Showman on 4K disk and it seemed fine, but I am not able to compare it with anything.  I listened to a lot of music, looking for something with a lot of bass.  I came to one song I was really familiar with and I thought it sounded kind of “tinny”. I looked up and saw that the lights on the 18’s and 19 was red.  They evidently shut down.  After rebooting the Theatre I tried again and things sounded better.  I’m not sure why the  front speakers shutdown?  Wireless issue?  I used the B&O app to “Play sound” on all the speakers and noticed it wasn’t playing on the 17’s behind me.  I unplugged the 17’s and then it was fine again.  Music sounded very good and I am pleased with all of it.  I then watched a stereo concert from a blu-ray that I ripped to AppleTV.  It was really good, but being stereo not really any rear channel activity.  I paused and did a “Play sound” just to  check everything.  Again no sounds from the 17’s.  Another unplug and they were working again.

This morning I AirPlay’ed a song to the Theatre and notice all lights were green.  A good sign.  But looking at the rear right the light went from green to red to green again.  I’m not sure what that means.

I paired the BeoRemote One with the Theatre and one of the first things I noticed was a flaky volume control.  I could take the volume all the way down, but I could only raise it a little bit.  The volume control of the Halo worked fine.  I later noticed that this behavior on the BeoRemote One was only this way when I was using AirPlay.  There must be some kind of communication between the AirPlay source and the Theatre that is still a little shaky.  It does work sometimes.

Other odd things I can’t change the settings for the virtulized speakers, up-firing and side firing speakers.  I also can’t find the source list in the B&O app like Steve mentions in his post about the line-in input.

My B&O USB-C adapter didn’t arrive yet so I purchased an Apple variant.  I can’t get it to work yet, so no turntable. Are they different adapters or do I have a setting wrong.  I have to choose source from the Halo.

Things seem ok for the most part but I’m most concerned about the BeoLab 17’s shutting down.  I guess it is probably a wireless issue, but I really want to use wireless if possible.

  • This reply was modified 1 month, 1 week ago by Mark.