Sign in   |  Join   |  Help

Beogram 3000 5903 tone arm stuck in start position and platter won't spin

rated by 0 users
Not Answered This post has 0 verified answers | 11 Replies | 0 Followers

4L86
Not Ranked
Omaha, NE
13 Posts
OFFLINE
Bronze Member
4L86 posted on Fri, Mar 28 2014 9:51 PM

So I got a Beogram 3000 and powered it on and it was working fine but the tone arm wasn't returning all the way to the right and didn't start playing records from the beginning. I pushed the tone arm over all the way to the right when the machine was off (probably not a good idea in hindsight) and now it appears to be stuck and the platter won't turn either. Solutions?

Beogram 3000 5903 with MMC-3

Beomaster 3000 2933

Beovox RL 140's

All Replies

Dillen
Top 10 Contributor
Copenhagen / Denmark
10,912 Posts
ONLINE
Founder
Moderator
Dillen replied on Fri, Mar 28 2014 11:28 PM

Will none of the buttons make the platter turn ?
Even with a record on the platter ?

Martin

4L86
Not Ranked
Omaha, NE
13 Posts
OFFLINE
Bronze Member
4L86 replied on Sat, Mar 29 2014 2:06 AM

Unfortunately none of the buttons will make it turn. I hit 'play' and it won't turn. I set it to both 33 and 45 and hit 'play' and 'turn' but nothing happens. I can hear the belt drive trying to make it turn for a few seconds but then it just stops and turns off. This is all with a record on the platter. I am assuming the the belt drive and the tone arm are somehow linked by the way this problem started. 

Beogram 3000 5903 with MMC-3

Beomaster 3000 2933

Beovox RL 140's

Dillen
Top 10 Contributor
Copenhagen / Denmark
10,912 Posts
ONLINE
Founder
Moderator
Dillen replied on Sat, Mar 29 2014 8:32 AM

Transport safety screws losened ?
Belt correctly fitted ?

Martin

4L86
Not Ranked
Omaha, NE
13 Posts
OFFLINE
Bronze Member
4L86 replied on Sat, Mar 29 2014 7:19 PM

The belt appears to be fitted correctly and I did loosen the transport screws. 

Beogram 3000 5903 with MMC-3

Beomaster 3000 2933

Beovox RL 140's

Dillen
Top 10 Contributor
Copenhagen / Denmark
10,912 Posts
ONLINE
Founder
Moderator
Dillen replied on Sat, Mar 29 2014 7:47 PM

So you can hear the platter motor running for a few seconds but the platter doesn't turn ?
Is that correct?
lift off the platter and check if it really IS the platter motor, you can hear.

If no record is sensed on the platter, the platter motor (and platter) will just rotate for 2-3 seconds
at each attempt of starting the deck. That's normal.

Martin

4L86
Not Ranked
Omaha, NE
13 Posts
OFFLINE
Bronze Member
4L86 replied on Sat, Mar 29 2014 8:32 PM

I lifted the platter off and hit play and the wheel that drives the belt spins for a few seconds but the platter does not. Before I pushed the tone arm to the right to its correct start position it turned fine at both 33 and 45 rpm's.

Beogram 3000 5903 with MMC-3

Beomaster 3000 2933

Beovox RL 140's

Dillen
Top 10 Contributor
Copenhagen / Denmark
10,912 Posts
ONLINE
Founder
Moderator
Dillen replied on Sat, Mar 29 2014 9:51 PM

Cen you spin the platter by hand (gently) or is something blocking it ?

Martin

4L86
Not Ranked
Omaha, NE
13 Posts
OFFLINE
Bronze Member
4L86 replied on Sun, Mar 30 2014 2:33 AM

The platter wasn't turning clockwise smoothly so I turned it counterclockwise. After about a half turn I heard a clicking noise and then the platter turned smoothly clockwise again. Now it appears to working as it did before but a new problem has arisen. The arm still does not return completely to the right to the proper start position and therefor doesn't play records from the beginning. When it reaches the end of the record, the arm does not return to its starting position automatically. It returns after I press 'stop' but it only returns to the edge of the record. Would you have a solution for these problems?

Beogram 3000 5903 with MMC-3

Beomaster 3000 2933

Beovox RL 140's

Milo
Not Ranked
19 Posts
OFFLINE
Bronze Member
Milo replied on Tue, Aug 4 2015 7:38 PM

I have the same problems with the arm, did you eventually manage to fix it?

 

bramble
Top 200 Contributor
342 Posts
OFFLINE
Bronze Member
Issue with the arm on my bg8500 , is the stylus drops off the edge of the record! Surprise Ie like the arm/carriage needs to go a bit further, therefore allowing the needle to catch the groove..... Can it be adjusted? Or do I bin and buy a new deckSad

Beovision 7 40 mk 5 ,beovision 6x3,   beosound 3000, beogram 3300 , 2 x lc2, 2 x beocom 1401, beocom 6000 x 2,  5 x beo4, 

, 4 x beolab 4's, form 2, h2, a2,a1 and a beolab 2 😀😀

 

 

 

Jeff
Top 25 Contributor
USA
3,465 Posts
OFFLINE
Bronze Member
Jeff replied on Wed, Aug 5 2015 1:22 PM

I just started having the same issue with my BG3000, same model as the OP. I looked up the manual and it is a mechanical adjustment on one of the gears/cams but I haven't had a chance to get it on the bench, take it apart, and play with it. I obviously don't listen to LPs much. Adjustment seems fairly straightforward.

Edit: I mean where the arm drops. I have another BG3000 with similar issues to the OP but haven't even started trying to figure out that one yet.

Jeff

I'm afraid I'm recovering from the BeoVirus. Sad

Page 1 of 1 (12 items) | RSS
Beoworld Security Certificate

SSL