Sign in   |  Join   |  Help

Membership renewal problems

rated by 0 users
Not Answered This post has 0 verified answers | 16 Replies | 2 Followers

beoaus
Top 500 Contributor
147 Posts
OFFLINE
Founder
beoaus posted on Sat, Apr 21 2012 8:42 AM

Hi guys, could someone get back to me?

I am a gold founding member. The enquires@beoworld.org is still down and i can't get the payment system to work. Smilar to last year.

Thanks Beoaus.

All Replies

tournedos
Top 10 Contributor
Finland
7,302 Posts
OFFLINE
Gold Member
Moderator

I just renewed mine five minutes ago with a Visa and had no problems.

Are you sure your credit card is set up to allow Internet purchases? Nowadays on more and more cards it is disabled by default (to limit fraud possibilities, I suppose). I had to tick a box in my online bank.

--mika

Keith Saunders
Top 25 Contributor
Little Ann, Hampshire, United Kingdom
5,152 Posts
OFFLINE
Founder
Moderator

beoaus:
I am a gold founding member. The enquires@beoworld.org is still down and i can't get the payment system to work. Smilar to last year.

Your e-mail was received by Lee who forwarded it to me about an hour ago.

I have checked the payments system and no payment transactions have taken place or attempted.

Exactly what does not work with the payment system ? Do you get an error message, what and where does it apparently fail ?

I have just run a test transaction and it worked as expected..

Regards Keith....

frog
Top 150 Contributor
Camberley UK
486 Posts
OFFLINE
Founder
frog replied on Fri, Apr 5 2013 11:05 AM

Same here. the enquiries email bounces back too.

 

I've tried a few times to pay,. but after entering all my credit card details etc (AMEX) and press confirm, the page just hangs and nothing happens. Can you fix? I'm using a Mac withSafari.

Keith Saunders
Top 25 Contributor
Little Ann, Hampshire, United Kingdom
5,152 Posts
OFFLINE
Founder
Moderator

The system is working correctly, but it is likely that your browsers temporary files is holding the old payments web page prior to the recent upgrade which changed the final "Make Payments" page.

When on the final payments page with the "Make Payments" button, before pressing the button use the REFRESH button on your browser, then press "Make Payment". If for some reason that fails, then just delete your temporary internet files via the options setting of your browser.

If, for some reason that also fails, then please email me..

Regards Keith....

YannChris
Top 500 Contributor
Lorient - France
188 Posts
OFFLINE
Bronze Member

Hello!

Same problem for me too and no sucess with the workarounds proposed.

Keith, you've got mail!!

Kind regards,

Yann.

joeyboygolf
Top 25 Contributor
Ely, Cambridgeshire, UK
4,146 Posts
ONLINE
Founder

You have mail from me too.

Regards Graham

stefan
Top 50 Contributor
200 miles from Struer
2,728 Posts
OFFLINE
Founder
stefan replied on Mon, Apr 15 2013 6:52 AM

Keith Saunders:

The system is working correctly, but it is likely that your browsers temporary files is holding the old payments web page prior to the recent upgrade which changed the final "Make Payments" page.

When on the final payments page with the "Make Payments" button, before pressing the button use the REFRESH button on your browser, then press "Make Payment". If for some reason that fails, then just delete your temporary internet files via the options setting of your browser.

If, for some reason that also fails, then please email me..

I tried to renew my membership several times with all options mentioned above, but nothing works....??!!

Also sent you mail, Keith, but no reply.

What else can I do?

Stefan

 

Dave Farr
Top 50 Contributor
France
2,265 Posts
OFFLINE
Bronze Member

I had problems via Google Chrome and Firefox despite trying the 'fixes'.  I contacted Keith who has been working hard on sorting this out.  I actually managed to make the payment just by using an alternative debit card to the original one I tried (a UK card and not a French one via Firefox).

Keith told me he has identified what the problem is and is in the process of fixing it.  Try another card or be patient, I'm sure it will be fixed soon.

Dave.

Mike
Not Ranked
Stuttgart, GERMANY
4 Posts
OFFLINE
Bronze Member
Mike replied on Mon, Apr 15 2013 8:51 PM

stefan:

Keith Saunders:

...

I tried to renew my membership several times with all options mentioned above, but nothing works....??!!

Also sent you mail, Keith, but no reply.

What else can I do?

Stefan

 

Hi Stefan,

maybe you should try a different browser. I was unable to renew my membership using Safari on my Mac (the "Make Payments" button was greyed out all the time). I tried Firefox 18 instead and there was no problem at all.

 

Mike

stefan
Top 50 Contributor
200 miles from Struer
2,728 Posts
OFFLINE
Founder
stefan replied on Mon, Apr 15 2013 9:20 PM

Thanks Mike,

it worked with Firefox.

After a three weeks procedure I succeeded in renewing my Beowoworld membership...:))

This is real Beo..:))))))

Thanks again

Stefan

ps: sent via Firefox.......................

TEL
Not Ranked
40 Posts
OFFLINE
Founder
TEL replied on Mon, Apr 15 2013 9:28 PM

I've tried Google Chrome and Internet Explorer with Mastercard and Visa credit cards and a Visa Debit card and I'm unable to renew Gold membership.

The phone number given on the contact page gives an automated response 'the number you are calling is not available' and I have sent a message via the query page - is there anyway I can renew over the phone?

My renewal date is tomorrow and I would like to keep my '*** f classification.

When I go to renew membership the screen says proceed to step 4 but the payment screen displayed is headed 'Step 3' ?

TEL 

stefan
Top 50 Contributor
200 miles from Struer
2,728 Posts
OFFLINE
Founder
stefan replied on Mon, Apr 15 2013 9:40 PM

Visa card with Firefox on Mac worked for me.

Strange, looks like the Beoworld Team is not very interested in gold members, but I´m sure, they will give you your "f", even if you are late....:))

Good Luck !!

Stefan

Dave Farr
Top 50 Contributor
France
2,265 Posts
OFFLINE
Bronze Member

TEL,

the info I got from Keith was:  'I can also confirm that I have now determined that the problem you and a couple of other members had will only happen with Internet Explorer version 10 (Latest version), latest version of Chrome and the latest version of Safari on a Mac

I have determined the line of code which causes the problem and I will be testing a fix in the coming weeks'.

Try via Firefox or PM Keith.

Dave.

TEL
Not Ranked
40 Posts
OFFLINE
Founder
TEL replied on Mon, Apr 15 2013 10:11 PM

Thanks Dave

Have PM'd Keith

 

TEL

Page 1 of 2 (17 items) 1 2 Next > | RSS
Beoworld Security Certificate

SSL