Sign in   |  Join   |  Help

From Mac stereo to BV7 surround via HDMI

rated by 0 users
Not Answered This post has 0 verified answers | 3 Replies | 2 Followers

Sigmund
Not Ranked
20 Posts
OFFLINE
Bronze Member
Sigmund posted on Sun, Feb 17 2013 8:38 PM

My BeoVision 7 Mk V is set up with surround 5.1 speakers. When the source is stereo I like to have the two channels distributed over all speakers, but when I connect my Mac Mini via HDMI, the center and back speakers are silent.

The same happens with a MacBook connected via Thunderbolt (Mini DisplayPort) to HDMI cable: the result is stereo; two speakers, no center, no back.

One workaround is to use an adapter that joins Thunderbolt video with USB sound into HDMI. When the stereo sound originates from the USB port, not the Thunderbolt port, the sound gets beautifully distributed into 5.1 surround on the TV.

Can anyone please tell me how to activate all speakers when input is stereo Mac sound coming directly from HDMI? Or at least explain what happens here? Thank you.

Sigmund

All Replies

kallasr
Top 50 Contributor
Germany
2,553 Posts
OFFLINE
Bronze Member
did you try Speaker 4 with remote?

Ralf

Living Room: Beosystem 4, Beolab 7-2 (Center), Beolab 9 (Fronts), Beolab 8000 (Rears), no Subwoofer. Screen: Sony KD-85XH9096
Dining Room: Beosound Essence MK II with Beolab 4000 on stands, fed by Amazon Echo Show 8
Home Cinema: Beosystem 4, Beolab 7-4 (Center), Beolab 1 (Fronts), Beolab 4000 (Rears). Projector: Sony VPL-HW55
Home Office: Beosystem 3, Beolab 7-4, Beolab 5000, Screen: Sony KD-55XH9005 on Beovision 7-40 stand, ML to Beosound 9000 MK3 and Beosound 5/Beomaster 5 (1 TB SSD version)
Bedroom: Sony KD-65XH9077, Beosound Essence MK II with Beolab 6002 and Beolab 11 (all white, wall-mounted)

In storage: Beolab 5000/Beomaster 5000 (1960s). 

Hungedu
Top 500 Contributor
United States
165 Posts
OFFLINE
Bronze Member
Hungedu replied on Sun, Feb 17 2013 11:29 PM

On your BV-7, make sure it's set to Speaker 5 mode for video. On your Mac Mini, make sure you have your audio settings correct. You can check by going into your Utilities folder, then select "Audio MIDI Setup", then "Built-In Output" and select "Digital Output". For more details, see this instructional YouTube video that shows you the proper settings:

http://www.youtube.com/watch?v=po-_c7eHrkg

BeoLab 5, BeoVision 7-55 MK2, BeoSound 5 Encore, BeoSound 9000, BeoLab Penta III, BeoLab 8000, BeoLab 6000, BeoLab 2, BeoLab 7-6, BeoSound 8, BeoTime (analog clock), Beo 4 remote.

Sigmund
Not Ranked
20 Posts
OFFLINE
Bronze Member

Yes, Audio MIDI Setup did trick. On HDMI in the left column, Source "BeoVision 7", I set it to 2 channels. The message here must be that there are 2 channels coming through, not 5 or 7 or anything else. The BV7 then understands that center and back channels are missing, not that they are supposed to be silent, and distributes the stereo sound over all speakers. Thank you.

Page 1 of 1 (4 items) | RSS
Beoworld Security Certificate

SSL