Sign in   |  Join   |  Help

Beolab 50 firmware update June 2021

rated by 0 users
Not Answered This post has 0 verified answers | 19 Replies | 1 Follower

Michael
Top 50 Contributor
Sweden
2,575 Posts
OFFLINE
Bronze Member
Michael posted on Fri, Jun 11 2021 9:41 AM

Hello friends,

Just saw my Beolab 50 had a new firmware available to update. I was on 3.0.0.616 and updated to 3.1.0.1001. So far I haven't seen any differences except that the web-UI is dated 2021-06-03 and that I can see both the primary and secondary speakers firmware info in the product info but this might have been added earlier. (I remember that it was sometimes so that only one speaker would update previously). 

One thing that occurred for me was that the speaker got stuck on a dialog asking me to connect the DLP cable between the set but as this has always been there it made no sense, probably just a design glitch in the web interface as a simple manual reload helped (The dialogue suggested turning the power off for 30 seconds for both speakers but this was not necessary).

Beolab 50, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9 3rd Gen, BeoPlay H6, EarSet 3i, 
BeoVision Eclipse Gen 2 55", BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

All Replies

Geoff Martin
Top 150 Contributor
Struer, Denmark
656 Posts
OFFLINE
Bronze Member

Hi,

Just a heads-up that the software is being rolled out regionally over the coming weeks. So, not everyone will see the new version immediately.

Cheers
- geoff

politician
Top 500 Contributor
171 Posts
OFFLINE
Bronze Member

I've now updated my Lab 90s and 50s to the new software.

One disconcerting feature is that the white light on the rear of the master Lab 90 now flashes whenever it is playing, just as it did last year when I had constant problems with a previous version of the software. It's almost as though the master thinks it cannot connect with the slave – but whereas last year the speakers refused to activate at all unless I reloaded the software, they're playing perfectly normally at the moment. I have tried rebooting both speakers a couple of times but it has made no difference to the flashing.

Flere
Top 200 Contributor
Netherlands
345 Posts
OFFLINE
Gold Member
Flere replied on Mon, Jun 21 2021 10:02 PM
Seems V8 of the Technical Sound Guide is available for download.

- Flere

smile and enjoy the moment

politician
Top 500 Contributor
171 Posts
OFFLINE
Bronze Member

I've noticed that my BeoLab 50s have updated themselves to another new firmware version – 3.1.0.1075.

My Lab 90s are not set to update automatically due to the bugs I discovered in 3.1.0.1001 and have been rolled back to 3.0.0.616.

Does anybody know what's new with 3.1.0.1075 and whether it corrects the problems I identified in 3.1.0.1001 (volume turning up very high when anything is played through USB-Audio; flashing white light on rear of Primary BL90)?

Does @GeoffMartin have any input on this?

Michael Kjær
Not Ranked
1 Posts
OFFLINE
Bronze Member

There are several good fixes in version 3.1.0.1075, I'm using it at home both on BL90 and BL50.

 

The things fixed are:

1. Fixed issue (SXL-1194) that sometimes narrow/wide preset settings was not stored correctly in the DSP.

2. Fixed issue (SL-1550) that after 49 days the secondary speaker sometimes stopped playing and would require a power-cycle.

3. Fixed issue (SL-1545) that sometimes the speakers wouldn't turn off if Line-in had a little noise, filter improved.

4. Fixed issue (SL-1548) with network LED was showing the wrong status blinking white, even when network connection was successful.

5. Fixed issue (SXL-1190) with USB audio sync when coming from WPL

6. Fixed issue (SXL-1526) with Powerlink not being selected if UI had been changed from WPL to automatic.

7. Fixed issue (SL-1553) that sometimes ARC values was not stored in the secondary speaker

8. Fixed issue (SL-1534) with the WebUI that had a wrong height in beam control giving it a bad experience with scrolling.

9. Fixed issue (SL-1198) using the service tool where auto-calibrate was failing.

Page 2 of 2 (20 items) < Previous 1 2 | RSS
Beoworld Security Certificate

SSL