Sign in   |  Join   |  Help

Please help me for BEO5 - Windows

rated by 0 users
This post has 10 Replies | 3 Followers

gnlp1964
Not Ranked
Posts 8
OFFLINE
Bronze Member
gnlp1964 Posted: Sun, May 9 2021 7:13 PM

Hello to all users

I got a BEO5 at a very good price, but I'm having trouble setting it up.

I downloaded various versions of the Configuration Tools software from the forum but the problem is that my pc does not recognize the BEO5 when I connect it.

I am really going crazy because it seems strange to me that it is not possible to connect it with Win10.

I would simply like to connect it to a Beosound5, Sony Bravia TV and SkyQ decoder

Nobody has the good heart to help me?

Thanks in advance

Best regards

Weebyx
Top 75 Contributor
Denmark
Posts 1,208
OFFLINE
Bronze Member
Weebyx replied on Mon, May 10 2021 4:46 PM

gnlp1964:

Hello to all users

I got a BEO5 at a very good price, but I'm having trouble setting it up.

I downloaded various versions of the Configuration Tools software from the forum but the problem is that my pc does not recognize the BEO5 when I connect it.

I am really going crazy because it seems strange to me that it is not possible to connect it with Win10.

I would simply like to connect it to a Beosound5, Sony Bravia TV and SkyQ decoder

Nobody has the good heart to help me?

Thanks in advance

Best regards

You need Win7-32 for the Beo5. Beo6 with the latest 6.84 tool, can connect on Win10, the others wont.

/Jacob

Guy
Top 50 Contributor
Buckinghamshire
Posts 2,493
OFFLINE
Gold Member
Guy replied on Wed, Nov 24 2021 3:29 PM

Weebyx:

You need Win7-32 for the Beo5. Beo6 with the latest 6.84 tool, can connect on Win10, the others wont.

/Jacob

Is this definitely the case or is there a workaround?

I recently acquired a Beo5 and have been attempting to update the configuration, but am left with the Beo5 screen showing 'no valid configuration'.

I have been using a 32-bit Win 10 desktop, together with config tool 6.84.  The Beo5 initially connects fine (red cross over arrows disappears) and the config starts to download, but seems to lose the USB connection once it gets to 'Writing Wifi Firmware' (which I am surprised that it is trying to do on a Beo5, not Beo6).

I have also tried a Vista laptop with the same outcome.

I have read most of the forum threads and Keith's advice pages but am no further forward.  Do I need to find a Win7-32 computer?

 

 

Guy
Top 50 Contributor
Buckinghamshire
Posts 2,493
OFFLINE
Gold Member
Guy replied on Wed, Nov 24 2021 7:34 PM

So I have now created a Windows 7 Virtual Machine on my QNAP NAS and ran the Configuration Tool on there.  I had exactly the same result when trying to download the configuration to the Beo5.

I am confused as to why the Tool is 'Writing Wifi Firmware' to the Beo5 anyway - does it think it's a Beo6?

Also, the Beo5 initially connects fine to the Configuration tool, but seems to lose connection during configuration download.  I suppose it could be a battery problem but the remote seemed to have quite good battery performance earlier, and I have tried update just after disconnection from a long period of mains charging.

I am now unsure what to try next!

 

Guy
Top 50 Contributor
Buckinghamshire
Posts 2,493
OFFLINE
Gold Member
Guy replied on Thu, Nov 25 2021 12:14 PM

Anyone?

I have been trying again this morning but am about to give up.  Whatever I try, the Beo5 initially connects fine but seems to lose the USB connection during the configuration download.

Do I need to open up the Beo5 and carry out some sort of 'hard reset' by disconnecting/reconnecting the battery - this seems a bit drastic!

(EDIT:  I have also attempted with version 5.12 of the CT, on both Win10-32 and Win7 VM, with the same results)

Stoobietoo
Top 150 Contributor
Exeter, Devon, UK
Posts 674
OFFLINE
Gold Member

Guy,

Don't give up! and don't open up the remote at this stage! It took me about 10 goes over a week to get my BEO5 back to life!
If you are OK with working with virtual machines, make a Windows XP SP2 32 bit VM with 5.12. The BEO5 will only connect to a 32bit Windows installation and the 5.12 Config Tool was written for XP.

I use ORACLE VirtualBox 6.1 and have 6 VMs set up with various versions of Windows (32bit & 64bit) and various versions of CT tools so I don't have to keep uninstalling. I have BEO5 and BEO6s. VMware Workstation 16 Player.

Please note that the BEO5 needs to be fully charged and the connection to the PC does not charge sufficiently. you can run the battery down quite quickly when trying to program it. Also, although it is a BEO5 I would leave the "Writing WiFi Firmware" running for quite a while.

I cannot remember if it was my BEO 5 or 6 but when it was doing the update, it took what seemed for ever. It loses the connection and seems to hang for about a minute or more, then all of a sudden, pops into life and carries on to completion.

Another thing to remember, is that if you are using a virtual machine, you need to tell the VM to take the USB port automatically because when it disconnects as part of the download, it needs to be able to connect again automatically. I had problems with that in other VMs and in ORACLE you can set it to recognise the BEO5 automatically so when it disconnects and reconnects it is on the USB.

Stoobie

Stoobietoo
Top 150 Contributor
Exeter, Devon, UK
Posts 674
OFFLINE
Gold Member

Take a look in this link to see whach CT Tool you need to use depending on your firmaware level

https://forum.beoworld.org/forums/t/47089.aspx

Stoobie

Guy
Top 50 Contributor
Buckinghamshire
Posts 2,493
OFFLINE
Gold Member
Guy replied on Thu, Nov 25 2021 6:32 PM

Thanks for all that Stoobie - very useful and encouraging!  I had seems some of your posts in other Beo5/6 threads and this is a very useful summary that pulls them together and focusses on the problems that I am experiencing.

I am new to VMs but willing to research and learn further.  Also I will take your advice and stick with CT5.12.

From reading your post, I suspect that there are at least two problems with the current VM Win7 that I have been trying:

- Firstly I have been trying to use Win7 in a Win XP compatibility mode, whereas using a proper Win XP SP2 would perhaps be better.

- Secondly the implementation of VM on my QNAP has only a manual USB connection (as far as I can tell!), and I have to keep re-connecting it.  This suggests that the issue highlighted in your last paragraph may well be a problem. 

So I will try a 'true' WinXP SP2 VM with auto USB connection.  I'll investigate ORACLE and WMware.

Out of frustration I will probably give it a rest for the next day or so, but will certainly be back to report progress once I have investigated further.

Thanks once again!  Regards Guy

 

 

Guy
Top 50 Contributor
Buckinghamshire
Posts 2,493
OFFLINE
Gold Member
Guy replied on Thu, Nov 25 2021 6:35 PM

Stoobietoo:

Take a look in this link to see whach CT Tool you need to use depending on your firmaware level

https://forum.beoworld.org/forums/t/47089.aspx

Stoobie

Thanks - pretty sure that the Firmware is 1.02 (or something similar) so I will stick with 51.2 for now, but maybe try 6.84 if I have no luck.

Stoobietoo
Top 150 Contributor
Exeter, Devon, UK
Posts 674
OFFLINE
Gold Member

Both ORACLE and VMWare are free.I think you need to install the Virtual Machine on your PC. I don't think having it installed on on a NAS will work.

I would Try ORACLE first. as you can set the USB connetions easier in there. Search ORACLE 6.1 installation on You Tube. it will explain any "extension packs" etc you need to download as well.

Definitely give it a bit of a rest, but leave the BEO5 charging.

To check the firmware press and hold the Red Dot and then press the Center button.

Good luck

Stoobie

 

Guy
Top 50 Contributor
Buckinghamshire
Posts 2,493
OFFLINE
Gold Member
Guy replied on Thu, Nov 25 2021 8:02 PM

Yes I'll try ORACLE on my PC first - the NAS is just another complicating factor, and I have enough of those!

The Beo5 is back on charge, and I can't now check the Firmware because the display just says 'No Valid Configuration!' whenever I pick it up or press any buttons!

Thanks again! 

Page 1 of 1 (11 items) | RSS
Beoworld Security Certificate

SSL