Sign in   |  Join   |  Help

Stylus sliding on my Beogram 9500

rated by 0 users
This post has 11 Replies | 2 Followers

Bisonman
Not Ranked
Posts 8
OFFLINE
Bronze Member
Bisonman Posted: Tue, Mar 30 2021 11:39 PM

Hi all, very new to this forum,signed up today.

I recently bought some B&O equipment, mostly because I have a Beocenter 9500 since years in our summerhouse and it´s a fantastic machine.

One of the things I bought on an auction was a Beogram 9500with a MMC2 stylus.

It seem to be working fine, starts, moves in all directions but there is very very little sound coming out and the sound is distorted.

When lowering the stylus it finds the track but soon after it starts to slide towards the center of the record.

So , I bought one of these USB magnifiers or microscope and compared to outher styluses , Denon 160 and a Goldring something it looks fine.

Suspension problems or...?

I hesitate to buy a new stylus for XXX € without knowing if there is another problem

Any help would be much appreciated.

  • Filed under:
Dillen
Top 10 Contributor
Copenhagen / Denmark
Posts 12,921
OFFLINE
Founder
Moderator
Dillen replied on Wed, Mar 31 2021 8:20 AM

Sounds like a missing or completely worn down stylus tip or a broken suspension.
Send the cartridge in for re-tip'ing.

Martin

Brian
Top 500 Contributor
London/Aarhus
Posts 214
OFFLINE
Bronze Member
Brian replied on Wed, Mar 31 2021 9:31 AM

I’ve got a completely refurbished MMC2, never used. I have no use for it so happy to sell.

Stoobietoo
Top 150 Contributor
Exeter, Devon, UK
Posts 638
OFFLINE
Gold Member

Are you able to post photos of the stylus from your USB magnifier. Maybe a couplephotos from of angles. This will at least help people see if it is fine, and make other suggestions if it is fine.

Stoobie

Bisonman
Not Ranked
Posts 8
OFFLINE
Bronze Member
Bisonman replied on Wed, Mar 31 2021 7:45 PM

Hi Brian, if indeed the stylus is gone I´m interested

Bisonman
Not Ranked
Posts 8
OFFLINE
Bronze Member
Bisonman replied on Wed, Mar 31 2021 8:22 PM

Hmm,not sure if this was the best way..., anyway here´s some photos.

I´m not sure how to judge 

 

 

 

 

Bisonman
Not Ranked
Posts 8
OFFLINE
Bronze Member
Bisonman replied on Wed, Mar 31 2021 8:23 PM

Did not work,I´ll try an other method

Bisonman
Not Ranked
Posts 8
OFFLINE
Bronze Member
Bisonman replied on Wed, Mar 31 2021 8:23 PM

Did not work,I´ll try an other method

Bisonman
Not Ranked
Posts 8
OFFLINE
Bronze Member
Bisonman replied on Wed, Mar 31 2021 8:23 PM

Did not work,I´ll try an other method

Bisonman
Not Ranked
Posts 8
OFFLINE
Bronze Member
Bisonman replied on Wed, Mar 31 2021 8:25 PM

Bisonman
Not Ranked
Posts 8
OFFLINE
Bronze Member
Bisonman replied on Wed, Mar 31 2021 8:54 PM

I´ve tried to add pictures but no luck.

Anyone who knos how to make it works???

Stoobietoo
Top 150 Contributor
Exeter, Devon, UK
Posts 638
OFFLINE
Gold Member
Stoobietoo replied on Wed, Mar 31 2021 11:32 PM

This might  help

https://forum.beoworld.org/wikis/memberspages/upload-pics.aspx

Stoobie

Page 1 of 1 (12 items) | RSS
Beoworld Security Certificate

SSL