Sign in   |  Join   |  Help

Beogram CDX lid won't open

rated by 0 users
Not Answered This post has 0 verified answers | 1 Reply | 0 Followers

StarBandO
Not Ranked
3 Posts
OFFLINE
Bronze Member
StarBandO posted on Tue, Mar 30 2021 7:07 PM

Hi,

 

We have a problem with our Beogram CDX player.  When you press the eject button the unit lights up but won't open. 

 

I managed to get it open manually - the motor worked once the lid was slightly lifted and closed properly.

 

It managed to play a cd although we had to press the lid a bit before it properly read the CD.

 

Any idea's what's likely causing the issue?  Or is it best getting it repaired?

All Replies

Pindsen
Not Ranked
Denmark
35 Posts
OFFLINE
Bronze Member

It can be caused by one or more of three things:

1) The two black dots under the lid tend to get sticky and then they hold the lid. Best is to remove them. Some say the dots underneath a Beolink 1000 can be used but I have never tried that.

2) The gear wheel is worn and needs replacement

3) The position switches is damaged and needs replacement

/Pindsen

Page 1 of 1 (2 items) | RSS
Beoworld Security Certificate

SSL