Sign in   |  Join   |  Help

BL 18/19 to Samsung TV - No Sound

rated by 0 users
Answered (Not Verified) This post has 0 verified answers | 6 Replies | 1 Follower

jabell
Not Ranked
23 Posts
OFFLINE
Bronze Member
jabell posted on Wed, Feb 17 2021 8:22 PM

Hello,

 

I have configured my 18s/19 to a Transmitter 1, which is connect to a Core. I'm trying to connect my core to my Samsung TV using optical but it's not working.

 

I have the following settings:

B&O Core App (under configure menu)

1. Sound > Optical - Disable delay

2. Sound > Speaker Setup - Beolab 18 selected from the menu; check marked "wireless transmitter box"'

3. Your Content > Sources - Optical

 

Samsung TV

1. Sound Output > Optical

2. Digital Output Audio Format > PCM

 

 

I'm planning on controlling the volume via Core App, but can't seem to get any sound going.  Any thoughts?

 

 

 

All Replies

mbolo01
Top 50 Contributor
Louannec - France
1,904 Posts
OFFLINE
Gold Member
Maybe a stupid question, but as it already happened to other users I’m asking: Is the Samsung TV connected to the Core’s Optical/Line-In? Not to be confused with Core’s optical Out port.

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

jabell
Not Ranked
23 Posts
OFFLINE
Bronze Member
jabell replied on Wed, Feb 17 2021 9:17 PM

I believe so. I have added the attachment onto the end of the optical cable that is to be inserted into the Core. I have plugged the cable into the Optical/Line-in. I have check marked "optical" and "line in" on the app, but nothing happens. 

 

mbolo01
Top 50 Contributor
Louannec - France
1,904 Posts
OFFLINE
Gold Member
Looks ok.

What do you have for Core Sound/Optical configuration?

As you cannot control the volume from the TV side, you’ll have to control it via the B&O App (as you wrote in another post, an Essence remote could also do the job, this little device is very convenient for more than controlling the sound)

Here is my sound/optical setup:

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

jabell
Not Ranked
23 Posts
OFFLINE
Bronze Member
jabell replied on Wed, Feb 17 2021 9:31 PM

My Core Sound/Optical configuration matches what you have. I am perplexed. Sad Perhaps it's a faulty optical cable. However, I literally just purchased it last night, brand new from Best Buy. I can't think of anything else, though. 

jabell
Not Ranked
23 Posts
OFFLINE
Bronze Member
Answered (Not Verified) jabell replied on Wed, Feb 17 2021 11:36 PM
Suggested by Curly

Great news! I have swapped the "powerlink to phono" cable with a "powerlink to powerlink" cable between the transmitter and Core, and the TV audio works now! And I can control the volume smoothly with the B&O app.

 

I'm still using the same optical cable between the TV and the Core, so the difference is with the connection between the Core and Transmitter. Not sure why the "powerlink to phono" cable wouldn't work. 

 

Thanks for your help. 

mbolo01
Top 50 Contributor
Louannec - France
1,904 Posts
OFFLINE
Gold Member
Bravo!

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

Page 1 of 1 (7 items) | RSS
Beoworld Security Certificate

SSL