Sign in   |  Join   |  Help

Questions/Advice from Beolab 50 Owners

rated by 0 users
Not Answered This post has 0 verified answers | 60 Replies | 3 Followers

BeoJosh
Not Ranked
42 Posts
ONLINE
Bronze Member
BeoJosh posted on Thu, Jan 28 2021 1:12 AM

Sorry for the long post, but I’d love some advice from Beolab 50 owners. In my living room, I have a Harmony 77 with 2 pairs of 18s and a 19 for surround sound and music. I love the setup and have no complaints, but after recently auditioning the Beolab 90s and 50s, I can’t get them out of my mind. I don’t have the room (or the budget) for the 90s, but I could potentially make the 50s work as the front left and right, and move that pair of 18s (and the 19) elsewhere in our home. 

I’d be sold already if it wasn’t for the layout of our living room. It isn’t typical, in that the sofas are parallel to each other—and perpendicular to the Harmony on one wall and the fireplace on the opposite wall—so there is no real sweet spot. For my music setting, I have the surrounds set to left and right, inverted from the left and right fronts, so no matter which sofa you’re on you have nice stereo imaging.

My dilemma has been that in my limited experience with them, and in everything I’ve read here, the 50s really shine in narrow mode—which doesn’t seem all that useful to me without a sweet spot. Therefore, I think I’d really only have the 50s in wide mode. My dealer says the room calibration alone is worth the upgrade, but given the investment it seems like a lot of money for a pair of speakers that I can’t take full advantage of. It’s like buying a sports car, but only driving under the speed limit. (And I like to drive fast.)

So my questions to owners of the 50s are a) Do you think the 50s in this scenario used exclusively in wide mode is enough of an improvement over my current setup to justify the money—and if so, why? And b) If yes, would you use the 50s on their own for music, or keep them in the same setup with the surround 18s where I have them as inverted L/R.

Thanks for reading—and the advice!

 

All Replies

Sandyb
Top 50 Contributor
2,036 Posts
ONLINE
Bronze Member
Sandyb replied on Tue, Feb 16 2021 7:33 PM
Mikipidia:

Or Geoff isn’t the one writing (all) the software New: Beovision Harmony, Beolab 50's, Beolab 18's, Beolab 17's, Beolab 3's, Beosound 9000 mk3, Beosound Stage & LG, Beosound 2, Beoplay M3, Beoplay A1, Beoplay H4 gen 2, Beoplay E8 3.0

Mikipedia on YouTube: https://www.youtube.com/c/Mikipedia

mikipedi4 on Twitch: https://www.twitch.tv/mikipedi4

Old: Beovision Eclipse, Beolab 1's, Beolab 2, Beovision 10-46, Overture 2300, beolab 8000's, Beolab 4000's, Beovision avant 32" etc. etc.

Wait, are you suggesting there isn’t a BL50 conspiracy of silence going on?

Heaven forbid.....
Esax
Top 500 Contributor
309 Posts
OFFLINE
Bronze Member
Esax replied on Tue, Feb 16 2021 8:45 PM
beolion:

Or. This is the final one, the one that solved all problems ;-)

In software there never have and never will bee a final one.

Beovision 7-55 MK1 red, Beolab 10 red. Beolab 50, all black. Beolab 17 broken ice. Beolab transmitter. Apple tv4 and apple express 2.

Michael
Top 50 Contributor
Sweden
2,573 Posts
OFFLINE
Bronze Member
Hm yes I’ve had huge issues with the firmware on the lastest edition as well. First I couldn’t control bass and treble with the app or web page but that was resolved with a factory reset.

But I still have random really weak bass and sometimes really boomy bass. It seems definitely stronger in narrow mode more often. Weird I think as I would like bass to be there at least as much in a party mode (wide).

Most of the times I experience issues with the sound quality I have friends over so I can’t start to change to much but yeah, it seems to be some issues.

But more than that, it’s 30 000 euro speakers and the company is pretty quiet about the issues and potential fixes or what might have (perhaps) solved it. I was even refused a manual to install them.

I’m happy Geoff talks a lot about the speakers but honestly almost everything I have leery about them is through him as B&O seemingly want them to be like secret magic. It makes me really sad because the speakers are really good but the communication and support really is everything butUnsure.

Beolab 50, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9 3rd Gen, BeoPlay H6, EarSet 3i, 
BeoVision Eclipse Gen 2 55", BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

Sandyb
Top 50 Contributor
2,036 Posts
ONLINE
Bronze Member
Sandyb replied on Tue, Feb 16 2021 9:53 PM

What does your dealer say about the issues you are having?

 

Michael:
Hm yes I’ve had huge issues with the firmware on the lastest edition as well. First I couldn’t control bass and treble with the app or web page but that was resolved with a factory reset.

 

 

But I still have random really weak bass and sometimes really boomy bass. It seems definitely stronger in narrow mode more often. Weird I think as I would like bass to be there at least as much in a party mode (wide).

 

 

Most of the times I experience issues with the sound quality I have friends over so I can’t start to change to much but yeah, it seems to be some issues.

 

 

But more than that, it’s 30 000 euro speakers and the company is pretty quiet about the issues and potential fixes or what might have (perhaps) solved it. I was even refused a manual to install them.

 

 

I’m happy Geoff talks a lot about the speakers but honestly almost everything I have leery about them is through him as B&O seemingly want them to be like secret magic. It makes me really sad because the speakers are really good but the communication and support really is everything butUnsure.

 

Mikipidia
Top 50 Contributor
1,928 Posts
OFFLINE
Bronze Member
Have you considered it could be the source material? And if that can’t be it, have you tried the same source material at your dealer to see if those act the same?

New: Beovision Harmony, Beolab 50's, Beolab 18's, Beolab 17's, Beolab 3's, Beosound 9000 mk3, Beosound Stage & LG, Beosound 2, Beoplay M3, Beoplay A1, Beoplay H4 gen 2, Beoplay E8 3.0

Mikipedia on YouTube: https://www.youtube.com/c/Mikipedia

mikipedi4 on Twitch: https://www.twitch.tv/mikipedi4

Old: Beovision Eclipse, Beolab 1's, Beolab 2, Beovision 10-46, Overture 2300, beolab 8000's, Beolab 4000's, Beovision avant 32" etc. etc.

Geoff Martin
Top 150 Contributor
Struer, Denmark
640 Posts
OFFLINE
Bronze Member

Michael:

Thanks, and sadly I guess the lack of response to the firmware means that there is an issue with it that can not be discussed? 😬🙈

Hi,

There are two answers to this not-really-a-question.

Please remember that I'm not a short-circuit through B&O's customer support. I work on the development end, so things that are happening on the market end are usually things that I don't know much about off-hand. So, typically, I don't not know the answer to questions like this. I'm only here on Beoworld to help with more general questions and topics.

I did ask some people at work yesterday about why you might be having this problem - but I can see that someone else has already given the answer in this thread. If you are certain that you have the latest software update, and you are still experiencing this issue, please let customer support know so that the issue can be logged in their system and tracked appropriately.

Cheers
-geoff

Michael
Top 50 Contributor
Sweden
2,573 Posts
OFFLINE
Bronze Member
Mikipidia:

Have you considered it could be the source material? And if that can’t be it, have you tried the same source material at your dealer to see if those act the same? New: Beovision Harmony, Beolab 50's, Beolab 18's, Beolab 17's, Beolab 3's, Beosound 9000 mk3, Beosound Stage & LG, Beosound 2, Beoplay M3, Beoplay A1, Beoplay H4 gen 2, Beoplay E8 3.0

Mikipedia on YouTube: https://www.youtube.com/c/Mikipedia

mikipedi4 on Twitch: https://www.twitch.tv/mikipedi4

Old: Beovision Eclipse, Beolab 1's, Beolab 2, Beovision 10-46, Overture 2300, beolab 8000's, Beolab 4000's, Beovision avant 32" etc. etc.

Yes, and it is not. Especially as it differs so much between wide and narrow. And as I said sometimes the sound is even better from the tv speaker itself. Which is odd as the bass can simply wanish. I don’t know why. Maybe it’s a powerlink input issue or something else but an issue is somewhere and probably not in my config itself. I had the same experience before I replaced the old tv with an eclipse.

Beolab 50, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9 3rd Gen, BeoPlay H6, EarSet 3i, 
BeoVision Eclipse Gen 2 55", BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

Michael
Top 50 Contributor
Sweden
2,573 Posts
OFFLINE
Bronze Member
Geoff Martin:

Hi,

There are two answers to this not-really-a-question.

Please remember that I'm not a short-circuit through B&O's customer support. I work on the development end, so things that are happening on the market end are usually things that I don't know much about off-hand. So, typically, I don't not know the answer to questions like this. I'm only here on Beoworld to help with more general questions and topics.

I did ask some people at work yesterday about why you might be having this problem - but I can see that someone else has already given the answer in this thread. If you are certain that you have the latest software update, and you are still experiencing this issue, please let customer support know so that the issue can be logged in their system and tracked appropriately.

Cheers -geoff

Hehe thanks :)

Well, the support staff usually replies and tells me they can not give me info, manuals etc and refers to the speakers as flagship speakers and therefore won’t give out info as usual.

I’ve been updating the firmware though but for many months had an issue that was never officially talked about. However I still do notice that bass is lacking sometimes and in different modes so it’s probably a fault somewhere but nobody seem to think so except for me so I guess the problem is with me Smile.

Beolab 50, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9 3rd Gen, BeoPlay H6, EarSet 3i, 
BeoVision Eclipse Gen 2 55", BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

BeoJosh
Not Ranked
42 Posts
ONLINE
Bronze Member

Michael, I'm sorry to hear about your issues. Perhaps you've already done so, but have you spoken with your dealer about your concerns, rather than customer support? My dealer has been incredibly supportive through the purchase, install and troubleshooting of all my B&O equipment, and has liaised with Denmark on my behalf on some specific issues I was having with regard to my turntables not playing correctly from Core via multiroom to my Harmony TVs. He was able to have them diagnose remotely and send me some beta software to my specific equipment that corrected the issues prior to the official software update. Perhaps the same can be done in this case? Good luck!

Mikipidia
Top 50 Contributor
1,928 Posts
OFFLINE
Bronze Member
Michael:

Yes, and it is not. Especially as it differs so much between wide and narrow. And as I said sometimes the sound is even better from the tv speaker itself. Which is odd as the bass can simply wanish. I don’t know why. Maybe it’s a powerlink input issue or something else but an issue is somewhere and probably not in my config itself. I had the same experience before I replaced the old tv with an eclipse. Beolab 50, Beolab 8000 x 2, Beolab 4000 x 2, BeoSound Core, BeoSound 9000, BeoSound Century, BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9 3rd Gen, BeoPlay H6, EarSet 3i, BeoVision Eclipse Gen 2 55", BeoPlay V1-40, BeoCom 6000 and so much else :)

So did you or did you not test it with the exact same media at your dealer? And if so, you’re saying his speakers behaved totally different?

Not saying they can’t have a fault, I of all people know that, but many things are very unclear.

New: Beovision Harmony, Beolab 50's, Beolab 18's, Beolab 17's, Beolab 3's, Beosound 9000 mk3, Beosound Stage & LG, Beosound 2, Beoplay M3, Beoplay A1, Beoplay H4 gen 2, Beoplay E8 3.0

Mikipedia on YouTube: https://www.youtube.com/c/Mikipedia

mikipedi4 on Twitch: https://www.twitch.tv/mikipedi4

Old: Beovision Eclipse, Beolab 1's, Beolab 2, Beovision 10-46, Overture 2300, beolab 8000's, Beolab 4000's, Beovision avant 32" etc. etc.

Michael
Top 50 Contributor
Sweden
2,573 Posts
OFFLINE
Bronze Member

Mikipidia:
Michael:

Yes, and it is not. Especially as it differs so much between wide and narrow. And as I said sometimes the sound is even better from the tv speaker itself. Which is odd as the bass can simply wanish. I don’t know why. Maybe it’s a powerlink input issue or something else but an issue is somewhere and probably not in my config itself. I had the same experience before I replaced the old tv with an eclipse. Beolab 50, Beolab 8000 x 2, Beolab 4000 x 2, BeoSound Core, BeoSound 9000, BeoSound Century, BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9 3rd Gen, BeoPlay H6, EarSet 3i, BeoVision Eclipse Gen 2 55", BeoPlay V1-40, BeoCom 6000 and so much else :)

So did you or did you not test it with the exact same media at your dealer? And if so, you’re saying his speakers behaved totally different?

Not saying they can’t have a fault, I of all people know that, but many things are very unclear.

First off, no I have not been to my dealer. I have no real focus on specific media but I trust my ears and I notice pretty clearly that the speakers have two very different sounds in narrow vs wide. Not just that but sometimes they seem to boot up and play in one way, and another time in another way. It is like they forgot to adapt the correct values to the bass speakers on some boots, and sometimes not. I can't really explain it as I can't see the logs or know anything about how they work - I can just hear. 

The way they sound have changed several times through the firmware versions and as far as I know there has not been any info included with the firmware on that has changed which makes it even harder to track and test.

I would prefer to be able to be more clinical and compare my speakers to other speakers but I don't think there is a mechanical fault at my end. I have two speakers and both sound the same, so I think the issues is software based.

Now, if the issues is in the speakers, the TV (Eclipse mk2) or somewhere else I do not know. Maybe the issues is worse over power link for example? I know that they use less processing over that link. I also find it somehow both ironic and stupid that B&O haven't found another way link their best speakers with their own TVs that probably stands for the main source in most cases.. 

Anyway, I have a core and I will try it with the speakers as soon as I get a quality toslink cable that is long enough. I wish B&O worked on the DLP solution so the core could speak with the speakers that way. But that seems no go. Also seems no go that the Core and BL50 could communicate volume in tandem - this is why I still haven't connected it, as it would require me to change the volume on the speakers themselves, via the app or an extra IR remote and eye. If the Core could just over usb or whatever send the volume data to the speakers all would be good but... nope.

I do like my speakers in the end, but not knowing if they will sound correct or not is a bit annoying. And that B&O is so extremely quiet about it is more annoying still. I have a good relationship with my dealer but they aren't experts in the software and I don't like talking with middle hands, so I prefer going straight for B&O but I find that the support staff rarely know much themselves either and they won't connect us customers with their developers.

Maybe I am the only one who has the issues and then so be it, but I really do not think so.

A small side note, I noticed after updating the firmware in my Eclipse mk2 that on surround sampling of stereo that there now is a small sound defect of some midrange sounds that seem to be chopped off strangely between the different speakers. If I change to stereo the sound "woup" disappears and sound is good again.

Its something else but a weird thing :D. Its not easy having perfect pitch.  

Beolab 50, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9 3rd Gen, BeoPlay H6, EarSet 3i, 
BeoVision Eclipse Gen 2 55", BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

Esax
Top 500 Contributor
309 Posts
OFFLINE
Bronze Member
Esax replied on Wed, Feb 17 2021 6:16 PM
If you got the latest software 3.0.0.616. Tell your dealer to tell b&o to update your speaker again.

This version corrected the problems.

Beovision 7-55 MK1 red, Beolab 10 red. Beolab 50, all black. Beolab 17 broken ice. Beolab transmitter. Apple tv4 and apple express 2.

Curly
Top 500 Contributor
FL, USA
227 Posts
OFFLINE
Gold Member
Curly replied on Wed, Feb 17 2021 6:22 PM

I envisioned buying BL50 from a forum member privately (used) but seeing these threads makes me think I may have to pay significantly more to buy from a dealer to ensure I get support if something funky happens to the speakers... eeeek...

Currently: BeoLab 17, BeoLab 18, BeoSound Core, BeoPlay S8 Connection Hub, Essence Remote

Previously: BeoSound 1 non-GVA

Esax
Top 500 Contributor
309 Posts
OFFLINE
Bronze Member
Esax replied on Wed, Feb 17 2021 6:33 PM
Curly:

I envisioned buying BL50 from a forum member privately (used) but seeing these threads makes me think I may have to pay significantly more to buy from a dealer to ensure I get support if something funky happens to the speakers... eeeek...

Currently: BeoLab 17, BeoLab 18, BeoSound Core, BeoPlay S8 Connection Hub, Essence Remote

Previously: BeoSound 1 non-GVA

My dealer would help me even with things I bought second hand. It’s in his best interest if he like to keep my as a costumer.

Beovision 7-55 MK1 red, Beolab 10 red. Beolab 50, all black. Beolab 17 broken ice. Beolab transmitter. Apple tv4 and apple express 2.

Michael
Top 50 Contributor
Sweden
2,573 Posts
OFFLINE
Bronze Member
Esax:

If you got the latest software 3.0.0.616. Tell your dealer to tell b&o to update your speaker again.

This version corrected the problems. Beovision 7-55 MK1 red, Beolab 10 red. Beolab 50, all black. Beolab 17 broken ice. Beolab transmitter. Apple tv4 and apple express 2.

I already have the latest version. I still notice differences in the sound, and there was issues with that before as well.

But there is still more weird issues such as the impossibility to disable WiFi. It’s really weird that it’s so badly programmed. Can’t be so hard to do it right.

Regarding the questionable solutions, here is that email:

Dear Michael,

Thank you for reaching back out to us, I can completely understand your frustration and I totally do understand your point of view.

I am sorry but the only information I am allowed to share with you is the following. Therefore, we still need you to contact a local retailer for further installation procedures. We are sorry for the inconvenience but our hands are tied.

Beolab 50, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9 3rd Gen, BeoPlay H6, EarSet 3i, 
BeoVision Eclipse Gen 2 55", BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

Page 3 of 5 (61 items) < Previous 1 2 3 4 5 Next > | RSS
Beoworld Security Certificate

SSL