Sign in   |  Join   |  Help

Beosound 5 and Penta 3

rated by 0 users
Not Answered This post has 0 verified answers | 3 Replies | 1 Follower

Beheit
Not Ranked
19 Posts
OFFLINE
Bronze Member
Beheit posted on Mon, Dec 7 2020 8:26 PM

Hi all,

I have a Beosound 5 and a Beomaster 5 connected to a Beomaster 5500, since I didn't have a powered speakers,

Yesterday I got two beautiful Penta 3. I connected every thing but I didn't find the sound amazing, I know that those speakers should sound great, I need some help to find out where did I go wrong. I adjusted the bass treble loudness still to no avail.

 

Regards,

 

John Beheit

 

All Replies

Champbeo
Not Ranked
40 Posts
OFFLINE
Gold Member

Hi

Check the state of the speaker units.

 

Remove the cloth fronts.

See if the units are intact. Old Penta units are often not in a very good state and that can affect the sound quality. 

Beheit
Not Ranked
19 Posts
OFFLINE
Bronze Member
Beheit replied on Fri, Dec 11 2020 1:17 PM

Thank you for your answer, everything looks Ok, I plugged them and was not happy with it so I plugged back my old BOSE speakers, but now thinking about it again, those speakers were in a storage for 10 years, is it possible that I need to play them for few hours before judging?

Thanks for your advise.

Beheit
Not Ranked
19 Posts
OFFLINE
Bronze Member
Beheit replied on Fri, Dec 11 2020 1:18 PM

Thank you for your answer, everything looks Ok, I plugged them and was not happy with it so I plugged back my old BOSE speakers, but now thinking about it again, those speakers were in a storage for 10 years, is it possible that I need to play them for few hours before judging?

Thanks for your advise.

Page 1 of 1 (4 items) | RSS
Beoworld Security Certificate

SSL