Sign in   |  Join   |  Help

Beocom 6000 mk 2

rated by 0 users
Not Answered This post has 0 verified answers | 1 Reply | 2 Followers

Not Ranked
1 Posts
Bronze Member
Fraser posted on Sun, Nov 22 2020 9:07 AM

I just bought an additional handset beocom 6000 to replace one that had seen better days.

This is a mark 2 one with the Int button on it and it has a different menu layout. In trying to register it it comes up with a different PARK number than what’s on my base, but it’s definately pairing with that base.

It rings when we receive a call but when I don’t have a dialling tone. When I press to make a call I get a constant beep like an engaged tone.

anyone any ideas? Perhaps my base needs a software update ? I have stride resetting the handset to factory settings. It still the same.

All Replies

Top 50 Contributor
2,131 Posts
Gold Member
Guy replied on Sun, Nov 22 2020 9:35 AM

What SW versions do you have on the base and handset?  My handsets are at SW 2.60 and the base at SW1.40, and they work fine.

Have you tried a base reset?  (But be aware that you will lose any numbers stored on the base.)

Have you changed any of the connections between Base and telephone wall socket?  Those symptoms sound a bit like an incompatible (reversed polarity) RJ11/BT jack cable.  Is there a broadband filter in place?

Finally is the battery holding charge OK?  I find that weak batteries cause all kinds of funny symptoms in these phones.

Page 1 of 1 (2 items) | RSS
Beoworld Security Certificate