Sign in   |  Join   |  Help

Century goes weird after about 20mins

rated by 0 users
Not Answered This post has 0 verified answers | 2 Replies | 1 Follower

pinter75
Not Ranked
50 Posts
OFFLINE
Bronze Member
pinter75 posted on Sun, Oct 18 2020 9:11 PM

Hi,

I have a Beo Century that goes weird after about 20 or so mins. It skips tracks, the lcd displays random things and the CD door will open and close.

Anyone have any idea what could be up with it. I think it may be capacitor related?

Thanks!

 

All Replies

Pindsen
Not Ranked
Denmark
23 Posts
OFFLINE
Bronze Member

Hi,

What about FM or tape, does that also behave strange?
Do you experience any sigificant heat than normal?
When it starts to behave strange, does it then respond to the push buttons?
What controls all this is the microcontroller, maybe something in that area is defect or a loose cable connection that react maybe when the whole is heated up?

Have you cleaned the gear sensor, door sensor and CD lid sensor?


/Pindsen

pinter75
Not Ranked
50 Posts
OFFLINE
Bronze Member
pinter75 replied on Mon, Oct 19 2020 10:10 PM

The unit locks out - no button presses are registered, and only resets after a power cycle.

The buttons light up randomly, the CD tracks repeat and sometimes the CD door opens and closes. The LED display shows 77 ?

Definitely will be an MCU issue. I will pop it apart and check for dry solder joints.

Does not explain why it is ok after a power cycle, unless the issue is power related - bad caps?

 

Page 1 of 1 (3 items) | RSS
Beoworld Security Certificate

SSL