Sign in   |  Join   |  Help

1203 - Tonearm won't drop after paused

rated by 0 users
Not Answered This post has 0 verified answers | 0 Replies | 1 Follower

Not Ranked
1 Posts
Bronze Member
Teddy1234 posted on Sat, Oct 10 2020 9:59 AM

Hi all!

I recently inherited a Beogram 1203, a beautiful machine. There were 2 faults, it was too slow and the tonearm won’t drop after I pressed the lift button. Through this forum I learned how to properly lubricate the bearing and the speed problem is solved. But the not dropping of the tonearm is still a problem. I’ll explain.

When the record is playing, and I push the lift button the tonearm lifts properly and the record stops spinning. But when I push the lift button again the record does start spinning but the tonearm won’t drop. When I looked closer, I found that the little plastic switch underneath the camwheel does not fully get pushed to connect with the small wheel, so the system to drop the tonearm never gets engaged (see picture). When I give the red plastic arm that pushes the small switch just a micro fraction, it engages and the tonearm drops like it should. I disassembled the camwheel and I can’t find any damages and after proper lubrication with silicone spray it still doesn’t get pushed far enough to engage with the small wheel. I also disassembled to magnetic system with the 2 red plastic arm, of which one should push the small switch into place, but here I also can’t find any issues. The strange this is that the other small plastic switch does get pushed enough to engage with the small wheel. So lifting the tonearm is never an issue. Maybe this is so because that switch seems to be located just a bit more toward the outside of the camwheel so the plastic arm makes better contact with the switch to push it into place.

My thought is that the system that pushes the red plastic arm is somehow faulty. Does anyone have an idea how to test this of fix it?




Page 1 of 1 (1 items) | RSS
Beoworld Security Certificate