Sign in   |  Join   |  Help

Beomaster 2400/1900

rated by 0 users
This post has 2 Replies | 1 Follower

Struer
Top 500 Contributor
London
Posts 86
OFFLINE
Silver Member
Struer Posted: Wed, Sep 30 2020 12:41 PM

Hi all, i have a beomaster 2400 and a Beomaster 1900.

Not having the best of luck at the moment with my bombaster. I have just had a look at my 2400 and 1900 for the first time.

Neither of them are functioning properly. The resisters on the Beomaster 2400 were burnt when I bought it so I replaced them and replaced

The two Darlington’s and the resister. Comparing both models which I find easier to troubleshoot the 1900 light is stuck on standby.

The Beomaster 2400 flicks on for a split second and off again. All lights are working and all the remote buttons work activating the correct bulbs.

My thinking Is there must be a serious problem still. I have one of Martins kits, which I shouldn’t use yet, as perhaps adding capacitors etc…at this stage will make diagnoses more difficult.

I have read quite a few archival forums on these issues. Any advice welcomed.

Dillen
Top 10 Contributor
Copenhagen / Denmark
Posts 12,067
OFFLINE
Founder
Moderator
Dillen replied on Wed, Sep 30 2020 1:56 PM

Check for DC on the speaker outputs - even if only possible during the brief moment it comes out of standby.

Martin 

Struer
Top 500 Contributor
London
Posts 86
OFFLINE
Silver Member
Will give that a try. It literally flashes on and off.

And it clicks without the lights if I press any button again before a few seconds have lapsed
Page 1 of 1 (3 items) | RSS
Beoworld Security Certificate

SSL