Sign in   |  Join   |  Help

Beolab 50 are a nightmare.

rated by 0 users
Not Answered This post has 0 verified answers | 46 Replies | 1 Follower

Beofile7
Top 500 Contributor
117 Posts
OFFLINE
Bronze Member
Beofile7 posted on Sat, Sep 26 2020 3:59 PM

I have had these speakers for 18 months. When they work they work fine. But honestly.. what a nightmare to own! I cannot go one week without having to reboot them. Everything fails constantly. I just want my previous life back! 

All Replies

Beofile7
Top 500 Contributor
117 Posts
OFFLINE
Bronze Member

So after a reboot I just counted 11 times I had to hit the Beolab 50 icon on the app before it recognised them! That is usual. 

Curly
Top 500 Contributor
FL, USA
86 Posts
OFFLINE
Gold Member
Curly replied on Sat, Sep 26 2020 4:37 PM

Just curious, my friend, have you ensured you’re running the latest firmware on both the parent and child speaker?  

Currently: BeoSound Core, BeoLab 17, BeoLab 18

Previously: BeoSound 1 non-GVA

Michael
Top 50 Contributor
Sweden
2,425 Posts
OFFLINE
Bronze Member
I’ve had mine for a few weeks now, my friends have had them for years. I haven’t had any issues except for the app not responding two times but the speakers have been working well.

I enjoy them a lot. Maybe yours are faulty? Or your connections are not correct perhaps?

Beolab 50, Beolab 20, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9i, BeoPlay H6, EarSet 3i, 
BeoVision Avant 55, BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

Beofile7
Top 500 Contributor
117 Posts
OFFLINE
Bronze Member

They are hard wired to a Beosystem. But I regularly use them through BV11 wireless. But then everytime I power them back again a few days later,,, nothing. No config makes any difference. The only solution is to unplug, wait, and start again. That is so impressive, not!

Martin
Top 200 Contributor
Sweden
318 Posts
OFFLINE
Bronze Member
Martin replied on Sat, Sep 26 2020 6:20 PM

Hi Beophile

my first pair was a nightmaire. But I had them three month and after that I got a replacement. After that they work fine also with the new sw 3.1. BO have had trouble with some abL 50 and they know it very well! So try to change the speakers for new ones. I think that is the only solution.

Best regards

Martin

Sweden

Beovision Eclipse 65 with floorstand (from STB Brackets), New! Beolab 50 front, Beolab 3 rear, 2 x Beoplay A6 linkrooms, 2xBeoremote one BT, Beosound 9000 Mark III (sw 3.4), Philips Hue (all lights in the home), Oppo UDP-203, Apple TV 4K. 

Michael
Top 50 Contributor
Sweden
2,425 Posts
OFFLINE
Bronze Member
Beofile7:

They are hard wired to a Beosystem. But I regularly use them through BV11 wireless. But then everytime I power them back again a few days later,,, nothing. No config makes any difference. The only solution is to unplug, wait, and start again. That is so impressive, not!

It’s a bit sad seeing headlines like nightmare because it will then become the google headline and I don’t want that for B&O... I NEVER use wisa wireless because it’s simply really bad. It’s not designed for everyday home usage and even airplay suffers in dence radio areas.

Just stop using wireless now! I mean it. Underline it.

Also, bl50 looses a lot of its competence in wireless mode as the speakers can not communicate then. So please. Stop using it.

Beolab 50, Beolab 20, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9i, BeoPlay H6, EarSet 3i, 
BeoVision Avant 55, BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

Esax
Top 500 Contributor
245 Posts
OFFLINE
Bronze Member
Esax replied on Sat, Sep 26 2020 6:55 PM
Just sell them. Someone will take the ***.😂

Beovision 7-55 MK1 red, Beolab 10 red. Beolab 50, all black. Beolab 17 broken ice. Beolab transmitter. Apple tv4 and apple express 2.

moxxey
Top 25 Contributor
South West, UK
5,158 Posts
ONLINE
Bronze Member
moxxey replied on Sun, Sep 27 2020 9:23 AM

Michael:

Also, bl50 looses a lot of its competence in wireless mode as the speakers can not communicate then. So please. Stop using it.

That applies to most speakers, but perplexes me anyone would spend £20K+ on a speaker and then attempt to use a wireless connection to stream high quality audio from their TV to the speakers. The logistics and bandwidth required for this to work flawlessly is almost incomprehensible. I'd never connect a soundbar wirelessly to a TV, for example.

As a comparison, you can blind-stream radio or Spotify wireless to, say, an Edge or BeoSystem 2, and this generally does work flawlessly as it buffers the audio and you don't need to worry about sync. I've lost my internet connection a few times, yet the audio will carry on streaming for another 30 seconds as it was buffered.

When you connect your TV wireless speakers, you need perfectly streamed non-buffered flaw-free audio. And if you play an uncompressed Blu-ray audio feed, wirelessly, you're simply asking for issues.

I wonder if people really understand the technical barriers required to wirelessly stream audio?

Duels
Top 50 Contributor
England
2,415 Posts
OFFLINE
Gold Member
Duels replied on Sun, Sep 27 2020 9:31 AM
I also recommend using cables rather than WISA.

I cabled my BL18s and 19 about six months ago and haven’t looked back since.

Purchased the cables from Steve naturally.
Beofile7
Top 500 Contributor
117 Posts
OFFLINE
Bronze Member
Beofile7 replied on Sun, Sep 27 2020 12:06 PM

I think there is a little misunderstanding here...

They are hardwired to a 7000 system but with a bit of switching I can also wirelessly use them as TV speakers. Both work well, once working. 

I don't think I have ever had an issue driving them once the connection has been made. 

The issue is the app losing it's connectivity occasionally....like every week! Often accompanied by just one speaker switching on! They are ALWAYS switched on via the 7000. ie. the wired connection.

So I switch on with "radio" and they power up, but the app does not connect so I lose all the app functions and cannot then drive them from the TV wirelessly as I cannot make that switching.

A reset of the iphone or using an ipad makes no difference. The speakers must be rebooted. I can find no other way.

So this is happening every few days. I hope this explains the issue a little further?

Aussie Michael
Top 50 Contributor
Melbourne, AU
3,512 Posts
OFFLINE
Bronze Member
Deleting as i think we were typing at the same time and i read your response Beofile., they are hard wired.
Jaffrey2230
Top 150 Contributor
Washington DC
460 Posts
OFFLINE
Silver Member

Sorry. my response was not relevant to your issue.

My B&O Home: 

 

  • Beolab 8002 + Beolab 2 + Beosound Core with Essence Remote (Office)
  • Beolab 6000 + Beolab 11 + Beosound Core (Bedroom)
  • Beoplay A9 Mk2 (Living Room)
  • Beosound 1 with wireless dock (Portable)
  • Beoplay M5 (Dining)
  • Beoplay H95 (Focused listening, travel)
  • Beoplay H9 (3rd gen) (retired)
  • Beoplay P6 (Portable)
  • Beotime wall clock (hallway entrance)
  • Beoremote X (poor man's Halo Big Smile)

 

 

 

Michael
Top 50 Contributor
Sweden
2,425 Posts
OFFLINE
Bronze Member
Beofile7:

I think there is a little misunderstanding here...

They are hardwired to a 7000 system but with a bit of switching I can also wirelessly use them as TV speakers. Both work well, once working.

I don't think I have ever had an issue driving them once the connection has been made.

The issue is the app losing it's connectivity occasionally....like every week! Often accompanied by just one speaker switching on! They are ALWAYS switched on via the 7000. ie. the wired connection.

So I switch on with "radio" and they power up, but the app does not connect so I lose all the app functions and cannot then drive them from the TV wirelessly as I cannot make that switching.

A reset of the iphone or using an ipad makes no difference. The speakers must be rebooted. I can find no other way.

So this is happening every few days. I hope this explains the issue a little further?

With a bit of switching you can use them wireless? How?

Beolab 50, Beolab 20, Beolab 8000 x 2, Beolab 4000 x 2, 
BeoSound Core, BeoSound 9000, BeoSound Century, 
BeoLit 15, BeoPlay A1, BeoPlay P2, BeoPlay H9i, BeoPlay H6, EarSet 3i, 
BeoVision Avant 55, BeoPlay V1-40, 
BeoCom 6000 and so much else :)  

Beofile7
Top 500 Contributor
117 Posts
OFFLINE
Bronze Member

I change the sound on the BV11 to wireless BL 50 and the input to the speakers to wireless via the app. Obviously this will need to be pre-programmed.

Page 1 of 4 (47 items) 1 2 3 4 Next > | RSS
Beoworld Security Certificate

SSL