Sign in   |  Join   |  Help

Beocenter 3500 sluggish motor

rated by 0 users
Not Answered This post has 0 verified answers | 2 Replies | 1 Follower

Streethawk
Not Ranked
3 Posts
OFFLINE
Bronze Member
Streethawk posted on Thu, Aug 13 2020 11:20 PM

Hi I recently acquired a Beocentre 3500 for £15. The FM slider wasn’t working and the turntable seems to be very sluggish and slow. 

 

I have managed to get the slider working now but am a little lost with the Motor on the turn table. The TT will on work on the “on” setting when you switch it to the other two speeds 17 and 30 the motor just doesn’t turn at all? Also it takes quite some time for the motor to get going when you switch it to the on position (speed 25)

im not to clued up with vinyl speeds but a 45rpm record sounds very slow on the 25 speed setting?  

It’s it worth trying to repair this. I have already replaced the belt but this has made no difference. It really is a thing of beauty but don’t know if it’s beyond to repair? 

All Replies

Streethawk
Not Ranked
3 Posts
OFFLINE
Bronze Member

Seems like the switch mechanism for on off is broken. Anyone know how I can post a pic in here to show you?

Streethawk
Not Ranked
3 Posts
OFFLINE
Bronze Member

Ok managed to get the switch working there’s was a small bridging part which had come dislodged, I have refitted this now, having a hard time setting it so so manual off works and the the other three 17, 25 and 30 work. Realised that these are not just speeds changes but the position of the toner arm for 7” and 12” 

speed is running about 3% to slow to 45rpm according to an app I downloaded but thinking this may be due to the rubber on the idler wheel becoming hard. Really want to get this thing going and working as it should. Everything seems very delicate. 

 

The toner arm arm seems to have a mind of its own sometimes it will move over sometimes not any ideas? 

Page 1 of 1 (3 items) | RSS
Beoworld Security Certificate

SSL