Sign in   |  Join   |  Help

Beocord 8004 tape select problems

rated by 0 users
Answered (Verified) This post has 1 verified answer | 3 Replies | 1 Follower

CJ
Not Ranked
Aa - DK
8 Posts
OFFLINE
Silver Member
CJ posted on Mon, Aug 3 2020 6:06 PM

Recently got a hold on a serviced Beocord 8004, but I can't help but wonder if it's normal for the metal light to come on whenever I insert a Type 2 tape?

Also when recording onto type 2 and 4 cassettes I lose some treble compared to recording on type 1 cassettes.

Metal is not so bad until I enable Dolby C which is no problem when recording on type 1 but falls completely flat when used on type 4.

And whenever I record on type 2 cassettes it's like it uses Metal bias so the treble aren't as clear as I know a TDK SA-X tape normally to be.

So I was wondering if anyone have experienced the same and what to do if it's a malfunction?

Answered (Verified) Verified Answer

CJ
Not Ranked
Aa - DK
8 Posts
OFFLINE
Silver Member
Answered (Verified) CJ replied on Sat, Aug 8 2020 1:06 PM
Verified by CJ

To anyone who happens upon this thread with the same problems, my fix was that some of the wires on the tape selector switches had broken off so the bias and tape selection was all wrong except on type 1 cassettes.

All Replies

CJ
Not Ranked
Aa - DK
8 Posts
OFFLINE
Silver Member
Answered (Verified) CJ replied on Sat, Aug 8 2020 1:06 PM
Verified by CJ

To anyone who happens upon this thread with the same problems, my fix was that some of the wires on the tape selector switches had broken off so the bias and tape selection was all wrong except on type 1 cassettes.

CJ
Not Ranked
Aa - DK
8 Posts
OFFLINE
Silver Member
CJ replied on Sat, Aug 8 2020 1:06 PM

To anyone who happens upon this thread with the same problems, my fix was that some of the wires on the tape selector switches had broken off so the bias and tape selection was all wrong except on type 1 cassettes.

CJ
Not Ranked
Aa - DK
8 Posts
OFFLINE
Silver Member
CJ replied on Sat, Aug 8 2020 1:06 PM

To anyone who happens upon this thread with the same problems, my fix was that some of the wires on the tape selector switches had broken off so the bias and tape selection was all wrong except on type 1 cassettes.

Page 1 of 1 (4 items) | RSS
Beoworld Security Certificate

SSL