Sign in   |  Join   |  Help

BC 9000 - Signs of Life?

rated by 0 users
Not Answered This post has 0 verified answers | 2 Replies | 1 Follower

BeoFrederic
Top 500 Contributor
136 Posts
OFFLINE
Gold Member
BeoFrederic posted on Fri, May 22 2020 3:56 PM

I’m a happy guy today.   I just purchased a long sought Attyca 2.  After looking for a few years for a unit anywhere in USA, the seller turned up not 20 miles from my house.  Oh-and-by-the-way, the seller included a BC 9000 and two RL 140s.  (!)

The BC 9000 that isn’t functioning…yet.  Perhaps someone can point out a simple user-interaction fix.

Status: the unit is in very good + cosmetic shape, so I infer it wasn’t abused.  The bottom glass panel is loose, of course, but I’m able to seat it in the tray.  When I power it up, there’s a tiny red light in the top right of the top glass.  Simultaneously, ‘Clock’ is illuminated on the bottom glass.  The glass doesn’t respond to my touch and there is no standby light. 

I have both a Beolink 1000 and a Beo4; selecting ‘Menu’ brings up ‘Play’ ‘Record’ ‘Call’ sub-menu on the glass for a few seconds.  Selecting anything else, e.g. ‘Radio,’ causes the bottom panel to flash illuminate for a sub-second.   It’s as though the unit was somehow locked.  

Does the clock need to be reset before the unit will release/respond?  And if so, how?  The manual say to select ‘Programming’ but there is no ‘Programming’ illuminated/selectable.

Or does this unit end in the closet for spare parts?

All Replies

Dillen
Top 10 Contributor
Copenhagen / Denmark
11,616 Posts
ONLINE
Founder
Moderator
Dillen replied on Fri, May 22 2020 4:24 PM

Check the power supply module for cracked solder joints.
Particularly at the large filter capacitors.

The glass panel will not work until correctly fastened.

Martin

BeoFrederic
Top 500 Contributor
136 Posts
OFFLINE
Gold Member
Thanks for the rapid reply, Martin.
Page 1 of 1 (3 items) | RSS
Beoworld Security Certificate

SSL