Sign in   |  Join   |  Help

BeoPlay M5 - Periodical problems with iTunes AirPlay

rated by 0 users
Not Answered This post has 0 verified answers | 12 Replies | 1 Follower

Reo
Not Ranked
2 Posts
OFFLINE
Bronze Member
Reo posted on Wed, Apr 8 2020 12:52 PM

Hi all

I'm experiencing problems with my BeoPlay M5. Sometimes when I want to stream music from my iTunes via AirPlay (on Windows) it can't connect to the speaker

even though it is visible from the AirPlay menu

It happens from time to time, I'm not sure what is the problem, speaker is connected to the same WiFi as my computer and I have firmware up to date.

I can easily use Spotify by Chromecast or radio via BeoPlay app.

Can this be related to my network?

This issue is quite rustrating I'm thinking even of replacing my speaker which I don't wanna do as I like it.

 

All Replies

matador43
Top 75 Contributor
1,353 Posts
OFFLINE
Bronze Member

Hi Reo and welcome to Beoworld.

It's a quite well discussed topic recently so you might find lot of talk about that in that very same Forum.

I suppose that when you uptick the speaker it disappears from the list but appears again if you power cycle the speaker or quit and restart iTunes?

If so, it's a known problem not related to B&O or whatever brand; I randomly experience it with all my third party Airplay speakers and people here with B&O speakers too.

I've received a lot of valuable help to double check all my wifi setup and the issue is still there. 

TO me it has to do with a bad implementation of the airplay protocol along with the sleep mode of the devices.

Not very useful help but welcome on the train to find a solution (Static IP, renaming devices, changing channel etc etc of course dont work! Big Smile).

Millemissen
Top 10 Contributor
Flensborg, Denmark
14,393 Posts
OFFLINE
Bronze Member

Hi Reo,

if you have the possibily, try to connect the M5 with a cable to your network, you might try that.

If that works fine, you can be sure, that Matodor is right.

Although I think that this might not be the same with all (third party) Airplay receivers, when using Wifi..

My Essence MK2 runs flawless for years with AP etc over Wifi.

But my M3 is miserable  - connecting it wired solved the problem.

MM

There is a tv - and there is a BV.

mbolo01
Top 50 Contributor
Louannec - France
1,972 Posts
OFFLINE
Bronze Member
Reo:

Sometimes when I want to stream music from my iTunes via AirPlay (on Windows) it can't connect to the speaker

Hi Reo - how often do you restart you iTunes server? How often do you restart you Windows computer?

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

Jaffrey2230
Top 150 Contributor
Washington DC
514 Posts
OFFLINE
Bronze Member

That is correct. One option is to switch your wifi gear to something like Google wifi. I used to have problems with wireless devices until I switched my wifi gear. Now, I get it once in awhile but it usually requires recycling my ipad or iphone, not the speakers or connected device.

B&O in my life 😊: 

 

  • Beolab 8002 + Beolab 2 + Beosound Core with Essence Remote (Office)
  • Beolab 6000 + Beolab 11 + Beosound Core with Essence Remote (Bedroom)
  • Beoplay A9 Mk2 (Living Room)
  • Beosound 1 with wireless dock (Portable)
  • Beosound Balance (Dining)
  • Beoplay H95 (Focused listening, travel)
  • Beoplay H9 (3rd gen) (retired)
  • Beoplay P6 (Portable)
  • Beotime wall clock (hallway entrance)
  • BMW X5 50i with B&O Audio Package (Commute/drive)

 

 

 

Reo
Not Ranked
2 Posts
OFFLINE
Bronze Member
Reo replied on Wed, Apr 8 2020 3:26 PM

matador43:

Hi Reo and welcome to Beoworld.

It's a quite well discussed topic recently so you might find lot of talk about that in that very same Forum.

I suppose that when you uptick the speaker it disappears from the list but appears again if you power cycle the speaker or quit and restart iTunes?

If so, it's a known problem not related to B&O or whatever brand; I randomly experience it with all my third party Airplay speakers and people here with B&O speakers too.

I've received a lot of valuable help to double check all my wifi setup and the issue is still there. 

TO me it has to do with a bad implementation of the airplay protocol along with the sleep mode of the devices.

Not very useful help but welcome on the train to find a solution (Static IP, renaming devices, changing channel etc etc of course dont work! Big Smile).

 

Thanks bro!

Yeah, exactly as you say, it keeps disapearing from the iTunes if I uncheck it.

I'm using only Windows for this moment, I wonder if this is same issue on Mac, will have to try that out.

Earlier I tried with connecting to network by cable but it didn't sort it.

Anyway thanks, good to hear that I'm not alone with this! Maybe I will find out something

1990
Top 150 Contributor
517 Posts
OFFLINE
Bronze Member
1990 replied on Wed, Apr 8 2020 3:41 PM

Millemissen:

But my M3 is miserable  - connecting it wired solved the problem.

MM, how did you do that?! There is no Ethernet the M3!

mbolo01
Top 50 Contributor
Louannec - France
1,972 Posts
OFFLINE
Bronze Member

1990:
MM, how did you do that?! There is no Ethernet the M3!

USB-C <--> RJ45 adapter works and is often recommended by B&O support to fix WiFi issues.....

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

matador43
Top 75 Contributor
1,353 Posts
OFFLINE
Bronze Member

Reo:
I'm using only Windows for this moment, I wonder if this is same issue on Mac, will have to try that out.

Don' bother , it's the very same!

Reo:
Earlier I tried with connecting to network by cable but it didn't sort it.

I hope not, because it's the only backup solution to my setup. But it also mean that the problem is definitely in the speaker and not int the network coverage. Interesting!

 

 

matador43
Top 75 Contributor
1,353 Posts
OFFLINE
Bronze Member

Millemissen:
If that works fine, you can be sure, that Matodor is right.

Thank you Millmossen! Big Smile

Millemissen
Top 10 Contributor
Flensborg, Denmark
14,393 Posts
OFFLINE
Bronze Member

mbolo01:

1990:
MM, how did you do that?! There is no Ethernet the M3!

USB-C <--> RJ45 adapter works and is often recommended by B&O support to fix WiFi issues.....

Exactly - works perfect.

MM

 

There is a tv - and there is a BV.

mbolo01
Top 50 Contributor
Louannec - France
1,972 Posts
OFFLINE
Bronze Member

To check if Bonjour /mDNS services are advertising correctly, you can use the free Discovey DNS-SD app on OSX or IOS (check in App stores)

For Windows there is also a tool https://hobbyistsoftware.com/bonjourbrowser I haven't tested it nor I guarantee it is safe

@Matador: These tools are more user friendly than the dns-sd terminal command, while being complementary as with the dns-sd you can see Airplay target been added or removed till you close the screen.

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

matador43
Top 75 Contributor
1,353 Posts
OFFLINE
Bronze Member

mbolo01:
@Matador: These tools are more user friendly than the dns-sd terminal command, while being complementary as with the dns-sd you can see Airplay target been added or removed till you close the screen.

I've tried it, thanks for the tip. Actually I can see a lot of things which is a little confusing.
But anyway, all my speakers, standalone or by means of AE, are there. 

Page 1 of 1 (13 items) | RSS
Beoworld Security Certificate

SSL