Sign in   |  Join   |  Help

BL3500 MK1 SW1.2 and BeoLink Converter 1612 compatibility

rated by 0 users
Not Answered This post has 0 verified answers | 3 Replies | 2 Followers

hndrcks
Not Ranked
3 Posts
OFFLINE
Bronze Member
hndrcks posted on Fri, Feb 21 2020 6:10 PM

I have a BS9300 connected to a BL3500 MK1 via MCL and everything works fine.  I recently picked up a BL2000 with a 1612 Converter. When I connect the BL2000 to the 1612 / 9300 everything works great, but when I connect the BL3500 and switch the input to ML I get no display or sound.

I have a 1000 remote and after browsing this forum found the following:

MENU 00 PLAY shows SW 1.2

MENU 02 PLAY shows NO ML or ERROR 2

MENU 09 PLAY shows ML ON

If I do MENU 04 to switch to ML, I hear a click as it switches (I think) and then another click a few seconds later.

I figure the 1612 is working because the 2000 works fine. Before I chase down a repair for the 3500, does anyone know of compatibility issues between the MK 1 / 1.2 software and the 1612 converter? Should I chase down a 1614 instead?

(very careful about disconnecting power before making changes - and I didn't leave the MCL connected while testing the 1612)

 

 

 

All Replies

Stoobietoo
Top 200 Contributor
Exeter, Devon, UK
397 Posts
OFFLINE
Gold Member

Ignore my message. Didn't read yours properly sorry.

Stoobie 

hndrcks
Not Ranked
3 Posts
OFFLINE
Bronze Member
hndrcks replied on Sat, Feb 22 2020 12:20 AM

I think I solved my problem, unfortunately. According to Steve at Sounds Heavenly in an archived post:

"In order to work as an "ML driver" (ie. to act as an Audio Master to an ML network), the 1611 converter must be the later type that carries the full type number 1161166 on the sticker."

My 1612 is the old type, just the 4 digit number. SW version 1.3. My guess is it can't drive the ML network.


 

 

hndrcks
Not Ranked
3 Posts
OFFLINE
Bronze Member
hndrcks replied on Sat, Feb 22 2020 12:20 AM

 


 

 

Page 1 of 1 (4 items) | RSS
Beoworld Security Certificate

SSL