Sign in   |  Join   |  Help

Bang & Olufsen App 3.00 prod/beta

rated by 0 users
Not Answered This post has 0 verified answers | 70 Replies | 3 Followers

mbolo01
Top 75 Contributor
Annecy - France
1,660 Posts
ONLINE
Gold Member
mbolo01 posted on Sat, Feb 8 2020 12:18 PM

Dear app users, here's is a summary of some issues/comments I could find in previous app versions related threads that are still valid with the new app iteration.
I may have missed some, or some have been fixed since, so feel free to update the list while keeping all the items grouped for better reading (copy paste with changes).

Hopefully someone in B&O still reads this forum and cares.

Issues (new, re-introduced and on-going):

  • iPad version: Cannot put products into standby individually, power icon missing per product. Power icon is only available for global standby action.
  • Cannot get the app to control BeoSystem 4500 and BeoSound 2300, each connected to an NL/ML converter.
  • Apps freezing when Internet access is not available while local network access to products is functional.
  • Now playing screen: moving forward/backward within a DLNA track does not work as it should
  • Now playing screen: when changing a DLNA track, album cover is not displayed back until now playing screen is minimized/maximized <-- Issue seen with PLEX DLNA server but not with MinimServer
  • Music browsing: white back (<) and more (...) buttons are not visible when artist/album image background is white <--- Version 3.00 introduces a black back symbol (<) while keeping the more icon (...) white, no comment ....
  • Music browsing on iPhone: top artist/album image overlaps top screen informations
  • Now playing screen: icon depicting the product flashing for a fraction of a second.
  • IOS 3D Touch "shutdown all" option does not do what it is supposed to do but simply opens the B&O App (case opened by mbolo01 - Dec 2019)
  • Multiroom icon not always displayed against products member of a multiroom experience
  • Play queue: When inserting music track(s) to a product play queue, the play queue is emptied prior to loading new content to it which is the correct behavior, but when a TuneIn radio has been played after a music source, loading new music content to the product no longer clears the play queue but instead inserts the new track(s) after the latest music track played (case opened by mbolo01 - Dec 2019)
  • Cover-Art is not displayed when using Airplay while it is when using other music sources such as Chromecast or DLNA.
  • Product Multiroom screen: When a given product is streaming Airplay flow, its Multiroom page indicates that other products cannot join when such source is in use, which is obviously wrong (when products are correctly configured) and which works despite the displayed message.

Note: I have opened a case (#200208-000081) on Feb 8th 2020 for all the points above but the "Cannot get the app to control BeoSystem 4500 and BeoSound 2300, each connected to an NL/ML converter." that i cannot support as I don't have such equipment and "Now playing screen: when changing a DLNA track, album cover is not displayed back until now playing screen is minimized/maximized" which may be a PLEX DLNA poor implementation.

Issues fixed in 3.1:

  • Play Queue: Album Artist is shown for each track instead of Track Artist like in the now playing screen. When listening to Compilations that have "Various Artists" for Album Artist, identifying the track artist in the Play Queue is not possible which is a pity.
  • (introduced in 3.0): Now playing screen: back arrow (<) is black on a dark grey background, hardly visible.
  • (introduced in 3.0): iPad landscape mode the product images are overlapping in the most recent versions.

Issues fixed in 3.00:

  • Beolink settings: When disabled, Integrated devices monitoring option does not stay disabled after app restart (case opened by mbolo01 - Dec 2019)

On-going requests for enhancement by BeoWorld forum members:

  • Ability to “join” NL streams from the app.
  • Lack of virtual keyboard for the Eclipse when a menu where text input is required is encountered, e.g. search field
  • Split view and slide over on the Apple iPad
  • Deezer Flow
  • Possibility to reduce local source list in the now playing screen
  • Genre overview - with much smaller pictures per Genre, so that you see more content without scrolling, e.g to follow the Deezer design (as you did with Artists using round circles instead of squares). Deezer is using small rectangle instead of squares for displaying genre.
  • Clearer multiroom screen, you see all groupings at once, without changing selected products
  • Possibility to alias sources' names, e.g change BS Core "Line In" to "BG 4000"
  • More consistency across screen designs, e.g.  when you choose "show all“ at "Deezer Selection“ the displayed list looks different than all the other lists displayed at  "show all“, why?
  • Now playing screen: changing track by pressing on the image is far too sensitive, lack of inertia
  • Dark mode

 

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

All Replies

mbolo01
Top 75 Contributor
Annecy - France
1,660 Posts
ONLINE
Gold Member
steve1977:

Thanks for all your replies. A few thoughts:

1) Wouldn’t the main page benefit from having some form of indication what the “lead speakers” are? How do you figure this out when you have 3+ speakers in your home setup? Or even more confusing when you have two streams (= two lead speakers)

As already answered, if a product is part of a multiroom group, tapping on it will highlight the other members of the group (greyed) and the lead speaker will appear at the bottom as well as the playing source for this group. The UI could handle this better for sure, but that’s all we have for now.

steve1977:

3) My issue with not being able to join was a result of weak wifi. If the wifi is weak (orange or red light), it doesn’t allow to join streams. No idea why the wifi is weak as it sits closely next to an airport extreme. Only if hard-wired, it turns white. Any experience of others how to have stable wifi for the BS1?

Being too close is not a warranty of good signal. I would try to move it farer as a test.

Depending on your WiFi setup, it may also have chosen another WiFi access point which may not be the best choice.

What is the WiFi signal quality exposed by your BS1 in the app or the configuration screen?

steve1977:

4) The touch feature seems inconsistent. I don’t experience what others describe. One touch gives me a pause (if done on lead speaker, all speakers pause). I don’t know whether there is a way to “mute” instead of pause. Also, i haven’t found a way to “pause all”, but only to “stand by all”, which is different.

Strange indeed, maybe a different logic based on the product generation, but I doubt as it should be software driven.

My BS1 mk1 physical control behaves the same as the Essence remote (described in the other thread you are participating )

If I send an AirPlay flow to my BS1, expand to another product via NL multiroom, tapping on top of the BS1 mutes it and the other product still plays, tapping again unmute the BS1.

If there is no multiroom engaged, tapping on the BS1 pauses the AP flow, tapping again resumes the AP flow, both with the 2 seconds delay that is a sign of a basic AP 2 integration.

That said, on my side i cannot PAUSE with physical controls,the only way is to stand by all, including other potential running products not part of the multiroom group, or to use the source app or the B&O app.

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

steve1977
Top 100 Contributor
809 Posts
OFFLINE
Bronze Member

mbolo01:
Being too close is not a warranty of good signal. I would try to move it farer as a test.

Depending on your WiFi setup, it may also have chosen another WiFi access point which may not be the best choice.

What is the WiFi signal quality exposed by your BS1 in the app or the configuration screen?

I tried all kind of distances to the airports. All non-B&O devices work very well over iphone (Apple TV, iphones, ipads, notebooks).

I can check later what signal strength is shown. But it's not an issue of my home network, but a B&O issue (only impacted devices).

I believe I used to set a fixed IP address, which may help solve the issue? I can look into this. Any other thoughts appreciated!

mbolo01
Top 75 Contributor
Annecy - France
1,660 Posts
ONLINE
Gold Member
Also if you could run the Wireless Network Analysis from your product and share the output by MP if you need help to interpret it.

Apple devices always work fine with Apple Airports, not always the case with non Apple devices, trust me ...

Fixed IP, while being a good thing (I have that for all my speakers), will not help on this front unless you have set the same for two different devices which could produce big disorder, but I doubt it is the case.

Sample Wireless Analysis Screen:

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

steve1977
Top 100 Contributor
809 Posts
OFFLINE
Bronze Member

Thanks for your help.

Some progress!

Two devices (right next to each other) connect with different airports. So, I assume that the one with poor connectivity connects with an airport that is more distanced.

Any idea why this is happening?

Also, I am surprised that I see 4 airports showing up (3 on channel 11, 1 on channel 132). I only have 3 airports, so quite surprised to see 4. Also any thoughts on this?

mbolo01
Top 75 Contributor
Annecy - France
1,660 Posts
ONLINE
Gold Member

steve1977:

Also, I am surprised that I see 4 airports showing up (3 on channel 11, 1 on channel 132). I only have 3 airports, so quite surprised to see 4. Also any thoughts on this?

Without seeing the output, and without knowing your environment, i.e. if there are neighbors WiFi polluting your environment, I can guess that 2 AP have only 2.4 GHz set, or have 5 GHZ set with another name, and one AP has both 2.4 GHz and 5 GHz (channel 132).

In the output, you should also look at the strength value of the Access point which is a network quality indicator: under 20 it's not really good, above 40 it is very good.

Why a device connects to an AP instead of another? I guess (again) that is depends of which one responded first with decent quality, or if a previously connected AP has been off which triggered a reconnection to another AP, etc .... I usually restart my products post WiFi AP restart to make sure that the best one will be chosen.

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

mbolo01
Top 75 Contributor
Annecy - France
1,660 Posts
ONLINE
Gold Member
steve1977:

Also any thoughts on this?

Any findings ?

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

steve1977
Top 100 Contributor
809 Posts
OFFLINE
Bronze Member
mbolo01:

Any findings ? BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

Thanks for following up and sorry for not reporting back earlier. I’ll still need to do some more troubleshooting. The good news is that yet another factory reset got things working. Still orange, but not red anymore. I’ll look more into it.
Fansastic
Top 150 Contributor
The Netherlands
545 Posts
OFFLINE
Gold Member
I just switched to 3.7.0 beta version and app keeps crashing. Anyone having the same problem. I’m using iPhone iOS 14.0.01

BV Eclipse 55 Brass - BL 18 Brass - BL 19 Brass - BL 3 White - BS Moment - BS 2 Brass - BV Horizon 48 - BS3000 - BS 3200 - BS Essence - BL 4000 - V1 40 Black - V1 40 White - BLC NL/ML - H6 -  H4 - E8 Motion - A8 Earphone - Beolit 12 - Beolit 15 - Beoplay A1 Green - Beoplay A3 White

mbolo01
Top 75 Contributor
Annecy - France
1,660 Posts
ONLINE
Gold Member

Fansastic:
I just switched to 3.7.0 beta version and app keeps crashing. Anyone having the same problem. I’m using iPhone iOS 14.0.01

Public version 3.7.2 is ahead from the latest available beta and works well with IOS 14.0.1

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

Jaffrey2230
Top 150 Contributor
Washington DC
460 Posts
OFFLINE
Silver Member

I’ll switch to the released version. in my case the main problem is that with an iPad I can use the volume hardware buttons to change volume, with iPhone the volume button doesn’t work. Otherwise, beta has been quite solid for me. So much so that I end up using the App vs. Essence remote or even AirPlay most of the time.

My B&O Home: 

 

  • Beolab 8002 + Beolab 2 + Beosound Core with Essence Remote (Office)
  • Beolab 6000 + Beolab 11 + Beosound Core (Bedroom)
  • Beoplay A9 Mk2 (Living Room)
  • Beosound 1 with wireless dock (Portable)
  • Beoplay M5 (Dining)
  • Beoplay H95 (Focused listening, travel)
  • Beoplay H9 (3rd gen) (retired)
  • Beoplay P6 (Portable)
  • Beotime wall clock (hallway entrance)
  • Beoremote X (poor man's Halo Big Smile)

 

 

 

mbolo01
Top 75 Contributor
Annecy - France
1,660 Posts
ONLINE
Gold Member
mbolo01 replied on Sat, Oct 17 2020 11:34 PM
Jaffrey2230:

with iPhone the volume button doesn’t work

Did you configure that option? This is not a default setting.

BS Moment, BS Core, BG 4002, BC 4500, BS1, BL18, BL19, BL8000 + RCV1, A6, M5, M3, A1, P6 (tks Botty), H5, TR1

Page 5 of 5 (71 items) < Previous 1 2 3 4 5 | RSS
Beoworld Security Certificate

SSL