Sign in   |  Join   |  Help

Beimaster 5000 volume issue

rated by 0 users
Not Answered This post has 0 verified answers | 5 Replies | 1 Follower

Deek66
Not Ranked
8 Posts
OFFLINE
Bronze Member
Deek66 posted on Tue, Jan 14 2020 1:56 PM

Just bought a set up and while the radio plays loud enough to awaken the dead, the attached record player has a pretty low volume even when cranked up to 6. The cassette deck and cd deck do not work at the moment, so not connected. 
many obvious thing I can try to sort this?
thanks in advance.  

All Replies

GaSelle
Not Ranked
14 Posts
OFFLINE
Bronze Member

Check the DIN plug. The mounting angle causes the wires to break.

Deek66
Not Ranked
8 Posts
OFFLINE
Bronze Member
Deek66 replied on Tue, Jan 14 2020 4:56 PM

Anyone able to point me in direction of wiring diagram. Wires broken. Not sure where they re solder. TIA

Dillen
Top 10 Contributor
Copenhagen / Denmark
11,732 Posts
OFFLINE
Founder
Moderator
Dillen replied on Tue, Jan 14 2020 5:17 PM

Which Beogram are you using?
Is it connected to the PHONO input (the position of the sockets compared to the related lettering confuses many).

Martin

Deek66
Not Ranked
8 Posts
OFFLINE
Bronze Member
Deek66 replied on Tue, Jan 14 2020 5:21 PM

Beogram 5005 type 5921. I have the DIN apart and ready to resolder. By the time I had it apart only red wire and ground were still attached, so now stuck as I don’t know where rest of wires should go. 

Deek66
Not Ranked
8 Posts
OFFLINE
Bronze Member
Deek66 replied on Tue, Jan 14 2020 5:23 PM

Beogram 5005 type 5921. I have DIN apart ready to re solder. Only ground and red were still attached by time I wrestled it apart, so now stuck not knowing where rest of wires go. 

Page 1 of 1 (6 items) | RSS
Beoworld Security Certificate

SSL