Sign in   |  Join   |  Help

Beolab 5 krackling / Popping sound

rated by 0 users
Not Answered This post has 0 verified answers | 3 Replies | 1 Follower

sk0rpion
Not Ranked
3 Posts
OFFLINE
Bronze Member
sk0rpion posted on Thu, Dec 12 2019 10:22 AM

Hi,

I have an issue with one of my Beolab 5 speakers. Its a popping sound  from the midrange speaker now and then. Speaker seems to work other than that. What i have tried:

 

  • Changed power chord and tried different socket. 
  • Tried all inlets seperately (Digital / Powerlink) 
  • I also opened the speaker to check for loose connectors with no luck. 

 

The problem is most prominent at startup.. App. first 20min it comes some crackling noise now and then. Its also a constant very slight "buzzing" when i pause the music. (If i put my ear close to the midrange)

Anyone had same problem? And what was the solution to get it fixed? I suspect that it need to be some issue with the midrange amp. since the popping is concentrated only there. Is it possible to swap that one out? 

I attached a video here:

https://www.youtube.com/watch?v=_-FZp7MfxA4

Format: ???
Duration: 30sek

All Replies

Gary
Top 500 Contributor
Dublin, Ohio
94 Posts
OFFLINE
Bronze Member
Gary replied on Thu, Dec 12 2019 6:19 PM

Interesting that I have had the same issue with one of the Beolab 20 speakers I purchased almost a year ago. Initially we thought that it was an issue caused by a connected B&O Avant tv that had lost its video engine and was therefore causing the loud crackling in the speaker. After replacing the tv with an LG, the same crackling resulted. We changed the Cat cables on the speaker, flip flopped right with left and still the crackle would not disappear. Strangely, the speaker would function beautifully for days and up to a week without an issue, then the crackling would come back upon turning any video or music source randomly. After many communiques with the dealer and B&O Support, the speakers will be picked up by B&O Store, updated and amps replaced. I hope that this helps you for I know what you are experiencing is very frustrating. I suggest that you contact B&O Support for a resolution. 

petermc
Top 500 Contributor
Australia
95 Posts
OFFLINE
Founder
petermc replied on Fri, Dec 13 2019 12:31 AM
We had a similar problem in that the BL5’s would function normally for around 20 minutes and then the left speaker would start to emit a sound that sounded like rubbing your finger under the stylus of a turntable.

The crackle would continue and then could go away for a few days then come back again randomly. Became more frequent though.

Tried the cord replacement, cables, everything. In the end had the chassis replaced and has been fine since.

Peter
sk0rpion
Not Ranked
3 Posts
OFFLINE
Bronze Member

Yes kind of frustrating issue. I had an excuse to open and see how it looked inside at least :) the two largest amp seems to be easy to replace and to find for sale. But the 2x250w for tweeter and middle is in one piece and cant find that part anywhere. probably designed for the beolab5. Seems dealer is only option. :/ 

Page 1 of 1 (4 items) | RSS
Beoworld Security Certificate

SSL