Sign in   |  Join   |  Help

Beomaster 2000 1977 preset tuners

rated by 0 users
Not Answered This post has 0 verified answers | 5 Replies | 1 Follower

yapmaul
Not Ranked
4 Posts
OFFLINE
Bronze Member
yapmaul posted on Fri, Nov 8 2019 10:03 AM

Hi there! I'm new here, having just inherited my dad's B and O stereo. Everything is working fine, except that I cannot make the little preset tuners work.  It's as if the little wheels aren't engaging with the tuner. Any ideas? Do I need to take it apart? Also the light behind the main tuner windows isn't working.  Is this an available part. Incidentally, I have all the original manuals, wiring diagrams etc for this equipment which I am happy to share if anyone needs them. 

All Replies

Dillen
Top 10 Contributor
Copenhagen / Denmark
11,051 Posts
OFFLINE
Founder
Moderator
Dillen replied on Fri, Nov 8 2019 10:50 AM

The small fingerwheels on the preostats will need a tiny drop of glue to grip their spindles.
The whole dial is not lit, - only the pointer.

Martin

yapmaul
Not Ranked
4 Posts
OFFLINE
Bronze Member

Thanks, Martin. Are you suggesting for example pushing a little drop of glue in from the top on the tip of a pin? Or is there a simple way of getting better access?

yapmaul
Not Ranked
4 Posts
OFFLINE
Bronze Member

Thanks, Martin. Are you suggesting for example pushing a little drop of glue in from the top on the tip of a pin? Or is there a simple way of getting better access?

Dillen
Top 10 Contributor
Copenhagen / Denmark
11,051 Posts
OFFLINE
Founder
Moderator

Pry off the wheels with a small (watchmakers) screwdriver.
Add a tiny amount of glue inside the hole in the wheels and push them back on.
In most cases the wheels can be eased out without desoldering the preostats, due to their holes in the circuitboard.

Martin

yapmaul
Not Ranked
4 Posts
OFFLINE
Bronze Member

That's all sorted, so thanks! I have one more question.  The panel which conceals the loudness and tape 1/2 buttons seems to be fixed so that it can't move, and yet the buttons are there underneath.  Do you know why this is? I wonder if the buttons are disabled in this model.  Thanks again.

 

Paul

 

Page 1 of 1 (6 items) | RSS
Beoworld Security Certificate

SSL