Sign in   |  Join   |  Help

H9i firmware 5.0.7 vs. the Bang & Olufsen app

rated by 0 users
Not Answered This post has 0 verified answers | 8 Replies | 1 Follower

hsiktas
Not Ranked
7 Posts
OFFLINE
Bronze Member
hsiktas posted on Tue, May 21 2019 9:58 AM

Hi,

I have a new H9i which came with the 5.0.4 firmware. It worked without any issues and setting everything up with the Bang & Olufsen app for Android worked well. The app's changelog mentioned the ability to disable the proximity sensor but I could not find it anywhere in the app. Out of curiosity I joined the beta program on Google Play and soon I got a new update for the app with the same(?) changelog.

After a while, the app notified me about a new software update it offered me the new 5.0.7 firmware which adds the ability to disable the proximity sensor. This was probably the reason why the app did not show the option for me, yet. I downloaded the firmware and the app successfully sent it over to the H9i. Then it notified me that the H9i needs to restart and that this could take 1-2 minutes.

After ~15 minutes it was still not done. The H9i was still connected to my phone and my PC, its ANC was active but no playback would work. The power switch was also not functional.

I waited a little longer and as a last resort I removed the battery and the H9i started to work again. It seems like whenever I use the B&O app to connect to the H9i, the H9i locks up and returns in the above mentioned state. Going back to the stable release channel for the app did not change this.

Is this a bug in the new 5.0.7 firmware or did I somehow botch the upgrade process? I can't check if the firmware is really at 5.0.7 or in an undefined intermediate stage in between.

For now I uninstalled the B&O app and the H9i works without any issues. I contacted the support from within the app but I have no response yet. :(

All Replies

hsiktas
Not Ranked
7 Posts
OFFLINE
Bronze Member

I attempted the firmware update again with the Beoplay Software Updater for macOS and it flashed 5.0.7 without any issues.

Unfortunately, the problem still persists. As soon as I try to connect the Android app version 2.6.1 to the headphones, the headphones lock up and I have to remove the battery to get them back to normal.

Now, I have contacted the B&O support hotline directly. They advised me to factory reset the H9i but that did also not help. At least, the issue is now reported to them and maybe the appropriate people in their development teams can look at this issue.

Yendys
Top 200 Contributor
Sydney
303 Posts
OFFLINE
Bronze Member
Yendys replied on Thu, May 23 2019 10:09 AM
I used the windows update and H9i updated to 5.0.7 seamlessly and I now have the handy proximity sensor toggle switch show up in the latest version of the Bang and Olufsen App

I will say they actually different as soon as i started listening to test them, more definition.

The iOS App update should have mentioned the H9i needs to be on the latest version for this switch to show up
hsiktas
Not Ranked
7 Posts
OFFLINE
Bronze Member
hsiktas replied on Thu, May 23 2019 10:47 AM

I don't have access to an iOS device at the moment but maybe this is only triggered in the Android version. 🤔

hsiktas
Not Ranked
7 Posts
OFFLINE
Bronze Member
hsiktas replied on Thu, May 23 2019 10:47 AM

I don't have access to an iOS device at the moment but maybe this is only triggered in the Android version. 🤔

edit: Sorry for the doube-post

hsiktas
Not Ranked
7 Posts
OFFLINE
Bronze Member

B&O confirmed the issue and they provided me instructions to solve the issue. Everything is working fine now. Smile

My rough translation of their instructions:

  • Power off the headphones
  • Remove them from the B&O app
  • Remove the Bluetooth pairing from your Android settings (Previously, I was missing this crucial step!!)
  • Factory reset the H9i
  • Power on the headphones
  • Pair them from the Android Bluetooth settings and test if playback works
  • Add back the H9i in the B&O app
beltskyy
Not Ranked
4 Posts
OFFLINE
Bronze Member

I can't update my device h9i. Mine h9i firmware is still 5.0.4. When the app was updated last time it offered me 5.0.7 for h9i and asked me for some permissions but I accidentally rejected them. Since that time it hasn't offered anything and I don't know how to update my devices. Moreover there is no any button which let me switch proximity sensors for h9i. I tried to remove through the app and from bluetooth devices. I tried to clean app cache and data. I reinstalled Android app. Nothing helped. Does somebody have such kind of porblem? Any successful resolve?

hsiktas
Not Ranked
7 Posts
OFFLINE
Bronze Member

The desktop app to update the firmware shows only the 5.0.4 firmware for the H9i. Seems like version 5.0.7 got pulled from B&O. 🤔

beltskyy
Not Ranked
4 Posts
OFFLINE
Bronze Member

the same to me! I tried to use it too, but version is still 5.0.4

Page 1 of 1 (9 items) | RSS
Beoworld Security Certificate

SSL