Sign in   |  Join   |  Help

Beomaster 5 problems

rated by 0 users
Not Answered This post has 0 verified answers | 6 Replies | 0 Followers

marexy
Top 150 Contributor
448 Posts
OFFLINE
Silver Member
marexy posted on Thu, Apr 18 2019 7:21 AM
Hi
I have a BM5 that does not work.
There is nothing on the screen. The unit  BM5 turn on,disc spinning, fan working, but only 3 of 4 test led's are showing voltage .
+5v-ATX- ok,  +3,3V-ATX - ok,  +12V- Blank -ok, +5V_SB - NOT OK.
Only the red light on the BS5 screen lights up. It does not blink, it's only light.
I tested a screen on another BM5 running and the screen works normally.
I also changed the disc from one BM5 to another and the disk is working normally.

Is the power supply problem or on the motherboard?
Is it possible to repair by replacing the condensers?

Thanks for the advice.

 


All Replies

Beobuddy
Top 25 Contributor
Utrecht, The Netherlands
3,474 Posts
OFFLINE
Founder
Beobuddy replied on Thu, Apr 18 2019 10:10 AM

The leds are there to give a status about the PSU. So, in this case the 5SB powerline is dead.

I suspect more than just a capacitor.

marexy
Top 150 Contributor
448 Posts
OFFLINE
Silver Member
marexy replied on Thu, Apr 18 2019 10:13 AM

Hi

do you think motherboard is broken ?

 

Beobuddy
Top 25 Contributor
Utrecht, The Netherlands
3,474 Posts
OFFLINE
Founder
Beobuddy replied on Thu, Apr 18 2019 10:17 AM

Nope, the powerboard underneath the diskdrive.

marexy
Top 150 Contributor
448 Posts
OFFLINE
Silver Member
marexy replied on Thu, Apr 18 2019 10:28 AM

Thanks

will try to change with other one to check :)

Hope it can be fix.

 

 

marexy
Top 150 Contributor
448 Posts
OFFLINE
Silver Member
marexy replied on Thu, Apr 18 2019 12:36 PM

Beobuddy

so ..after that, do can conclude that the failure in on 5V stand by section on power supply PCB?
Have you ever repaired that error ?

 

 

marexy
Top 150 Contributor
448 Posts
OFFLINE
Silver Member
marexy replied on Fri, Apr 19 2019 7:06 AM

update..

Led smd had bad solder that is why not working.

After all chenges at the end,  problem is on motherboard.

let's go on :)

 

Page 1 of 1 (7 items) | RSS
Beoworld Security Certificate

SSL