Sign in   |  Join   |  Help

Optical sound from Samsung TV to BS Core

rated by 0 users
Answered (Not Verified) This post has 0 verified answers | 17 Replies | 1 Follower

Renesigk
Not Ranked
6 Posts
OFFLINE
Bronze Member
Renesigk posted on Sun, Aug 5 2018 9:43 AM

Hi

 

Just got myself a Beosound Core to play music though and to use as sound from my Samsung television. Beolab 14 as speekers. 

Music though Spotify works great, but I just can´t get any sound from my TV no matter what I do.

What I have done and tried: Optical cable connected from the TV to the Core. Light i the cable works, so there is "power" in the connection and should work. From the B&O app I have set the Core to play from optical, but that just gives a silent buzz. TV´s speakermode has been set to both internal speaker and external with no result and I have updated the TV´s firmware just to be sure that wasn´t the issue.

I have even tried with a cable with a jack end and an optical, since I ealier had a small set of computerspeakers connected from the jack. Still no sound.

TV: Samsung LE40C755

Anyone who knows what the probleme might be? 

 

Kind regards, René

All Replies

leosgonewild
Top 50 Contributor
Helsinki, Finland
1,833 Posts
OFFLINE
Bronze Member
Have you chosen optical as output in the tv’s menu?

Have you set up your or remote with the core?

At least with the s8-hub the smart stick remote does not work.
Renesigk
Not Ranked
6 Posts
OFFLINE
Bronze Member

Hi Leogoeswild

As far as I can see, I can´t choose optical as output on my TV, but should work without too much trouble(but...). On new versions of the Samsung fleet, I can see that there are some other menues to choose from. 

Hmm.. Setup my remote to the TV to the Core? Need to check up on how to do that. Would that change anything? Don´t know what the smart-stick is..

Millemissen
Top 10 Contributor
Flensborg, Denmark
11,831 Posts
OFFLINE
Bronze Member

@René

Are you sure that you can not choose between PCM and bitstream (untouched sound) in the sound menu?

The output must be PCM (2 channel) for the Core to play it back.

MM

There is a tv - and there is a BV.

Renesigk
Not Ranked
6 Posts
OFFLINE
Bronze Member

Hi Millemissen

It is set du PCM at the moment. I cannot change it for some reason and I don´t have the possibility to choose bitstream. 

 

K.R. René

leosgonewild
Top 50 Contributor
Helsinki, Finland
1,833 Posts
OFFLINE
Bronze Member
Can you try connecting the core to a different optical source? A MacBook Pro perhaps? That way we can find out if it is the core or the tv that is the issue here.
Renesigk
Not Ranked
6 Posts
OFFLINE
Bronze Member

That was actually a good idea. Will see if I can find something with optical to connect. Don´t think I have optical in my Macbook though. 

leosgonewild
Top 50 Contributor
Helsinki, Finland
1,833 Posts
OFFLINE
Bronze Member
MacBook Air don’t have optical. Most MacBook pros have it built into the mini jack. Big Smile
elephant
Top 10 Contributor
AU
8,215 Posts
OFFLINE
Founder
Renesigk:

That was actually a good idea. Will see if I can find something with optical to connect. Don´t think I have optical in my Macbook though.

Would buying a google audio ChromeCast as a test unit work ?????

BeoNut since '75

leosgonewild
Top 50 Contributor
Helsinki, Finland
1,833 Posts
OFFLINE
Bronze Member
That will work. It has optical out.
Renesigk
Not Ranked
6 Posts
OFFLINE
Bronze Member

Found out my PS4 Pro has digital out. Connected it, changed sound setting to digital out. Result: The buzz as ealier.

leosgonewild
Top 50 Contributor
Helsinki, Finland
1,833 Posts
OFFLINE
Bronze Member
Try changing the output settings on the PS4.
leosgonewild
Top 50 Contributor
Helsinki, Finland
1,833 Posts
OFFLINE
Bronze Member
Never mind, the problem is with the Core.
leosgonewild
Top 50 Contributor
Helsinki, Finland
1,833 Posts
OFFLINE
Bronze Member
Oh, and welcome to the group of beta-testers
davidr
Top 500 Contributor
Montréal
166 Posts
OFFLINE
Bronze Member
Suggested by elephant

From your description the optical input is not working, you've done a reasonable verification on the sources so I doubt it is that.

-Bad optical cable

-Optical input is not getting selected, not sure if it is auto sense or App based? If it is auto sense perhaps the shared analogue and optical input is not working properly.

-BS Core is defective.

Page 1 of 2 (18 items) 1 2 Next > | RSS
Beoworld Security Certificate

SSL