Sign in   |  Join   |  Help

Beolab 8000 problem - Newbie here!

rated by 0 users
Not Answered This post has 0 verified answers | 7 Replies | 0 Followers

appear
Not Ranked
11 Posts
OFFLINE
Bronze Member
appear posted on Sun, Nov 11 2012 10:57 PM

Hi 

Once many years ago I was a member of this fine forum and my B&O passion ended up costing me way too much. Another hobby got in the way and I am happy to report my trusty B&O gear has been playing without a hitch for 8 years... until about a month ago!

I have a set of first generation BL8000 speakers. They don't really sound that good, but good enough for dinner music and radio. The other night some old friends came by......... and the next morning one of the speakers sounded horrible. I assumed that it was the bass woofers that were 'blown' (for lack of better word) - the distorted sound comes form that speaker however today I attempted to swap the bass units from the other speakers (that sounds just fine) and those units sounded exactly the same in the 'bad' speaker - very distorted in all 'bass' situations. 

Inside the speaker the foam has deteriorated so I had to remove it - what a weird sticky substance. Some of it was resting on the (bronze) tech-module below the lower speaker.

So, the question is. If it's not the bass woofers that makes the bass sound like a 'bown' speaker what can it be? The 'funny' part it is that it sounds just fine in the midtone and treble.

 

Is it worth repairing or cheaper/easier to replace the entire speaker with another used oldie?

Sorry about the very non-technical explanation, hoping someone can provide some insight.  

 

Thanks! 

All Replies

9 LEE
Top 10 Contributor
Eastbourne, UK
7,150 Posts
OFFLINE
Founder
Moderator
9 LEE replied on Sun, Nov 11 2012 11:10 PM

Push the bass drivers inwards from the very centre, and very straight. If they make a scratching sound, they're blown and need replacing.

It may be that you've replaced a blown driver with another blown driver?

In my experience, the amp almost seems too powerful for the drivers - and quite a few get nuked this way. Tweeters also tend to get the same treatment..

It may indeed be the fact that a crossover or amplifier on one speaker has 'retired from active service' so to speak - but this is much rarer than a driver going wrong.

A bit of an obtuse reply, sorry - but it's the truth! Smile

Lee

appear
Not Ranked
11 Posts
OFFLINE
Bronze Member
appear replied on Sun, Nov 11 2012 11:21 PM

Hi 9Lee 

 

First of all thanks for the quick reply.

All the drivers makes no sounds at all when I press them in the center to the very limit of how far back they can move. I did it 4-5 times rapidly in a row on each speaker.

So it seems like a sick active-component or crossover. 

I have a radio specialist nearly is it something they could fix by identifying a tired resistor or would it make better sense to replace the entire logic board or speaker itself?

9 LEE
Top 10 Contributor
Eastbourne, UK
7,150 Posts
OFFLINE
Founder
Moderator
9 LEE replied on Sun, Nov 11 2012 11:29 PM

If the drivers are moving freely then I'd say it's almost certainly component related, at which point I will step aside and let a member with electronics knowledge come forward.  I spoke only from experience of many pairs with blown drivers, of which almost all make a scratching sound when you depress the centre of the cone.

My own guys in the warehouse at LifeStyle AV often use one of those mystical 'volt meters' to measure resistance to see if a component is blown/faulty, but that's out of my comfort zone! 

I'm sure someone will pop up with a correct answer. SOrry I couldn't be more help..

Lee

appear
Not Ranked
11 Posts
OFFLINE
Bronze Member
appear replied on Mon, Nov 12 2012 12:27 AM

You have been a great help! I have contacted my local radio shop which I am sure have a fancy device to check the old speaker. Hopefully they can find the faulty resistors and bring the old pipes back to life :) Thanks!

Søren Mexico
Top 10 Contributor
Mexico City
6,387 Posts
OFFLINE
Bronze Member

appear:

You have been a great help! I have contacted my local radio shop which I am sure have a fancy device to check the old speaker. Hopefully they can find the faulty resistors and bring the old pipes back to life :) Thanks!

Just a suggestion, sign up as silver or gold member and download the service manual, it will be a great help for the tech. in the shop.

 

Collecting Vintage B&O is not a hobby, its a lifestyle.

ipaul
Top 200 Contributor
422 Posts
OFFLINE
Founder
ipaul replied on Mon, Nov 12 2012 9:27 PM

Well, by swapping the woofers you already determined that these are ok, right ?

Then, if high is fine (which comes from the same STK module), the power is also ok.

So, left over is probably one 'half' of the STK module blown (probably the neg or pos side not working), otherwise it's the filter before the amp but not so likely.

Just today i was working on one, and indeed that rotten foam junk is the biggest pain....

Anyway, Leslie (NL) seems to have 4 amp modules left, i need one for that same STK module, maybe you can get one too :)

lscangus
Not Ranked
2 Posts
OFFLINE
Bronze Member

You can order some new damping materials from your local B&O shop. about 10 Pounds.

If your friend at your local radio shop manage to diagnose the problem. You can always contact your local B&O shop for parts.

I have ordered many parts for my pair of Beolab 8000, new tweeter, woofer, and many different parts and the staff has been extremely helpful..

Page 1 of 1 (8 items) | RSS
Beoworld Security Certificate

SSL