Sign in   |  Join   |  Help
Click here to change your Beoworld Account Details

Tacky casing finish over time

rated by 0 users
Not Answered This post has 0 verified answers | 2 Replies | 0 Followers

chickenceo
Not Ranked
16 Posts
OFFLINE
Bronze Member
chickenceo posted on Wed, Jul 11 2018 7:02 AM

Given the humid and hot weather here. My B&O casing black finish is turning tacky again. It happened to my beocenter 2, Beolab 3 (grey casing, replaced by white), Beolab 2 (speakers replaced), Beolab 10 and even my beo-phone dome charging base.

I have always love the design of B&O and have always want a Beolab 5. However, given the degrading of the environmental finish, I have the feeling that the neck portion of the lab 5 will have the same issue. But how about Beolab 9? It seems to me there is no such finishing on the Beolab 9.

Any thoughts?

Cheers

Wayne

BL8000, BL10, BL4000, BL2, BL3 (Idle), Beocentre 2, Pioneer LX83 amp, Pioneer plasma TV

All Replies

Hiort
Top 50 Contributor
Sweden
1,970 Posts
OFFLINE
Bronze Member
Hiort replied on Wed, Jul 11 2018 7:07 AM
chickenceo:

Given the humid and hot weather here. My B&O casing black finish is turning tacky again. It happened to my beocenter 2, Beolab 3 (grey casing, replaced by white), Beolab 2 (speakers replaced), Beolab 10 and even my beo-phone dome charging base.

I have always love the design of B&O and have always want a Beolab 5. However, given the degrading of the environmental finish, I have the feeling that the neck portion of the lab 5 will have the same issue. But how about Beolab 9? It seems to me there is no such finishing on the Beolab 3.

Any thoughts?

Cheers

Wayne

I have read about occasions when the rubbery finish have turned “sticky”. Happened to my Beocom 2 base also. But another base I have still looks fine. No problem with my BL3s.

 

chickenceo
Not Ranked
16 Posts
OFFLINE
Bronze Member

Sorry my mistake, I was asking for the Beolab 9. My lab 3 grey casing turn tacky too, but am ok now after I changed them to a white case. The speaker cover are all fine with my lab 3, but not with lab 2 : (

BL8000, BL10, BL4000, BL2, BL3 (Idle), Beocentre 2, Pioneer LX83 amp, Pioneer plasma TV

Page 1 of 1 (3 items) | RSS
Beoworld Security Certificate

SSL