Sign in   |  Join   |  Help

H8 and E8 disconnect from Skype

rated by 0 users
Not Answered This post has 0 verified answers | 23 Replies | 1 Follower

ianpugh
Not Ranked
42 Posts
OFFLINE
Bronze Member
ianpugh posted on Tue, Jan 9 2018 1:02 PM

Hello,

I have tried using my E8's and H8's with Skype for Business on my Windows laptop. Every single time they disconnect after a certain time. This happens even when I am speaking so it not because there is no activity.

There aren't any power-saving settings that I can find. Does anyone have any ideas?

Kind regards,

Ian

All Replies

Keith Saunders
Top 25 Contributor
Little Ann, Hampshire, United Kingdom
5,164 Posts
OFFLINE
Founder
Moderator

You appear to be saying that both the E8 and the H8 have the same problem when using SkyPE. Is that correct?

When using the E8's do you use BOTH ear pieces for SkyPE'ing? If you use only one, are you using the right one?

Does it disconnect when using the E8's for anything other than SkyPE?

Regards Keith....

ianpugh
Not Ranked
42 Posts
OFFLINE
Bronze Member

Hi Keith,

Yes that's correct. Both disconnect and I use both earpieces. I use both extensively for music listening on the same laptop and have never had any disconnection while listening.

It may be a Skype/Windows issue as most things usually are!

Kind regards,

Ian

Earle
Top 500 Contributor
191 Posts
OFFLINE
Bronze Member
Earle replied on Tue, Jan 9 2018 5:00 PM

Not hijacking the thread, but I also experience this with WebEx on my work computer. Seems to only happen when audio is switched to Headset (BeoPlay H8 Hands Free) and not when it's Headphones (BeoPlay H8 Stereo)

Although, I will say, that when I have Spotify playing at low level in the background, it resolves the disconnect issue.

andrenb
Not Ranked
8 Posts
OFFLINE
Bronze Member
andrenb replied on Mon, Feb 12 2018 10:21 PM

My E8 has the same behavior with Skype for business so I contacted B&O support who said they were looking in to the case and sent my information through to a technician. This was two weeks ago, I haven't heard back since.

I'm contemplating buying the H9i and I'm wondering if anyone here owns a pair and have tried them with Skype and if the same problem persists, that it turns off after 15 minutes when the headset bluetooth profile is active and in use on the computer.

andrenb
Not Ranked
8 Posts
OFFLINE
Bronze Member

To answer myself, the H9i has the same problem with turning off after 15 minutes when used with Skype for business. I contacted B&O support about this too and hopefully they'll be able to fix this in a future firmware update but they have yet to get back to me.

rsilvestri
Not Ranked
1 Posts
OFFLINE
Bronze Member

Hi all,

I also face exact same behaviour. exactly 15 minutes after the call started the device disconnects automatically. This happens with H8 as well as with H5.

Thanks for any hint how this can be solved.

Regards,

Ruedi

ianpugh
Not Ranked
42 Posts
OFFLINE
Bronze Member

Hi,

 

Update - got a pair of H9i's and they no longer disconnect after a time. I have discovered that loading or refreshing a page in Chrome while using the headphones with Skype for Business caused dropout for about 3 seconds. 

I have the latest version of Chrome and drivers for my laptop. I can replicate the problem so it's definitely there. Doesn't happen with Edge browser. 

On another note the microphone on my H9i's does not work at all when used in a call via Slack (workplace messaging app). 

Many thanks,

Ian

andrenb
Not Ranked
8 Posts
OFFLINE
Bronze Member

Can anyone confirm if the E8's now work with Skype for business on Windows 10 and doesn't disconnect after 15 minutes of use anymore? I ended up returning mine as there never came a fix for this within the return period while i owned them.

ianpugh
Not Ranked
42 Posts
OFFLINE
Bronze Member

Hi,

I had the same same issue with my H9's as I did with my E8's. I upgraded to H9i and the problem went away. I am going to try the E8's tomorrow in a 1.5 hour conference call and see if that has got better too. I'll let you know. 

I do know that the E8's have got better with Slack and everything else in general so i expect they'll be better with Skype too. What I did notice that if I had Chrome running and changed page during a Skype call it would drop connection for 5-10 seconds every time.  If you're using Windows too that might have been your problem.

Thanks for reminding me and I'll post tomorrow after my call.

Cheers,

ian  

ianpugh
Not Ranked
42 Posts
OFFLINE
Bronze Member

Hi,

My H9i's now work fine with Slack whereas the H9 never worked at all. 

Cheers,

Ian

andrenb
Not Ranked
8 Posts
OFFLINE
Bronze Member

 

Thank you, I appreciate you testing this out as I really would love to buy another pair of E8's if they also work with Skype for business!

Great to hear that the H9i's also work properly now with the headset-profile on computers.

ianpugh
Not Ranked
42 Posts
OFFLINE
Bronze Member
ianpugh replied on Thu, Jul 12 2018 10:15 PM

Hi again,

yes they worked fine for the whole 1.25 hour call but.i was careful not to use Chrome during that time as that could cause disconnects in the past. 

id recommend giving them a try as you can always send them back if they dint work with your setup. 

All the best,

Ian

andrenb
Not Ranked
8 Posts
OFFLINE
Bronze Member
andrenb replied on Fri, Jul 13 2018 12:14 AM

 

Lovely, I'll pick up a set at my local Electronics store. They have 50 days open return policy so if I'm not happy I can return them.

Thank you so much for the follow-up and test! Big Smile

andrenb
Not Ranked
8 Posts
OFFLINE
Bronze Member
andrenb replied on Fri, Jul 13 2018 12:15 AM

*double post*

Page 1 of 2 (24 items) 1 2 Next > | RSS
Beoworld Security Certificate

SSL