Sign in   |  Join   |  Help
Click here to change your Beoworld Account Details

Beoplay E8 Bluetooth issues

rated by 0 users
Answered (Not Verified) This post has 0 verified answers | 39 Replies | 3 Followers

Cardinalsong
Not Ranked
Melbourne, Au
22 Posts
OFFLINE
Bronze Member
Cardinalsong posted on Wed, Oct 11 2017 7:59 AM

Hi everyone,

Trying to work out if I’ve got bad luck or others are experiencing the same issues I am.

Picked up a brand new pair of E8 from my dealer that received their first delivery today. After charging them fully I took them for a spin. Noticed immediately the left hand bud would intermittently dip audio for half a second every 30sec or so.

took them for a walk and had continuous, sustained drop outs in both ears every few seconds, then fine for maybe 30sec, then more drop outs.

if anyone lived through the H8 launch in 2015, this feels very, very similar. I’m heartbroken as I really wanted the convenience of wireless buds, but the connectivity is atrocious.

using them with an iPhone 7 and an iPad Pro 10.5” left ear bud drop out in both, full dropping on the 7 only, especially when walking with the phone in my pocket. 

have attempted re-pairing and software updates, no success. 

All Replies

bloodscalper
Not Ranked
3 Posts
OFFLINE
Bronze Member

So far all my truly wireless buds (X1T, Bragi Headphones & Dash Pro, Beoplay E8) have a lag problem while using my Android (Samsung S8) phone. It's not really a pain but certainly noticeable. No problems while using them with iOS (Iphone SE). It's highly likely Apple's iOS is properly and successfully syncing the audio while playing videos.

bloodscalper
Not Ranked
3 Posts
OFFLINE
Bronze Member

Yup, same issue I have regarding finicky Bluetooth connections. Frequent dropouts while just turning my head to cross the road while phone is in my front right pocket. Gets worse when a light gust of wind blows my way. For each time the left bud 'pops' and loses connection for 1-2 secs, the music will then shift from center to the left. I needed to pause music, wait for 1-2 secs and resume to 'adjust' the sound back to center. These buds are strictly for indoor use only, coupled with your phone lying just next to you, and you best not make sudden movements or jerk away from your seat else you get another drop out.

But oy, the sound man....really makes it hard to return/refund them after sampling their sound for a few days. Just like being caught between a rock and a hard place.

 

harnham
Not Ranked
1 Posts
OFFLINE
Bronze Member

I've had the problem with the left earpiece on TWO sets now (first set replaced).  Never any problem with the right.  Both times I've updated the firmware to 5.4.0 but hasn't fixed the issue.  Just to clarify, I don't believe this is an issue with Bluetooth as such, but the way B&O transmit the signal to the left (slave) earpiece from the right (master).

bloodscalper
Not Ranked
3 Posts
OFFLINE
Bronze Member

I agree. I've also updated to 5.4 version yet to no avail. Both E8 & Bragi's buds use NFMI so how is it that the Dash Pro and Headphones have a much more solid connection compared to the E8? I think it's confirmed that my unit isn't the prob but rather the shoddy QC by B&O. Face it, the E8s suck no matter how much I love the sound.

adao
Not Ranked
2 Posts
OFFLINE
Bronze Member
adao replied on Wed, Jan 10 2018 11:03 PM

Does anyone have any fixes yet for this issue?

I unpaired and repaired my E8's which I thought it actually fixed it in the morning. But when i used it again on the commute home it was just dropping out again.

 

I'm gonna try contact B&O and the store i purchased from but not sure what they can do :( otherwise may have to return them

Submariner1
Not Ranked
2 Posts
OFFLINE
Bronze Member

Hello.I have been using these earphones for a couple of weeks,and i am happy with the sound quality,but not with the bluetooth conection.For some reason,if i turn my head to my left,i loose coonection,but when i face forward again,they connect.This is very annoying.Has anyone else had this problem.Thanks,Jihn.

EL1
Not Ranked
3 Posts
OFFLINE
Bronze Member
EL1 replied on Tue, Jan 23 2018 2:49 PM

I just purchased my E8 pair over the holidays and have had multiple dropout problems between the two earpieces along with intermittent iPhone App connection issues (using my iPhone X). 😡🤬 Dropouts seem less frequent when streaming sound from my MacBook Pro. Firmware has been updated to v5.4, and the dropouts persist, however inconsistently.

Even worse, there is a noticeable lag time when watching video with spoken audio on the iPhone X. 😫Not as much on the MacBook Pro. I've read a similar issue somewhere on this forum and someone's response explaining the stronger Bluetooth signal on a MacBook. The technical explanation made sense of the discrepancy between devices, but did not help justify the problem, considering the investment.

Sound quality is good, but I'm obviously disappointed over the overall wireless quality so far. Just unacceptable for a $299 pair of earphones.

I'm honestly considering sending these back to Amazon and just settling for the Apple EarPods. Sound is subpar on Apple's, but at least they have solid, redundant wireless connectivity.

🤬😫

Submariner1
Not Ranked
2 Posts
OFFLINE
Bronze Member

I have same priblem.If my phone is in my left pocket and i turn my head to my right,the sound starts to cut out.Its a shame because they sound great when working properly.

adao
Not Ranked
2 Posts
OFFLINE
Bronze Member
adao replied on Wed, Feb 21 2018 9:24 AM

I ended up getting my pair exchanged by the store that i bought them from. They were very accommodating regarding the issue and sent me a new pair by next day delivery.

This pair i've had little to no issues regarding the left ear dropping out and thus its been good so far. 

So far so good

therblack
Not Ranked
2 Posts
OFFLINE
Bronze Member

Hi everyone

 

My issues don't seem as bad as others on this thread, but they are there. At least once a minute or so there is a short gap (one or both sides lose sound) or a fraction or a second. Not much, sure, but annoying.

 

I'm using a Pixel 2 XL

 

I was wanting to see if this is normal, or if people do actually have continuous connections. That is, should I return or exchange...

 

Thanks

Page 3 of 3 (40 items) < Previous 1 2 3 | RSS
Beoworld Security Certificate

SSL