Sign in   |  Join   |  Help

Beosound 8 repair

rated by 0 users
Not Answered This post has 0 verified answers | 17 Replies | 3 Followers

BeoIce
Top 150 Contributor
Recklinghausen, Germany
750 Posts
OFFLINE
Bronze Member
BeoIce posted on Sun, Dec 18 2016 10:57 PM

Got a Beosound 8 in perfect condition. Only problem is that it will not power on at all.

Already checked the fuse inside, but it's ok.

What can I check next ?

Is there anybody who has every repaired a Beosound 8 successfully without changing the complete main board 999 ?

 

Martin

BeoSound 9000 MK3, BeoLab 8000, BeoLab 6000, BeoLab 3500, LCS9000, BeoLab 11, BeoLab 7.2, BeoLab 7.1, Beolab 4 PC, BeoCenter 2300, BeoSound Century, BeoSound 8, Beosound 2, BeoVision 7-40 MK2 , BeoVision 7-32 MK3, BeoVision 6-22, BeoVision 4-42, BeoMedia 1, BeoCom 4, BeoLink 1000, BeoLink 5, BeoLink 4 & BeoTime

All Replies

marexy
Top 150 Contributor
Slovenia
561 Posts
OFFLINE
Silver Member
marexy replied on Mon, Dec 2 2019 10:39 AM

Hi

I have BS8 ...it is workig..but!

When i charge or play iphone4S orange there is orange LED on BS8.

Must be green ?

Docking part plastic is not 100% ok..do you think it's that problem ?

Anyone have that part for sell ?

Thannks

 

Peter the Biker
Top 100 Contributor
Eastwestfalia
867 Posts
OFFLINE
Gold Member
Did you check the 30pin socket of your iPhone for collected dust particles inside? They like to block the contacts. A toothpick may be your helper.

Peter the biker

marexy
Top 150 Contributor
Slovenia
561 Posts
OFFLINE
Silver Member
marexy replied on Wed, Dec 4 2019 11:41 AM

Hi

yp...i did..in the Beoplay 8 is working perfectly fine.

It's 30 pin connector on BS8 that is faulty an no longer at the B&O in stock.

at least i receive that info..

Page 2 of 2 (18 items) < Previous 1 2 | RSS
Beoworld Security Certificate

SSL