Sign in   |  Join   |  Help
Click here to change your Beoworld Account Details

Beogram 1700

rated by 0 users
Not Answered This post has 0 verified answers | 4 Replies | 1 Follower

madskp
Top 500 Contributor
Denmark
213 Posts
OFFLINE
Gold Member
madskp posted on Sun, Jan 10 2016 11:02 AM

A friend of mine has a Begram 1700 that i starting to act a little weird.

Sometimes it will not start when the 33 button is pressed, but then it helps to push pause first and then 33.

Another thing is that it tends so spin to fast on 33. This can often be solved by pressing 45 and then back to 33.

I found these two threads that could indicate that the latter one is a belt issue, but in one of the threads it sound like it didn't solve it.

http://forum.beoworld.org/forums/p/2081/17970.aspx#17970 

http://forum.beoworld.org/forums/p/1586/13662.aspx#13662

I just want to hear if there is any good advise before opening it up? 

Also if it is the belt how much do you need two remove to change it? Can you just remove the platter? I can't quite figure it out from the exploded view in the service manual.

Thanks in advance

 

 

All Replies

Dillen
Top 10 Contributor
Copenhagen / Denmark
10,587 Posts
OFFLINE
Founder
Moderator
Dillen replied on Sun, Jan 10 2016 4:50 PM

Just lift off the platter.
It lifts straight off.

Martin

madskp
Top 500 Contributor
Denmark
213 Posts
OFFLINE
Gold Member
madskp replied on Sun, Jan 10 2016 8:07 PM

Thanks for the answer. Where do I get a belt if he want's to try to change it? I am located in Denmark.

Dillen
Top 10 Contributor
Copenhagen / Denmark
10,587 Posts
OFFLINE
Founder
Moderator
Dillen replied on Sun, Jan 10 2016 8:20 PM

I can supply a correct belt.
PM / email me.

Martin

madskp
Top 500 Contributor
Denmark
213 Posts
OFFLINE
Gold Member

We now have changed the belt, but the Beogram will still not start when the 33 button is pressed. Any ideas to if there is a fix for that?

Thanks in advance

Page 1 of 1 (5 items) | RSS
Beoworld Security Certificate

SSL